[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-10 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Summary: Refactoring timeline classes to remove "app" related words  (was: 
Removing ATS Prefix of ATS* POJO Classes)

> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
>




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)


[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-10 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Description: Remove ATS prefix, change package name, fix javadoc and so on

> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
>
> Remove ATS prefix, change package name, fix javadoc and so on



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)


[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-11 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Attachment: YARN-1687.1.patch

Created a patch that refactors the timeline module: class names, package names, 
javadoc, variable names, configuration names, webservices paths.

> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
> Attachments: YARN-1687.1.patch
>
>
> Remove ATS prefix, change package name, fix javadoc and so on



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)


[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-20 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Attachment: YARN-1687+YARN-1732.1.patch

Submit a combined patch of YARN-1687 and YARN-1732 for jenkins to verify

> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
> Attachments: YARN-1687+YARN-1732.1.patch, YARN-1687.1.patch, 
> YARN-1687.2.patch
>
>
> Remove ATS prefix, change package name, fix javadoc and so on



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)


[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-20 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Attachment: YARN-1687.2.patch

Create a new patch that rebases against the latest trunk, and on top of patch 
YARN-1732. It includes the following changes:

* Move all timeline related code to the package that ends with ".timeline";
* Remove ATS prefix for ATSXXX classes;
* Change class name XXXApplicationTimeline to XXXTimeline;
* Fix the javadoc to say "timeline service" instead of "application timeline 
service";
* Remove ats prefix for the local variables in a number of classes;
* Change entity in Timeline#getEntity params to entityId to be distinguished 
from entity POJO instance;
* Change the timeline related configuration name to start with 
"timeline."/TIMELINE_, and also fix the default configuration values;
* Change the root path of timeline service to "timeline" as well.


> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
> Attachments: YARN-1687+YARN-1732.1.patch, YARN-1687.1.patch, 
> YARN-1687.2.patch
>
>
> Remove ATS prefix, change package name, fix javadoc and so on



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)


[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-21 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Attachment: YARN-1687.3.patch

Vinod, thanks for your comments.

bq. We should rename PutErrors to be PutResponse.

Done, and change some the name of some local variables of this class as well.

bq. TIMELINE_PREFIX -> TIMELINE_SERVICE_PREFIX

Done

bq. yarn.ats -> yarn.timeline-service.
bq. yarn.ats.store.class -> yarn.timeline-service.store-class

Done

bq. What about the module applicationhistoryservice rename?

Yes, we should definitely do that. However, let's keep the scope of this patch 
in refactoring timeline service code. YARN-1744 is tracing module renaming.

bq. TimelineClient#postEntities->putEntities

Done

> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
> Attachments: YARN-1687+YARN-1732.1.patch, 
> YARN-1687+YARN-1732.2.patch, YARN-1687.1.patch, YARN-1687.2.patch, 
> YARN-1687.3.patch
>
>
> Remove ATS prefix, change package name, fix javadoc and so on



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)


[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-21 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Attachment: YARN-1687+YARN-1732.2.patch

Again, upload a combined patch for jenkins.

> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
> Attachments: YARN-1687+YARN-1732.1.patch, 
> YARN-1687+YARN-1732.2.patch, YARN-1687.1.patch, YARN-1687.2.patch, 
> YARN-1687.3.patch
>
>
> Remove ATS prefix, change package name, fix javadoc and so on



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)


[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-21 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Attachment: YARN-1687+YARN-1732.3.patch

> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
> Attachments: YARN-1687+YARN-1732.1.patch, 
> YARN-1687+YARN-1732.2.patch, YARN-1687+YARN-1732.3.patch, YARN-1687.1.patch, 
> YARN-1687.2.patch, YARN-1687.3.patch, YARN-1687.4.patch
>
>
> Remove ATS prefix, change package name, fix javadoc and so on



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)


[jira] [Updated] (YARN-1687) Refactoring timeline classes to remove "app" related words

2014-02-21 Thread Zhijie Shen (JIRA)

 [ 
https://issues.apache.org/jira/browse/YARN-1687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zhijie Shen updated YARN-1687:
--

Attachment: YARN-1687.4.patch

Thanks for the help from Vinod. I uploaded a new patch which changes POJO 
classes to have Timeline prefix.

> Refactoring timeline classes to remove "app" related words
> --
>
> Key: YARN-1687
> URL: https://issues.apache.org/jira/browse/YARN-1687
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Zhijie Shen
>Assignee: Zhijie Shen
> Attachments: YARN-1687+YARN-1732.1.patch, 
> YARN-1687+YARN-1732.2.patch, YARN-1687+YARN-1732.3.patch, YARN-1687.1.patch, 
> YARN-1687.2.patch, YARN-1687.3.patch, YARN-1687.4.patch
>
>
> Remove ATS prefix, change package name, fix javadoc and so on



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)