[jira] Commented: (ZOOKEEPER-112) src/java/main ZooKeeper.java has test code embedded into it.

2008-09-04 Thread Benjamin Reed (JIRA)

[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-112?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12628352#action_12628352
 ] 

Benjamin Reed commented on ZOOKEEPER-112:
-

+1 I do have some nits: I don't really like the name ZooKeeperStub, since stub 
usually refers to a non functional implementation. ZooKeeperStub is fully 
functional but also allows disconnection. Perhaps DisconnectableZooKeeper 
maybe? You trade having disconnect on ZooKeeper with making ClientCnxn public, 
which also pollutes the public API. Perhaps ZooKeeperStub should go into 
src/java/test/org/apache/zookeeper/ZooKeeperStub. That way you get package 
visibility for ClientCnxn, but you still keep ZooKeeperStub out of the main 
tree.

Both are just nits, and I support committing the change if you don't want to 
fix it.

 src/java/main ZooKeeper.java has test code embedded into it.
 

 Key: ZOOKEEPER-112
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-112
 Project: Zookeeper
  Issue Type: Bug
  Components: tests
Reporter: Patrick Hunt
Assignee: Patrick Hunt
 Fix For: 3.0.0

 Attachments: ZOOKEEPER-112.patch, ZOOKEEPER-112.patch


 src/java/main ZooKeeper.java has a method public void disconnect() that is 
 not part of the public api but put there for testing purposes (to test 
 disconnection of the client from the server w/o actually shutting down the 
 session)
 This method needs to be moved out of the public api. preferably we should 
 have a subclass in the test code itself that provides this method.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Commented: (ZOOKEEPER-133) hudson tests failing intermittently

2008-09-04 Thread Benjamin Reed (JIRA)

[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-133?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12628361#action_12628361
 ] 

Benjamin Reed commented on ZOOKEEPER-133:
-

I'm thrown by:

 
+// small chance that is hasn't been delivered yet, ignore
+assertEquals(0, watchers[i].events.size());

Why would we ignore? If size  0, it means that we got an event we weren't 
expecting right? The check looks correct, but the comment looks wrong. 



 hudson tests failing intermittently
 ---

 Key: ZOOKEEPER-133
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-133
 Project: Zookeeper
  Issue Type: Bug
  Components: tests
Affects Versions: 3.0.0
Reporter: Patrick Hunt
Assignee: Patrick Hunt
 Fix For: 3.0.0

 Attachments: ZOOKEEPER-133.patch


 There is a bug in the ClientTest.java unit test, timing issue in 
 withWatcherObj test. Patch forthcoming.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Commented: (ZOOKEEPER-134) findbugs cleanup

2008-09-04 Thread Benjamin Reed (JIRA)

[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-134?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12628362#action_12628362
 ] 

Benjamin Reed commented on ZOOKEEPER-134:
-

+1 ready to commit

 findbugs cleanup
 

 Key: ZOOKEEPER-134
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-134
 Project: Zookeeper
  Issue Type: Improvement
Affects Versions: 3.0.0
Reporter: Patrick Hunt
Assignee: Patrick Hunt
 Fix For: 3.0.0

 Attachments: ZOOKEEPER-134.patch


 cleaned up a number of findbugs warnings, in particular:
 1) added @overrides appropriately
 2) import cleanups
 3) log or document many empty blocks
 4) resource cleanup (usually by adding finally blocks)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Updated: (ZOOKEEPER-135) Fat jar build target

2008-09-04 Thread Benjamin Reed (JIRA)

 [ 
https://issues.apache.org/jira/browse/ZOOKEEPER-135?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Benjamin Reed updated ZOOKEEPER-135:


Attachment: ZOOKEEPER-135.patch

This patch modifies the build file to create an optional fat-jar target. This 
target will only be build if explicitly requested. The fat-jar will have 
everything in it. The MainClass is a simple redirector that uses a mainClasses 
file to execute the main() methods of other classes.

 Fat jar build target
 

 Key: ZOOKEEPER-135
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-135
 Project: Zookeeper
  Issue Type: New Feature
  Components: build
Reporter: Benjamin Reed
Priority: Minor
 Attachments: ZOOKEEPER-135.patch


 For testing and experimentation purposes it would be nice to have everything 
 in a self contained executable jar file that you can plop down on a machine 
 and run.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Updated: (ZOOKEEPER-134) findbugs cleanup

2008-09-04 Thread Benjamin Reed (JIRA)

 [ 
https://issues.apache.org/jira/browse/ZOOKEEPER-134?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Benjamin Reed updated ZOOKEEPER-134:


Hadoop Flags: [Reviewed]

 findbugs cleanup
 

 Key: ZOOKEEPER-134
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-134
 Project: Zookeeper
  Issue Type: Improvement
Affects Versions: 3.0.0
Reporter: Patrick Hunt
Assignee: Patrick Hunt
 Fix For: 3.0.0

 Attachments: ZOOKEEPER-134.patch


 cleaned up a number of findbugs warnings, in particular:
 1) added @overrides appropriately
 2) import cleanups
 3) log or document many empty blocks
 4) resource cleanup (usually by adding finally blocks)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Updated: (ZOOKEEPER-134) findbugs cleanup

2008-09-04 Thread Benjamin Reed (JIRA)

 [ 
https://issues.apache.org/jira/browse/ZOOKEEPER-134?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Benjamin Reed updated ZOOKEEPER-134:


Resolution: Fixed
Status: Resolved  (was: Patch Available)

Committed revision 692164.

 findbugs cleanup
 

 Key: ZOOKEEPER-134
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-134
 Project: Zookeeper
  Issue Type: Improvement
Affects Versions: 3.0.0
Reporter: Patrick Hunt
Assignee: Patrick Hunt
 Fix For: 3.0.0

 Attachments: ZOOKEEPER-134.patch


 cleaned up a number of findbugs warnings, in particular:
 1) added @overrides appropriately
 2) import cleanups
 3) log or document many empty blocks
 4) resource cleanup (usually by adding finally blocks)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Updated: (ZOOKEEPER-112) src/java/main ZooKeeper.java has test code embedded into it.

2008-09-04 Thread Patrick Hunt (JIRA)

 [ 
https://issues.apache.org/jira/browse/ZOOKEEPER-112?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Patrick Hunt updated ZOOKEEPER-112:
---

Attachment: ZOOKEEPER-112.patch

renamed zkstub per ben's suggestion

 src/java/main ZooKeeper.java has test code embedded into it.
 

 Key: ZOOKEEPER-112
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-112
 Project: Zookeeper
  Issue Type: Bug
  Components: tests
Reporter: Patrick Hunt
Assignee: Patrick Hunt
 Fix For: 3.0.0

 Attachments: ZOOKEEPER-112.patch, ZOOKEEPER-112.patch, 
 ZOOKEEPER-112.patch


 src/java/main ZooKeeper.java has a method public void disconnect() that is 
 not part of the public api but put there for testing purposes (to test 
 disconnection of the client from the server w/o actually shutting down the 
 session)
 This method needs to be moved out of the public api. preferably we should 
 have a subclass in the test code itself that provides this method.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Updated: (ZOOKEEPER-133) hudson tests failing intermittently

2008-09-04 Thread Patrick Hunt (JIRA)

 [ 
https://issues.apache.org/jira/browse/ZOOKEEPER-133?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Patrick Hunt updated ZOOKEEPER-133:
---

Attachment: ZOOKEEPER-133.patch

fixed the doc

 hudson tests failing intermittently
 ---

 Key: ZOOKEEPER-133
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-133
 Project: Zookeeper
  Issue Type: Bug
  Components: tests
Affects Versions: 3.0.0
Reporter: Patrick Hunt
Assignee: Patrick Hunt
 Fix For: 3.0.0

 Attachments: ZOOKEEPER-133.patch, ZOOKEEPER-133.patch


 There is a bug in the ClientTest.java unit test, timing issue in 
 withWatcherObj test. Patch forthcoming.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Updated: (ZOOKEEPER-128) test coverage on async client operations needs to be improved

2008-09-04 Thread Patrick Hunt (JIRA)

 [ 
https://issues.apache.org/jira/browse/ZOOKEEPER-128?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Patrick Hunt updated ZOOKEEPER-128:
---

Attachment: ZOOKEEPER-128.patch

Updated the patch to include more documentation. I didn't document the exact 
format of each subclasses expect string (tostring output) since it's really 
easy to determine by looking at the toString method, but I did document more 
about how the expected value is generated and pointed out that it's the result 
of toString.

 test coverage on async client operations needs to be improved
 -

 Key: ZOOKEEPER-128
 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-128
 Project: Zookeeper
  Issue Type: Improvement
  Components: java client
Reporter: Patrick Hunt
Assignee: Patrick Hunt
 Fix For: 3.0.0

 Attachments: ZOOKEEPER-128.patch, ZOOKEEPER-128.patch


 clover reports limited testing of the async client operations. need addition 
 tests to verify this functionality.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.