Re: [OpenJDK 2D-Dev] RFR(M): 8170525: Fix minor issues in awt coding

2016-11-30 Thread Semyon Sadetsky
yes, this is a potential issue. But actually cases MID,FOCUS,BLACK,WHITE are never used. But the fix is wrong. It should be color.alpha = 1; --Semyon On 01.12.2016 08:05, Prasanta Sadhukhan wrote: Also, in gtk3_interface.c, there is this change for color.alpha 2219 color.alpha = 0; in gtk3

Re: [OpenJDK 2D-Dev] RFR(M): 8170525: Fix minor issues in awt coding

2016-11-30 Thread Prasanta Sadhukhan
Also, in gtk3_interface.c, there is this change for color.alpha 2219 color.alpha = 0; in gtk3_get_color_for_flags() but it is used in gtk3_get_color_for_state() where it is not initialized 2268 GdkRGBA color; Regards Prasanta On 12/1/2016 1:28 AM, Phil Race wrote: Hi Goetz, DataBuffer

Re: [OpenJDK 2D-Dev] RFR(M): 8170525: Fix minor issues in awt coding

2016-11-30 Thread Phil Race
Hi Goetz, DataBufferNative.c Using uninitialized value lockInfo.rasBase when calling DBN_GetPixelPointer. 75 lockInfo.resBase = NULL; Did you actually compile this ? The variable is called "rasBase", not "resBase". And strictly there is no problem since inside DBN_GetPixelPointer

Re: [OpenJDK 2D-Dev] RFR(M): 8170525: Fix minor issues in awt coding

2016-11-30 Thread Langer, Christoph
Hi Goetz, I have some small remarks. src/java.desktop/unix/native/common/awt/fontpath.c: 247 fontDirPath[sizeof(fontDirPath)-1] = '\0'; -> you should add spaces left and right of '-' 248 strncat(fontDirPath, "/fonts.dir", sizeof(fontDirPath) - strlen(fontDirPath)); -> I

Re: [OpenJDK 2D-Dev] RFR(M): 8170525: Fix minor issues in awt coding

2016-11-30 Thread Sergey Bylokhov
cc 2d-dev. On 30.11.16 18:41, Lindenmaier, Goetz wrote: Hi Vincent, thanks for the quit review! Good catch that I lost the change to p11_mutex.c ... I had to change it and it fell out of my patches. I edited the Last Modified Date, and also updated the copyright messages. New webrev: http://cr.

Re: [OpenJDK 2D-Dev] [9] RFR JDK-8025439: [TEST BUG] [macosx] PrintServiceLookup.lookupPrintServices doesn't work properly since jdk8b105

2016-11-30 Thread Philip Race
+1 -phil. On 11/30/16, 2:19 AM, Prasanta Sadhukhan wrote: Please find the modifed the webrev as per review comments http://cr.openjdk.java.net/~psadhukhan/8025439/webrev.02/ Regards Prasanta On 11/30/2016 1:04 AM, Phil Race wrote: Leaving aside platform printer naming conventions and the like,

Re: [OpenJDK 2D-Dev] [9] RFR JDK-8025439: [TEST BUG] [macosx] PrintServiceLookup.lookupPrintServices doesn't work properly since jdk8b105

2016-11-30 Thread Prasanta Sadhukhan
Please find the modifed the webrev as per review comments http://cr.openjdk.java.net/~psadhukhan/8025439/webrev.02/ Regards Prasanta On 11/30/2016 1:04 AM, Phil Race wrote: Leaving aside platform printer naming conventions and the like, it seems that PrintService.getName() returns "Rich Aficio"