Re: [PATCH 1/8] drm/ttm: turn ttm_bo_device.vma_manager into a pointer

2019-09-08 Thread Christian König
Am 05.09.19 um 09:05 schrieb Gerd Hoffmann: Rename the embedded struct vma_offset_manager, new name is _vma_manager. ttm_bo_device.vma_manager changed to a pointer. The ttm_bo_device_init() function gets an additional vma_manager argument which allows to initialize ttm with a different vma manag

[PATCH] drm/amd/powerplay: Add the interface for geting dpm current power state

2019-09-08 Thread Liang, Prike
implement the sysfs power_dpm_state Signed-off-by: Prike Liang --- drivers/gpu/drm/amd/powerplay/renoir_ppt.c | 34 ++ 1 file changed, 34 insertions(+) diff --git a/drivers/gpu/drm/amd/powerplay/renoir_ppt.c b/drivers/gpu/drm/amd/powerplay/renoir_ppt.c index a5cf846

[PATCH] drm/amd/powerplay: Remove unnecessary comparison statement

2019-09-08 Thread Austin Kim
size contain non-negative value since it is declared as uint32_t. So below statement is always false. if (size < 0) Remove unnecessary comparison. Signed-off-by: Austin Kim --- drivers/gpu/drm/amd/powerplay/navi10_ppt.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/gpu/d

RE: [PATCH 3/3] drm/amdgpu: rename umc ras_init to ras_asic_init

2019-09-08 Thread Zhou1, Tao
umc.funcs->ras_late_init is common for all versions of umc, so it's implemented in amdgpu_umc.c, but ras_asic_init is specific to each version of umc and is placed in umc_vx_x.c. err_cnt_init is good for current implementation but may be not enough for the future, how about rename it to umc.func

RE: [PATCH 1/2] drm/amdgpu: initialize ras structures for xgmi block

2019-09-08 Thread Chen, Guchun
-Original Message- From: Zhang, Hawking Sent: Monday, September 9, 2019 6:07 AM To: amd-gfx@lists.freedesktop.org; Zhou1, Tao ; Chen, Guchun ; Li, Dennis ; Deucher, Alexander Cc: Zhang, Hawking Subject: [PATCH 1/2] drm/amdgpu: initialize ras structures for xgmi block init ras commo

Re: [PATCH] drm/amd/powerplay: do proper cleanups on hw_fini

2019-09-08 Thread Deucher, Alexander
We should probably also add the callbacks for set_mp1_state like we have for the older powerplay code so we properly send the SMU shutdown or reset message on GPU reset and driver unload. Alex From: amd-gfx on behalf of Quan, Evan Sent: Monday, September 2, 2

RE: [PATCH] radeon: add option so DVI always respect HPD over DDC

2019-09-08 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx On Behalf Of > Dave Airlie > Sent: Sunday, September 1, 2019 11:09 PM > To: amd-gfx@lists.freedesktop.org > Subject: [PATCH] radeon: add option so DVI always respect HPD over DDC > > From: Dave Airlie > > Purelink FX-D120 (DVI over fibre extendeders)

RE: [PATCH 3/3] drm/amdgpu: rename umc ras_init to ras_asic_init

2019-09-08 Thread Zhang, Hawking
Never mind. I was confused by the name "ras_asic_init". The programming sequence is exactly what we discussed before. I think we can rename this function to "err_cnt_init". Regards, Hawking -Original Message- From: amd-gfx On Behalf Of Zhang, Hawking Sent: 2019年9月9日 6:23 To: Zhou1, Tao

RE: [PATCH 3/3] drm/amdgpu: rename umc ras_init to ras_asic_init

2019-09-08 Thread Zhang, Hawking
The ras init (or the new asic_init) seems not necessary as last time we discussed. Any UMC RAS register initialization is safe enough to be centralized to ras_late_init interface. I would suggest to reduce such kind of un-necessary interface. Regards, Hawking -Original Message- From: Zh

[PATCH 1/2] drm/amdgpu: initialize ras structures for xgmi block

2019-09-08 Thread Zhang, Hawking
init ras common interface and fs node for xgmi block Signed-off-by: Hawking Zhang --- drivers/gpu/drm/amd/amdgpu/amdgpu_gmc.h | 1 + drivers/gpu/drm/amd/amdgpu/amdgpu_xgmi.c | 36 drivers/gpu/drm/amd/amdgpu/amdgpu_xgmi.h | 1 + drivers/gpu/drm/amd/amdgpu/gmc_v

[PATCH 2/2] drm/amdgpu: enable error injection to XGMI block via debugfs

2019-09-08 Thread Zhang, Hawking
allow inject error to XGMI block via debugfs node ras_ctrl Signed-off-by: Hawking Zhang --- drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_ras.c index d2437e1..9348864 100644

Re: gnome-shell stuck because of amdgpu driver [5.3 RC5]

2019-09-08 Thread Mikhail Gavrilov
On Thu, 5 Sep 2019 at 12:58, Daniel Vetter wrote: > > I think those fences are only emitted for CS, not display related. > Adding Christian König. More fresh kernel log with 5.3RC7 - the issue still happens. https://pastebin.com/tyxkWJYV -- Best Regards, Mike Gavrilov. On Thu, 5 Sep 2019 at 12

[PATCH] drm/radeon: Bail earlier when radeon.cik_/si_support=0 is passed

2019-09-08 Thread Hans de Goede
Bail from the pci_driver probe function instead of from the drm_driver load function. This avoid /dev/dri/card0 temporarily getting registered and then unregistered again, sending unwanted add / remove udev events to userspace. Specifically this avoids triggering the (userspace) bug fixed by this