[PATCH 0/1] Convert to using devm_drm_dev_alloc()

2020-09-03 Thread Luben Tuikov
This is based on top of Daniel's documentation patch and it applies cleanly onto amd-staging-drm-next. I'm also running this live. Luben Tuikov (1): drm/amdgpu: Convert to using devm_drm_dev_alloc() drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c | 11 +++ 1 file changed, 3 insertions(+), 8 de

[PATCH 1/1] drm/amdgpu: Convert to using devm_drm_dev_alloc()

2020-09-03 Thread Luben Tuikov
Convert to using devm_drm_dev_alloc(), as drm_dev_init() is going away. Signed-off-by: Luben Tuikov --- drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c | 11 +++ 1 file changed, 3 insertions(+), 8 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c b/drivers/gpu/drm/amd/amdgpu/am

[pull] amdgpu, amdkfd, radeon, scheduler drm-next-5.10

2020-09-03 Thread Alex Deucher
Hi Dave, Daniel, First batch of new stuff for 5.10. Forgot to mention in the tag, switch amdgpu from using drm_dev_alloc to drm_dev_init. Will need a follow up patch to switch to devm_drm_dev_alloc. The following changes since commit 922e7455bb6122696b0420172700ea2b4e2f5739: Revert "drm/amd/

[PATCH] drm/amdgpu: Fix L1 policy violations (PSP) on sienna cichlid SRIOV

2020-09-03 Thread Rohit Khaire
Signed-off-by: Rohit Khaire --- drivers/gpu/drm/amd/amdgpu/gfx_v10_0.c | 49 -- drivers/gpu/drm/amd/amdgpu/gfxhub_v2_1.c | 64 +++- drivers/gpu/drm/amd/amdgpu/mmhub_v2_0.c | 42 3 files changed, 95 insertions(+), 60 deletions(-) diff --git

[PATCH] drm/amdgpu: Fix L1 policy violations (PSP) on Navi21 SRIOV

2020-09-03 Thread Rohit Khaire
Signed-off-by: Rohit Khaire --- drivers/gpu/drm/amd/amdgpu/gfx_v10_0.c | 49 -- drivers/gpu/drm/amd/amdgpu/gfxhub_v2_1.c | 64 +++- drivers/gpu/drm/amd/amdgpu/mmhub_v2_0.c | 42 3 files changed, 95 insertions(+), 60 deletions(-) diff --git

[PATCH] drm/amdgpu/pm: Account for extra separator characters in sysfs interface

2020-09-03 Thread Matt Coffin
Currently, the the input to the pp_od_clk_voltage sysfs interface has two adjacent separator characters, i.e. "\n\0", then we try to parse an argument out of the empty string, whereas we really should just ignore this case, and treat any number of adjacent separators as one separator for arguments.

Re: [PATCH] drm/managed: Cleanup of unused functions and polishing docs

2020-09-03 Thread Luben Tuikov
On 2020-09-03 10:26 a.m., Daniel Vetter wrote: > On Wed, Sep 02, 2020 at 09:26:27AM +0200, Daniel Vetter wrote: >> Following functions are only used internally, not by drivers: >> - devm_drm_dev_init >> >> Also, now that we have a very slick and polished way to allocate a >> drm_device with devm_dr

Re: [PATCH 0/3] Use implicit kref infra

2020-09-03 Thread Luben Tuikov
On 2020-09-02 9:57 p.m., Pan, Xinhui wrote: > > >> 2020年9月2日 22:50,Tuikov, Luben 写道: >> >> On 2020-09-02 00:43, Pan, Xinhui wrote: >>> >>> 2020年9月2日 11:46,Tuikov, Luben 写道: On 2020-09-01 21:42, Pan, Xinhui wrote: > If you take a look at the below function, you should not use

Re: [PATCH] drm/amdgpu/gfx10: Delete some duplicated argument to '|'

2020-09-03 Thread Alex Deucher
Applied. Thanks! Alex On Thu, Sep 3, 2020 at 2:35 AM Huang Rui wrote: > > On Thu, Sep 03, 2020 at 10:17:56AM +0800, Ye Bin wrote: > > 1. gfx_v10_0_soft_reset GRBM_STATUS__SPI_BUSY_MASK > > 2. gfx_v10_0_update_gfx_clock_gating AMD_CG_SUPPORT_GFX_CGLS > > > > Signed-off-by: Ye Bin > > Reviewed-b

Re: [PATCH] drm/amdgpu: add ta firmware load in psp_v12_0 for renoir

2020-09-03 Thread Deucher, Alexander
Reviewed-by: Alex Deucher From: Zhu, Changfeng Sent: Thursday, September 3, 2020 11:19 AM To: Lakha, Bhawanpreet ; Deucher, Alexander ; amd-gfx@lists.freedesktop.org ; Huang, Ray Subject: RE: [PATCH] drm/amdgpu: add ta firmware load in psp_v12_0 for renoir [A

[RESEND] Requests For Proposals for hosting XDC2021 are now open

2020-09-03 Thread Lyude Paul
(Including a bunch more emails in the To: that got missed the first time) Hello everyone! The X.org board is soliciting proposals to host XDC in 2021. Since XDC2020 is being held virtually this year, we've decided to host in either North America or Europe. However, the board is open to other loca

[PATCH 5/6] drm/amdgpu: add user friendly xgmi events

2020-09-03 Thread Jonathan Kim
Non-outbound data is useless for throughput metrics. Add human readable events and note deprecated events. New events are now per-device and not per-device-per-ip. Signed-off-by: Jonathan Kim --- drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c | 38 + drivers/gpu/drm/amd/amdgpu

[PATCH 1/6] drm/amdgpu: stop resetting xgmi perfmons on disable

2020-09-03 Thread Jonathan Kim
Disabling perf events does not specify reset in ABI so stop doing it in hardware. Signed-off-by: Jonathan Kim --- drivers/gpu/drm/amd/amdgpu/amdgpu_df.h | 4 ++-- drivers/gpu/drm/amd/amdgpu/df_v3_6.c | 23 ++- 2 files changed, 16 insertions(+), 11 deletions(-) diff --git

[PATCH 2/6] drm/amdgpu: fix xgmi perfmon a-b-a problem

2020-09-03 Thread Jonathan Kim
Mapping hw counters per event config will cause ABA problems so map per event instead. Signed-off-by: Jonathan Kim --- drivers/gpu/drm/amd/amdgpu/amdgpu_df.h | 6 +- drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c | 23 -- drivers/gpu/drm/amd/amdgpu/df_v3_6.c| 104 +++- 3

[PATCH 3/6] drm/amdgpu: make df defines private and change counter report

2020-09-03 Thread Jonathan Kim
DF public defines should not be used outside of DF IP version so make them private. Also, users do not care about the number of available programmable hardware counters so report the number of events available instead. Signed-off-by: Jonathan Kim --- drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c | 8

[PATCH 6/6] drm/amdgpu: add xgmi perfmons for arcturus

2020-09-03 Thread Jonathan Kim
Add xgmi perfmons for Arcturus. Signed-off-by: Jonathan Kim --- drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c | 32 + drivers/gpu/drm/amd/amdgpu/df_v3_6.c| 3 +++ 2 files changed, 35 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c b/drivers/gpu/drm/amd

[PATCH 4/6] drm/amdgpu: cleanup pmu

2020-09-03 Thread Jonathan Kim
Switch from marcros to helper that builds events per chip. Also abstract IP events from version since they can bind to chip instead. Signed-off-by: Jonathan Kim --- drivers/gpu/drm/amd/amdgpu/amdgpu.h | 13 --- drivers/gpu/drm/amd/amdgpu/amdgpu_pmu.c | 108 +--- drivers/

Re: [PATCH v4 0/8] Implement PCI Error Recovery on Navi12

2020-09-03 Thread Deucher, Alexander
[AMD Official Use Only - Internal Distribution Only] I'll push an updated branch shortly. Alex From: Grodzovsky, Andrey Sent: Thursday, September 3, 2020 11:01 AM To: Bjorn Helgaas Cc: amd-gfx@lists.freedesktop.org ; sathyanarayanan.kuppusw...@linux.intel.com

Re: [PATCH v4 4/8] drm/amdgpu: Fix consecutive DPC recovery failures.

2020-09-03 Thread Andrey Grodzovsky
On 9/2/20 6:23 PM, Bjorn Helgaas wrote: On Wed, Sep 02, 2020 at 02:42:06PM -0400, Andrey Grodzovsky wrote: Cache the PCI state on boot and before each case where we might loose it. s/loose/lose/ v2: Add pci_restore_state while caching the PCI state to avoid breaking PCI core logic for stuff

Re: [PATCH v4 3/8] drm/amdgpu: Fix SMU error failure

2020-09-03 Thread Andrey Grodzovsky
On 9/2/20 6:05 PM, Bjorn Helgaas wrote: On Wed, Sep 02, 2020 at 02:42:05PM -0400, Andrey Grodzovsky wrote: Wait for HW/PSP initiated ASIC reset to complete before starting the recovery operations. v2: Remove typo Signed-off-by: Andrey Grodzovsky Reviewed-by: Alex Deucher --- drivers/gpu/

Re: [PATCH v4 1/8] drm/amdgpu: Avoid accessing HW when suspending SW state

2020-09-03 Thread Andrey Grodzovsky
On 9/2/20 5:56 PM, Bjorn Helgaas wrote: On Wed, Sep 02, 2020 at 02:42:03PM -0400, Andrey Grodzovsky wrote: At this point the ASIC is already post reset by the HW/PSP so the HW not in proper state to be configured for suspension, some blocks might be even gated and so best is to avoid touching i

RE: [PATCH] drm/amdgpu: add ta firmware load in psp_v12_0 for renoir

2020-09-03 Thread Zhu, Changfeng
[AMD Public Use] [AMD Public Use] Thanks, Lakha. BR, Changfeng. From: Lakha, Bhawanpreet Sent: Thursday, September 3, 2020 11:07 PM To: Deucher, Alexander ; Zhu, Changfeng ; amd-gfx@lists.freedesktop.org; Huang, Ray Subject: Re: [PATCH] drm/amdgpu: add ta firmware load in psp_v12_0 for re

Re: [PATCH] drm/amdgpu: add ta firmware load in psp_v12_0 for renoir

2020-09-03 Thread Lakha, Bhawanpreet
[AMD Public Use] Hi Alex, psp_sw_fini() releases the ta firmware Reviewed-by: Bhawanpreet Lakha From: Deucher, Alexander Sent: September 2, 2020 10:18 AM To: Zhu, Changfeng ; amd-gfx@lists.freedesktop.org ; Huang, Ray ; Lakha, Bhawanpreet Subject: Re

Re: [PATCH v4 0/8] Implement PCI Error Recovery on Navi12

2020-09-03 Thread Andrey Grodzovsky
This one is very close - https://cgit.freedesktop.org/~agd5f/linux/log/?h=amd-staging-drm-next Andrey On 9/2/20 8:41 PM, Bjorn Helgaas wrote: On Wed, Sep 02, 2020 at 11:43:41PM +, Grodzovsky, Andrey wrote: It's based on v5.9-rc2 but won't apply cleanly since there is a significant amount

Re: [PATCH] drm/managed: Cleanup of unused functions and polishing docs

2020-09-03 Thread Daniel Vetter
On Wed, Sep 02, 2020 at 09:26:27AM +0200, Daniel Vetter wrote: > Following functions are only used internally, not by drivers: > - devm_drm_dev_init > > Also, now that we have a very slick and polished way to allocate a > drm_device with devm_drm_dev_alloc, update all the docs to reflect the > new

Re: [PATCH 9/9] drm/amd/pm: make namings and comments more readable

2020-09-03 Thread Alex Deucher
On Wed, Sep 2, 2020 at 4:32 AM Evan Quan wrote: > > And to fit more accurately what the cod does. > > Change-Id: I2d917e66b55925c3a14aa96ac8e0c8c2110848c0 > Signed-off-by: Evan Quan Series is: Reviewed-by: Alex Deucher > --- > drivers/gpu/drm/amd/pm/swsmu/smu11/navi10_ppt.c | 8 > 1

Re: [PATCH] drm/amdgpu: fix max_entries calculation v4

2020-09-03 Thread Pan, Xinhui
Reviewed-by: xinhui pan > 2020年9月3日 17:03,Christian König 写道: > > Calculate the correct value for max_entries or we might run after the > page_address array. > > v2: Xinhui pointed out we don't need the shift > v3: use local copy of start and simplify some calculation > v4: fix the case that

[PATCH] drm/amdgpu: fix max_entries calculation v4

2020-09-03 Thread Christian König
Calculate the correct value for max_entries or we might run after the page_address array. v2: Xinhui pointed out we don't need the shift v3: use local copy of start and simplify some calculation v4: fix the case that we map less VA range than BO size Signed-off-by: Christian König Fixes: 1e691e2

Re: [PATCH 1/1] drm/amdgpu: disable gpu-sched load balance for uvd_enc

2020-09-03 Thread Nirmoy
Hi Alex, If possible, please squash this with: commit e0300ed8820d19fe108006cf1b69fa26f0b4e3fc drm/amdgpu: disable gpu-sched load balance for uvd Regards, Nirmoy On 9/2/20 1:07 PM, Christian König wrote: Am 02.09.20 um 12:15 schrieb Nirmoy Das: On hardware with multiple uvd instances, d

Re: [PATCH 1/2] drm/amdgpu/gmc9: print client id string for mmhub

2020-09-03 Thread Christian König
Am 03.09.20 um 08:36 schrieb Huang Rui: On Wed, Sep 02, 2020 at 02:16:39PM -0400, Alex Deucher wrote: Print the name of the client rather than the number. This makes it easier to debug what block is causing the fault. Signed-off-by: Alex Deucher Series are Reviewed-by: Huang Rui I would d

Re: [PATCH] drm/amdgpu: enable ih1 ih2 for Arcturus only

2020-09-03 Thread Christian König
Am 02.09.20 um 20:28 schrieb Felix Kuehling: Am 2020-09-02 um 2:13 p.m. schrieb Alex Deucher: On Wed, Sep 2, 2020 at 2:08 PM Alex Deucher wrote: On Wed, Sep 2, 2020 at 1:01 PM Alex Sierra wrote: Enable multi-ring ih1 and ih2 for Arcturus only. For Navi10 family multi-ring has been disabled.

Re: [PATCH] drm/amdgpu: fix max_entries calculation v3

2020-09-03 Thread Christian König
Am 02.09.20 um 18:15 schrieb Pan, Xinhui: 2020年9月2日 23:21,Christian König 写道: Calculate the correct value for max_entries or we might run after the page_address array. v2: Xinhui pointed out we don't need the shift v3: use local copy of start and simplify some calculation Signed-off-by: Chr