[PATCH v3] drm/amd/display: move calcs folder into DML

2022-01-07 Thread Isabella Basso
compile when DCN was disabled. Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/display/dc/Makefile | 4 +- drivers/gpu/drm/amd/display/dc/calcs/Makefile | 68 --- drivers/gpu/drm/amd/display/dc/dml/Makefile | 10 ++- .../amd/display/dc/{ => dml}/calcs/bw_fixed.c |

Re: [PATCH v2] drm/amd/display: move calcs folder into DML

2022-01-03 Thread Isabella Basso
ted? >From what I tested locally both work pretty much the same. I think my solution is a little harder to test but ends up being a little more compact, which might translate into being more maintainable (maybe?). Please let me know what you think :). Cheers, -- Isabella Bas

[PATCH v2] drm/amd/display: move calcs folder into DML

2021-12-20 Thread Isabella Basso
The calcs folder has FPU code on it, which should be isolated inside the DML folder as per https://patchwork.freedesktop.org/series/93042/. This commit aims single-handedly to correct the location of such FPU code and does not refactor any functions. Signed-off-by: Isabella Basso --- drivers

[PATCH v2 09/10] drm/amdgpu: remove unnecessary variables

2021-12-09 Thread Isabella Basso
ueira: 1. Drop display_count variable. - As suggested by Felix Kuehling: 1. Remove block surrounding amdgpu_xgmi_same_hive. Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdkfd/kfd_svm.c | 4 .../gpu/drm/amd/display/dc/clk_mgr/dcn201/dcn201_clk_mgr.c | 7 +--

[PATCH v2 10/10] drm/amdgpu: re-format file header comments

2021-12-09 Thread Isabella Basso
Fix the warning below: warning: Cannot understand * \file amdgpu_ioc32.c on line 2 - I thought it was a doc line Changes since v1: - As suggested by Alexander Deucher: 1. Reduce diff to minimum as this DOC section doesn't provide much value. Signed-off-by: Isabella Basso --- dr

[PATCH v2 06/10] drm/amd/display: fix function scopes

2021-12-09 Thread Isabella Basso
msg_id, unsigned int param) | ^ Changes since v1: - As suggested by Rodrigo Siqueira: 1. Rewrite function signatures to make them more readable. 2. Get rid of unused functions in order to remove 'defined but not used' warnings. Signed-off-by

[PATCH v2 03/10] drm/amdgpu: fix amdgpu_ras_mca_query_error_status scope

2021-12-09 Thread Isabella Basso
This commit fixes the compile-time warning below: warning: no previous prototype for ‘amdgpu_ras_mca_query_error_status’ [-Wmissing-prototypes] Changes since v1: - As suggested by Alexander Deucher: 1. Make function static instead of adding prototype. Signed-off-by: Isabella Basso

[PATCH v2 00/10] drm/amd: fix various compilation warnings

2021-12-09 Thread Isabella Basso
functions in patch 6/10 - Removed more unecessary code in patch 9/10 - Reduced patch 10/10 to a minimum [1] - https://pad.riseup.net/p/ZMkzoeO89Kt7R_IC4iAo-keep [2] - https://patchwork.freedesktop.org/series/97701 Isabella Basso (10): drm/amd: Mark IP_BASE definition as __maybe_unused drm/amd: fix

[PATCH 03/10] drm/amdgpu: add missing function prototype for amdgpu_ras_mca_query_error_status

2021-12-07 Thread Isabella Basso
This commit fixes the compile-time warning below: warning: no previous prototype for ‘amdgpu_ras_mca_query_error_status’ [-Wmissing-prototypes] Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdgpu/amdgpu_ras.h | 4 1 file changed, 4 insertions(+) diff --git a/drivers/gpu/drm

[PATCH 02/10] drm/amd: fix improper docstring syntax

2021-12-07 Thread Isabella Basso
tarts with '/**', but isn't a kernel-doc comment. Refer Documentation/doc-guide/kernel-doc.rst Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdgpu/amdgpu_atomfirmware.c| 4 ++-- drivers/gpu/drm/amd/amdgpu/amdgpu_atpx_handler.c| 2 +- drivers/gpu/drm/amd/amdgpu/amd

[PATCH 04/10] drm/amdgpu: fix function scopes

2021-12-07 Thread Isabella Basso
o previous prototype for 'amdgpu_vkms_output_init' [-Wmissing-prototypes] 399 | int amdgpu_vkms_output_init(struct drm_device *dev, | ^~~~~~~ Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdgpu/amdgpu_vkms.c | 4 ++-- 1 file changed, 2 insertions(+),

[PATCH 06/10] drm/amd/display: fix function scopes

2021-12-07 Thread Isabella Basso
, unsigned int param) | ^~~~~ Signed-off-by: Isabella Basso --- .../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 19 +-- .../gpu/drm/amd/display/dc/calcs/dcn_calcs.c | 4 +- .../display/dc/clk_mgr/dcn10/rv1_clk_mgr.c| 2 +- .../display/dc/clk_mgr/dcn20/d

[PATCH 09/10] drm/amdgpu: remove unnecessary variables

2021-12-07 Thread Isabella Basso
ocks': warning: variable 'enter_display_off' set but not used [-Wunused-but-set-variable] 132 | bool enter_display_off = false; | ^~~~~ Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdkfd/kfd_svm.c | 3 +-- .

[PATCH 10/10] drm/amdgpu: re-format file header comments

2021-12-07 Thread Isabella Basso
Fix the warning below by switching header comments to be more aligned with AMD's docstrings: warning: Cannot understand * \file amdgpu_ioc32.c on line 2 - I thought it was a doc line Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdgpu/amdgpu_ioc32.c | 16 +--- 1

[PATCH 08/10] drm/amdgpu: fix location of prototype for amdgpu_kms_compat_ioctl

2021-12-07 Thread Isabella Basso
d int cmd, unsigned long arg) | ^~~ Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdgpu/amdgpu.h | 2 -- drivers/gpu/drm/amd/amdgpu/amdgpu_drv.h | 3 +++ 2 files changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu

[PATCH 05/10] drm/amdkfd: fix function scopes

2021-12-07 Thread Isabella Basso
~~ Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdkfd/kfd_packet_manager_vi.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_packet_manager_vi.c b/drivers/gpu/drm/amd/amdkfd/kfd_packet_manager_vi.c index 08442e7d9944..3c0658e32e93 10

[PATCH 01/10] drm/amd: Mark IP_BASE definition as __maybe_unused

2021-12-07 Thread Isabella Basso
defined but not used [-Wunused-const-variable=] 123 | static const struct IP_BASE UMC0_BASE ={ { { { 0x00014000, 0, 0, 0, 0 } }, | ^~~~~ Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/include/cyan_skillfish_ip_offset.h | 10 +- drivers

[PATCH 00/10] drm/amd: fix various compilation warnings

2021-12-07 Thread Isabella Basso
were gathered by a script [1]. [1] - https://pad.riseup.net/p/ZMkzoeO89Kt7R_IC4iAo-keep Isabella Basso (10): drm/amd: Mark IP_BASE definition as __maybe_unused drm/amd: fix improper docstring syntax drm/amdgpu: add missing function prototype for amdgpu_ras_mca_query_error_status drm

[PATCH 07/10] drm/amd: append missing includes

2021-12-07 Thread Isabella Basso
o previous prototype for ‘amdgpu_has_atpx’ [-Wmissing-prototypes] 76 | bool amdgpu_has_atpx(void) { | ^~~ Signed-off-by: Isabella Basso --- drivers/gpu/drm/amd/amdgpu/amdgpu_atpx_handler.c| 1 + .../drm/amd/display/dc/clk_mgr/dcn10/rv1_clk_mgr_vbios_sm