Re: [PATCH 4/4] drm/amdgpu: rework synchronization of VM updates v3

2020-01-23 Thread William Lewis
Was the change to true from the only use of intr in amdgpu_bo_sync_wait_resv intentional?  If so, would it not make sense to remove the argument from the function signature while the API is changing? On 1/23/20 8:21 AM, Christian König wrote: > If provided we only sync to the BOs reservation >

Re: [PATCH] drm/amdgpu: fix doc by clarifying sched_list definition

2020-01-21 Thread William Lewis
If we're worrying about spelling and grammar, see one more nitpick inline. On 1/20/20 10:35 AM, Nirmoy Das wrote: > expand sched_list definition for better understanding. > Also fix a typo atleast -> at least > > Signed-off-by: Nirmoy Das > --- > drivers/gpu/drm/scheduler/sched_entity.c | 2 +-

Re: [PATCH v2 2/5] drm: Add Reusable task barrier.

2019-12-13 Thread William Lewis
Some typographical error nitpicks inline. On 12/13/19 10:54 AM, Andrey Grodzovsky wrote: > It is used to synchronize N threads at a rendevouz point before execution rendezvous > of critical code that has to be started by all the threads at approximatly approximately > the same time. > > v2:

Re: [PATCH 6/8] drm/amdgpu: add psp memory training callbacks and macro

2019-10-08 Thread William Lewis
On 10/8/19 2:29 PM, Alex Deucher wrote: > From: "Tianci.Yin" > > add interface for memory training. > > Change-Id: Ibb6d1d24eb651df796bc2bb3419a44937af60242 > Reviewed-by: Alex Deucher > Signed-off-by: Tianci.Yin > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c | 18 >

Re: [PATCH 4/8] drm/amdgpu: update atomfirmware header with memory training related members

2019-10-08 Thread William Lewis
On 10/8/19 2:29 PM, Alex Deucher wrote: > From: "Tianci.Yin" > > add new vram_reserve_block structure and atomfirmware_internal_constants > enumeration > > Change-Id: I6ba642ecd7ad94250162ae5c322ed8d85de9c35a > Reviewed-by: Alex Deucher > Signed-off-by: Tianci.Yin > --- >

Re: [PATCH] drm/amd/powerplay: detect version of smu backend

2019-06-14 Thread William Lewis
On 6/14/19 2:01 AM, Prike Liang wrote: > Change-Id: Ib050c8cf0c2c5af4c1f747cf596860f9be01a2d3 > Signed-off-by: Prike Liang > --- > drivers/gpu/drm/amd/powerplay/hwmgr/hwmgr.c | 1 + > drivers/gpu/drm/amd/powerplay/inc/hwmgr.h | 1 + >

Re: [PATCH v3] drm/amdgpu: add badpages sysfs interafce

2019-05-09 Thread William Lewis
Typo in the patch description.  s/interafce/interface/ On 5/9/19 10:24 AM, Alex Deucher wrote: > On Thu, May 9, 2019 at 6:31 AM Pan, Xinhui wrote: >> add badpages node. >> it will output badpages list in format >> gpu pfn : gpu page size : flags >> >> example >> 0x : 0x1000 : R >>

Re: [PATCH] drm/amdkfd: fix a compiling error when CONFIG_HSA_AMD disalbed

2019-03-06 Thread William Lewis
Typo in patch description: s/disalbed/disabled/ On 3/6/19 10:11 AM, Deucher, Alexander wrote: Add a line like: Fixes: 9032ea09e2d2ef ("drm/amdkfd: add RAS ECC event support") With that added: Reviewed-by: Alex Deucher From:

Re: [PATCH] drm/amd/powerplay: revise Vega20 pptable version check

2018-10-30 Thread William Lewis
On 10/29/18 8:41 PM, Alex Deucher wrote: > On Mon, Oct 29, 2018 at 9:39 PM Evan Quan wrote: >> Tell the version numbers when the pptable versions do not match. >> >> Change-Id: I3ea8aac7493927281b14d28866fa87690621f0f0 >> Signed-off-by: Evan Quan >> --- >>

Re: [PATCH libdrm 3/6] amdgpu: add handle table implementation

2018-08-02 Thread William Lewis
Applies to patch #1 and patch #3, should lockup not be lookup? On 08/02/2018 09:04 AM, Christian König wrote: > The kernel handles are dense and the kernel always tries to use the > lowest free id. Use this to implement a more efficient handle table > by using a resizeable array instead of a

Re: [PATCH] drm/amdgpu: Partially revert commit 2dc80b006

2018-06-13 Thread William Lewis
On 06/13/2018 08:30 AM, Jan Vesely wrote: Hi, can you please improve the commit message? seeing "Revert $HASH" conveys zero information about the code change. I'm sorry for bringing this up again, but following AMDGPU/Radeon driver development is an exercise in frustration for anyone who is

Re: [PATCH] drm/amdgpu: Fix amdgpu_sync_add_later to preserve explicit flag.

2017-12-05 Thread William Lewis
On 12/05/2017 08:41 AM, Andrey Grodzovsky wrote: > Signed-off-by: Andrey Grodzovsky > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_sync.c | 9 ++--- > 1 file changed, 6 insertions(+), 3 deletions(-) > > diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_sync.c >

Re: [PATCH 2/6] drm/amd/display: Use new DRM API where possible

2017-10-14 Thread William Lewis
On 10/12/2017 04:15 PM, sunpeng...@amd.com wrote: > From: "Leo (Sunpeng) Li" > > To conform to DRM's new API, we should not be accessing a DRM object's > internal state directly. Rather, the DRM for_each_old/new_* iterators, > and drm_atomic_get_old/new_* interface should be

Re: [PATCH] drm/amdgpu: discard commands of killed processes

2017-08-23 Thread William Lewis
On 08/21/2017 07:58 AM, Christian König wrote: > From: Christian König > > When a process is killed we shouldn't submit all waiting jobs, but instead > clean up as fast as possible. > > Signed-off-by: Christian König > --- >

Re: [PATCH 1/6] drm: Add helper to cast DMA-buf to GEM object v2

2017-07-20 Thread William Lewis
On 07/18/2017 09:22 PM, Felix Kuehling wrote: > v2: Use the new helper in drm_gem_prime_import > > Signed-off-by: Felix Kuehling > Reviewed-by: Christian König > Reviewed-by: Daniel Vetter > --- >

Re: [PATCH] drm/amd/powerplay: fix copy error in powerplay.

2017-06-08 Thread William Lewis
On 06/08/2017 02:50 AM, Rex Zhu wrote: > should disable led dpm feature when stop dpm. > > Change-Id: I9d78459ff2467d2eba0b26d9696138f7eba484a0 > Signed-off-by: Rex Zhu > --- > drivers/gpu/drm/amd/powerplay/hwmgr/vega10_hwmgr.c | 6 +++--- > 1 file changed, 3 insertions(+),

Re: [PATCH] drm/amdgpu: set vm size and block size by individual gmc by default

2017-04-05 Thread William Lewis
On 04/05/2017 01:43 AM, Junwei Zhang wrote: > By default, the value is set by individual gmc. > if a specific value is input, it overrides the global value for all > > Signed-off-by: Junwei Zhang > --- > drivers/gpu/drm/amd/amdgpu/amdgpu.h| 2 ++ >

Re: [PATCH 03/15] drm/amdgpu: add num_level to the VM manager

2017-03-28 Thread William Lewis
On 03/27/2017 12:53 AM, Chunming Zhou wrote: > From: Christian König > > Needs to be filled with handling. > > Change-Id: I04881a2b304a020c259ce85e94b12900a77f1c02 > Signed-off-by: Christian König > Reviewed-by: Alex Deucher

Re: [PATCH 3/6] drm/amdgpu: add get_clockgating callback for soc15

2017-03-24 Thread William Lewis
On 03/24/17 00:47, Huang Rui wrote: > Signed-off-by: Huang Rui > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_pm.c | 3 +++ > drivers/gpu/drm/amd/amdgpu/soc15.c | 34 > ++ > 2 files changed, 37 insertions(+) > > diff --git

Re: [PATCH 16/21] drm/amdgpu: implement lru amdgpu_queue_mgr policy for compute v3

2017-03-03 Thread William Lewis
Minor spelling nitpick. >> +/** >> + * amdgpu_ring_lru_get - get the least recently used ring for a HW >> IP block >> + * >> + * @adev: amdgpu_device pointer >> + * @type: amdgpu_ring_type enum >> + * @ring: output ring >> + * >> + * Retreive the amdgpu_ring structure for the least recently

Re: [PART1 PATCH 2/8] drm/amdgpu: add parse clock gating state

2017-01-05 Thread William Lewis
Minor nit. s/Grain/Grained/ Also, amdgpu_clockgating_state as a function name does not seem explicit enough as to what it's doing, maybe amdgpu_get_clockgating_state? On 01/05/17 07:49, Huang Rui wrote: > Signed-off-by: Huang Rui > --- >

Re: [PATCH 1/2] drm/amdgpu/si/dpm: make a bunch of things static

2016-09-13 Thread William Lewis
Two minor possible changes inline for further simplification... On 09/12/16 23:11, Alex Deucher wrote: > remnants of the port from radeon. > > Signed-off-by: Alex Deucher > --- > drivers/gpu/drm/amd/amdgpu/si_dpm.c | 34 -- > 1 file