Re: [android-developers] problem in radioGroup.getCheckedRadioButtonId()

2012-03-09 Thread Ray Tayek
At 10:55 PM 3/8/2012, you wrote: ... please see code below. seems like i had the wrong OnCheckedChangeListener. it needs to be a RadioGroup.OnCheckedChangeListener. thanks --- co-chair http://ocjug.org/ -- You received this message because you are subscribed to the Google Groups

Re: [android-developers] problem in radioGroup.getCheckedRadioButtonId()

2012-03-09 Thread Kostya Vasilyev
Yes, this behavior is expected: https://github.com/android/platform_frameworks_base/blob/master/core/java/android/widget/CompoundButton.java#L108 The mOnCheckedChangeListener is your (application-provided) listener. The mOnCheckedChangeWidgetListeneris installed by the radio group, and is

Re: [android-developers] problem in radioGroup.getCheckedRadioButtonId()

2012-03-09 Thread Ray Tayek
At 02:49 AM 3/9/2012, you wrote: Yes, this behavior is expected: https://github.com/android/platform_frameworks_base/blob/master/core/java/android/widget/CompoundButton.java#L108https://github.com/android/platform_frameworks_base/blob/master/core/java/android/widget/CompoundButton.java#L108

[android-developers] problem in radioGroup.getCheckedRadioButtonId()

2012-03-08 Thread Ray Tayek
hi, i have some groups of radio buttons that i create programmatically. they work fine (please see code below). but calling radioGroup.getCheckedRadioButtonId() always returns -1 when it's called from onCheckedChanged(). is this correct behaviour? thanks package tayek.radio; import

Re: [android-developers] problem in radioGroup.getCheckedRadioButtonId()

2012-03-08 Thread TreKing
On Thu, Mar 8, 2012 at 11:24 AM, Ray Tayek rta...@ca.rr.com wrote: please see code below Please break your problem down to the smallest snippet of code necessary to demonstrate your problem and, if possible, apply some indentation and coloring to help readability. You've posted a giant blob of

Re: [android-developers] problem in radioGroup.getCheckedRadioButtonId()

2012-03-08 Thread Ray Tayek
At 02:16 PM 3/8/2012, you wrote: ... Please break your problem down to the smallest snippet of code necessary to demonstrate your problem and, if possible, apply some indentation and coloring to help readability. You've posted a giant blob of foreign, unformatted text that few people will