Re: [ath5k-devel] Race condition in CRDA calls?

2010-06-16 Thread Luis R. Rodriguez
On Wed, Jun 16, 2010 at 9:47 PM, Bruno Randolf wrote: > hi! > > are there any news on that? i think i hit the same bug, now... I provided verbose instructions what can be done to further debug this. Luis ___ ath5k-devel mailing list ath5k-devel@lists

Re: [ath5k-devel] Race condition in CRDA calls?

2010-06-16 Thread Bruno Randolf
hi! are there any news on that? i think i hit the same bug, now... thanks, bruno On Thu May 27 2010 06:46:58 Luis R. Rodriguez wrote: > Just FYI, you want to use linux-wireless for reporting such things, > not ath5k-devel. Also I have been real busy in March (and stil am but > just trying to rep

[ath5k-devel] OOPS in ath5k when setting coverage class

2010-06-16 Thread Steve Brown
From the printk's, it appears that ah->ah_current_channel isn't set at the time of the callback. The following produces the oops with compat-wireless-2010-06-10. Steve - rmmod ath5k insmod ath5k iw phy0 set distance 11000 pcu.c:ath5k_hw_set_coverage_class:849 a

[ath5k-devel] [PATCH 17/17] ath5k: report PHY error frames only for chips which need it

2010-06-16 Thread Bruno Randolf
Only report PHY error frames for ANI on chipsets which do not have PHY error counters in hardware. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/desc.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/drivers/net/wireless/ath/at

[ath5k-devel] [PATCH 16/17] ath5k: review RX descriptor functions

2010-06-16 Thread Bruno Randolf
Reviewed RX descriptor functions against the HAL sources. Some minor changes: - check size before making changes to the descriptor - whitespace - add comments about 5210 timestamps. this needs to be adressed later! - FIFO overrun error only available on 5210 - rs_phyerr should not be

[ath5k-devel] [PATCH 15/17] ath5k: take descriptor differences between 5210 and 5211 into account

2010-06-16 Thread Bruno Randolf
There are some differences between 5210 and 5211 descriptors which we did not take into account before. Signed-off-by: Bruno Randolf --- drivers/net/wireless/ath/ath5k/desc.c | 29 ++--- drivers/net/wireless/ath/ath5k/desc.h |6 +++--- 2 files changed, 25 insertions

[ath5k-devel] [PATCH 14/17] ath5k: update 5210/5211 frame types

2010-06-16 Thread Bruno Randolf
Update 5210 frame types to match the HAL. We have to apply the same bitshift to the constants as we use later. Add 5211 specific frame types. Signed-off-by: Bruno Randolf --- drivers/net/wireless/ath/ath5k/desc.c |2 +- drivers/net/wireless/ath/ath5k/desc.h | 12 +++- 2 files chan

[ath5k-devel] [PATCH 13/17] ath5k: review and add comments for descriptors

2010-06-16 Thread Bruno Randolf
I carefully reviewed desh.h against the HAL sources. Added comments and made differences between 5210, 5211 and 5212 more clear by adding _521x to the defines which are specific to that chipset. Renamed some defines. No functional changes. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland ---

[ath5k-devel] [PATCH 12/17] ath5k: remove pointless rx error overlay struct

2010-06-16 Thread Bruno Randolf
ath5k_hw_rx_error was only used once, where we could easily just use ath5k_hw_rx_status as well, so remove it. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/debug.c |2 +- drivers/net/wireless/ath/ath5k/desc.c | 12 drivers/net/wirele

[ath5k-devel] [PATCH 11/17] ath5k: cosmetic changes in ath5k_hw_proc_5212_rx_status()

2010-06-16 Thread Bruno Randolf
Just whitespace and indentation. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/desc.c | 10 +- 1 files changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/net/wireless/ath/ath5k/desc.c b/drivers/net/wireless/ath/ath5k/desc.c index b

[ath5k-devel] [PATCH 09/17] ath5k: move checks and stats into new function

2010-06-16 Thread Bruno Randolf
Create a new function ath5k_receive_frame_ok() which checks for errors, updates error statistics and tells us if we want to further "receive" this frame or not. This way we can avoid a goto and have a cleaner separation between buffer handling and other things. Signed-off-by: Bruno Randolf --- d

[ath5k-devel] [PATCH 10/17] ath5k: use direct function calls for descriptors when possible

2010-06-16 Thread Bruno Randolf
Use direct function calls for ath5k_hw_setup_rx_desc() and ath5k_hw_setup_mrr_tx_desc() instead of a function pointer which always pointed to the same function in the case of ath5k_hw_setup_rx_desc() and which is easily unified in the case of ath5k_hw_setup_mrr_tx_desc(). Also simplify the initial

[ath5k-devel] [PATCH 08/17] ath5k: split descriptor handling and frame receive

2010-06-16 Thread Bruno Randolf
Move frame reception into it's own function to have a clearer separation between buffer and descriptor handling and things that are done when we actually receive a frame. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/base.c | 149 +--

[ath5k-devel] [PATCH 07/17] ath5k: unify rx descriptor error handling

2010-06-16 Thread Bruno Randolf
There is no reason for a special handling (return) here, just break like we do with the checks before. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/base.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/drivers/net/wireless/at

[ath5k-devel] [PATCH 05/17] ath5k: print more errors when decriptor setup fails

2010-06-16 Thread Bruno Randolf
Signed-off-by: Bruno Randolf --- drivers/net/wireless/ath/ath5k/base.c |4 +++- 1 files changed, 3 insertions(+), 1 deletions(-) diff --git a/drivers/net/wireless/ath/ath5k/base.c b/drivers/net/wireless/ath/ath5k/base.c index 5bd9a39..6c303d5 100644 --- a/drivers/net/wireless/ath/ath5k/base

[ath5k-devel] [PATCH 06/17] ath5k: reset more pointers after we free skbs

2010-06-16 Thread Bruno Randolf
After we free skbs for receive or transmit descriptors, make sure we have no pointers to the now invalid memory address. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/base.c |7 +++ 1 files changed, 7 insertions(+), 0 deletions(-) diff --git a/d

[ath5k-devel] [PATCH 04/17] ath5k: fix rx descriptor debugging

2010-06-16 Thread Bruno Randolf
In the debug ouptut rx_status_0 was printed twice instead of rx_status_1. Also make the debug message more clear. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/debug.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/ne

[ath5k-devel] [PATCH 00/17] ath5: descriptor cleanup series

2010-06-16 Thread Bruno Randolf
hi! this series is a bunch of smaller changes i made while reviewing rx buffer handling and some stuff i picked up while carefully reviewing the descriptor definitions from the HAL against what we have. it's mostly cosmetics and refactoring. greetings, bruno --- Bruno Randolf (17): ath5k:

[ath5k-devel] [PATCH 03/17] ath5k: fix some comment typos

2010-06-16 Thread Bruno Randolf
Fix comment about dma sizes, brackets were missing. Replace 'insure' with 'ensure'. Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/ath5k.h |2 +- drivers/net/wireless/ath/ath5k/base.c |6 +++--- 2 files changed, 4 insertions(+), 4 deletions(-) d

[ath5k-devel] [PATCH 02/17] ath5k: rename ath5k_txbuf_free() to ath5k_txbuf_free_skb()

2010-06-16 Thread Bruno Randolf
Rename ath5k_txbuf_free() to ath5k_txbuf_free_skb() since this is what it does: it frees the skb and not the buf. Same for ath5k_rxbuf_free(). Signed-off-by: Bruno Randolf Acked-by: Bob Copeland --- drivers/net/wireless/ath/ath5k/base.c | 17 + 1 files changed, 9 insertions(+)

[ath5k-devel] [PATCH 01/17] ath5k: more debug prints for resets

2010-06-16 Thread Bruno Randolf
Add a debug print for every case of reset. Signed-off-by: Bruno Randolf --- drivers/net/wireless/ath/ath5k/base.c | 14 +++--- drivers/net/wireless/ath/ath5k/debug.c |1 + 2 files changed, 12 insertions(+), 3 deletions(-) diff --git a/drivers/net/wireless/ath/ath5k/base.c b/driv