Re: Ant test framework - running a test

2005-01-11 Thread Andrew Perry2
When all the source code has been compiled and the libraries built there is a package step (for Ant anyway) which creates a directory structure which has the following directories only, i.e. the binary distribution. bin/ deploy/ docs/ include/ lib/ LICENSE NOTICE samples/ tests/ I take this b

Re: Ant test framework - running a test

2005-01-11 Thread Andrew Perry2
I have never had a problem with specifying a classpath with the jar option in ant, but as the general concensus seems to be to use the classname invocation method, I'll update the buildTest.xml to use this method. Regards, Andrew Perry IBM C/C++ Web Services Client [EMAIL PROTECTED] Mail Poin

Re: Ant test framework - running a test

2005-01-11 Thread Andrew Perry2
I generally call the ant -f test.xml -Ddir.release= rather than change the properties file. I'm not too sure if/how the build.xml uses the dir.release property so cannot comment safely on altering the properties file, unless it is only for the test run in which case there is no problem. Adrian

Re: setUri() API - Usage

2005-01-11 Thread Roshan Weerasuriya
hi All, Currently in the code we use the Attribute class as the place holder for Attributes and Namespces(i.e Namespace decl

Re: setUri() API - Usage

2005-01-11 Thread Adrian Dick
Roshan Weerasuriya <[EMAIL PROTECTED]> wrote on 11/01/2005 09:47:59: > > So what I propose is to introduce a new class as a palce holder for > namespaces (i.e actualy for namespace declarations). eg: > class Namespace > { > public: > void setURI(AxisString asURI); > void setPre

Re: Ant test framework - running a test

2005-01-11 Thread Adrian Dick
I accept people have been having difficulties using the JAR option and using classname is the easy option, but I feel we should still persevere, otherwise we will no longer be testing the correct creation of the manifest file. Regards, Adrian ___ Adrian Dic

Re: Ant test framework - running a test

2005-01-11 Thread sanjaya singharage
I keep getting this same error too despite using both Axis java 1.2 beta/RC1 jars for AXISJAVA_LIB env variable. sanjaya. - Original Message - From: "Samisa Abeysinghe" <[EMAIL PROTECTED]> To: "Apache AXIS C Developers List" Sent: Monday, January 10, 2005 10:07 PM Subject: Re: Ant test fr

Re: setUri() API - Usage

2005-01-11 Thread Roshan Weerasuriya
hi Addrian, >I agree with the INamespace and Namespace structure. When it comes to > implementation, I believe the best aproach is for Namespace to encapsulate > an Attribute, such that Attribute::setValue is exposed as setURI while > Attribute::setURI is made unavailable. Your idea is cool, bu

Re: Ant test framework - running a test

2005-01-11 Thread Adrian Dick
The packaging process appends '-src' and '-bin' to the end of dir.release when creating a source and binary package respectively. So, modifying the property files would not have the effect you're hoping for. ___ Adrian Dick ([EMAIL PROTECTED]) Andrew Perry

Re: Ant test framework - running a test

2005-01-11 Thread Samisa Abeysinghe
I was wondering if the cause of the error is due to an error in manifest on my system. Once I got a message saying "invalid manifest". How can I veryfy if it is a problem with manifest? Thanks, Samisa... On Tue, 11 Jan 2005 10:23:58 +, Adrian Dick <[EMAIL PROTECTED]> wrote: > > > I accept

Re: Ant test framework - running a test

2005-01-11 Thread Samisa Abeysinghe
The problem is that when ant is run with test.xml, it is trying to use the release folder wsdl2ws.jar wihtout -bin suffix. I think it would work if we suffix use of dir.release in test related files. Thanks, Samisa... On Tue, 11 Jan 2005 10:40:10 +, Adrian Dick <[EMAIL PROTECTED]> wrote: >

Re: Assistance with creating a new Makefile.am

2005-01-11 Thread Samisa Abeysinghe
Hi Adrian, If you are trying to compile these files into an existing lib, the task is straightforward, just add the list of cpp files to the libsoap_la_SOURCES in the file ws-axis/c/src/soap/Makefile.am. In this case, ss per my understanding, you would not require a new Makefile.am. Thanks, S

Re: setUri() API - Usage

2005-01-11 Thread Andrew Perry2
A small note about AxisString. I thought a while ago that STL stuff, i.e. string, wasn't going to be in the public API, or is AxisString the same as AxisChar*? Regards Andrew Perry IBM C/C++ Web Services Client [EMAIL PROTECTED] Mail Point 127 IBM UK Laboratories. Hursley Park, Winchester, Ha

Re: Ant test framework - running a test

2005-01-11 Thread Andrew Perry2
We regularly have tests run on 10+ machines on 4 different platforms and have never had a problem with using the Ant java task with jar and a nested classpath. The classpath is constructed from a filelist *.jar from the ${dir.axisJARs} property which points to the directory $AXISJAVA_LIB by def

Re: setUri() API - Usage

2005-01-11 Thread Adrian Dick
I agree that my proposed solution will indeed use a little more memory. But is it such a significant amount of memory to offset the simplicity and ease of maintenance of this design? Adrian ___ Adrian Dick ([EMAIL PROTECTED]) Roshan Weerasuriya <[EMAIL PR

errno

2005-01-11 Thread John Hawkins
Hi Folks, Still looking into errno ! After finding yet another issue that was solved by getting errno. I want to use it but it isn't thread-safe. Looking here -> http://httpd.apache.org/docs-2.0/developer/thread_safety.html It gives the recommendation of "make sure your module or library defines

Re: errno

2005-01-11 Thread Steve Hardy
_D_REENTRANT is a feature that is fully supported in linux from glibc 2.x .. as long as you specify this while compiling libc-based programs when using multi-threading you're fine. This is an issue that was present in more like 1995/1996, and has been resolved since (by introducing the -D_REENTRAN

Re: setUri() API - Usage

2005-01-11 Thread Roshan Weerasuriya
hi Addrian, >I agree that my proposed solution will indeed use a little more memory. It is better if we could gain, if possible from where ever it is, because perfomance is also a matter at the end. >But is it such a significant amount of memory to offset the simplicity >and > ease of maintenanc

Re: setUri() API - Usage

2005-01-11 Thread James Jose
Roshan,    setUri() for an attribute does not change the SOAP Message. So if we going for separate class for namespace, then do we need this setUri() API in IAttribute class. Regards James -- James Jose Messaging Clients Team, WMQDDC IBM Software La

Re: setUri() API - Usage

2005-01-11 Thread Roshan Weerasuriya
hi Andrew, >is AxisString the same as > AxisChar*? AxisString is std::basic_string >A small note about AxisString. I thought a while ago that STL stuff, >i.e. > string, wasn't going to be in the public API Well yes. The API should be like: class Namespace { public: const AxisChar* getPr

Re: setUri() API - Usage

2005-01-11 Thread Roshan Weerasuriya
hi James, Well I think we might need. For example when a user want to declare couple of Attributes in his/her own namespace, user will need to set his/her namespace for a attribute, so that the engine can put the correct prefix for all such attributes. Or for example if a user is defining a attr

[VOTE] James Jose for committer

2005-01-11 Thread John Hawkins
Hi Folks, I would like to nominate James for committer. His diligent test work is providing real value-add to the project and his eye for detail is helping greatly in our API understanding, documentation and debug. He will be continuing to work on the code for some time - adding in new tests and

Re: [VOTE] James Jose for committer

2005-01-11 Thread Roshan Weerasuriya
+1 Roshan On Tue, 2005-01-11 at 18:53, John Hawkins wrote: > Hi Folks, > > I would like to nominate James for committer. > > His diligent test work is providing real value-add to the project and > his eye for detail is helping greatly in our API understanding, > documentation and debug. He will

Re: [VOTE] James Jose for committer

2005-01-11 Thread Andrew Perry2
+1. The tests he is writing is finding real problems. Andrew Perry IBM C/C++ Web Services Client [EMAIL PROTECTED] Mail Point 127 IBM UK Laboratories. Hursley Park, Winchester, Hants. SO21 2JN Tel. Internal 249828 External + 44 (0)1962 819828 Fax. + 44(0)1962 818080 John Hawkins/UK/[EMAIL P

[jira] Created: (AXISCPP-373) To change the names of the Channel and Channel_ssl properties to include a http reference

2005-01-11 Thread Fred Preston (JIRA)
To change the names of the Channel and Channel_ssl properties to include a http reference - Key: AXISCPP-373 URL: http://issues.apache.org/jira/browse/AXISCPP-373 Project: Axis-C++

1.5 release date.

2005-01-11 Thread John Hawkins
Hi Folks, I'm not sure we ever concluded on what date we were going for to release 1.5 May I suggest we head for end of Jan as alpha then release at end of Feb? that gives us one month of pure bug fix time. John Hawkins

[jira] Resolved: (AXISCPP-373) To change the names of the Channel and Channel_ssl properties to include a http reference

2005-01-11 Thread Fred Preston (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-373?page=history ] Fred Preston resolved AXISCPP-373: -- Resolution: Fixed Updates complete. > To change the names of the Channel and Channel_ssl properties to include a > http reference >

[jira] Closed: (AXISCPP-262) SetSecure method in Client.cpp does not need seperate values for ciphers v2 and v3.

2005-01-11 Thread Fred Preston (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-262?page=history ] Fred Preston closed AXISCPP-262: Resolution: Fixed Update completed. > SetSecure method in Client.cpp does not need seperate values for > ciphers v2 and v3. > --

Re: [VOTE] James Jose for committer

2005-01-11 Thread Fred Preston
+1 Regards, Fred Preston. John

[jira] Resolved: (AXISCPP-313) Axis Transport Project

2005-01-11 Thread Fred Preston (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-313?page=history ] Fred Preston resolved AXISCPP-313: -- Resolution: Fixed There was no SSL implementation in 1.3 The comments suggest ways of changing the code to enable SSL, but if you want SSL you wi

[jira] Resolved: (AXISCPP-261) Need to define how SSL defaults will be stored in the config file

2005-01-11 Thread Fred Preston (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-261?page=history ] Fred Preston resolved AXISCPP-261: -- Resolution: Fixed Updates complete. > Need to define how SSL defaults will be stored in the config file > ---

[jira] Commented: (AXISCPP-361) Improvements to HTTP Transport (Axis3)

2005-01-11 Thread Fred Preston (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-361?page=comments#action_57510 ] Fred Preston commented on AXISCPP-361: -- Hi All, I believe this is now complete for windows, but I will need help to create the makefiles for non windows platforms...

[jira] Commented: (AXISCPP-373) To change the names of the Channel and Channel_ssl properties to include a http reference

2005-01-11 Thread Fred Preston (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-373?page=comments#action_57505 ] Fred Preston commented on AXISCPP-373: -- Changing the following:- Channel -->> Channel_HTTP Channel_ssl -->> Channel_HTTP_SSL Adding the following:- SecureInfo > T

Re: errno

2005-01-11 Thread Nadir Amra
Not sure about other platforms, but OS/400 errno is thread-safe. I think this is true for AIX and Linux, but you may need to verify. Nadir K. Amra e-Business Technologies - IBM eServer i5/OS IBM Rochester, MN, (Tel. 507-253-0645, t/l 553-0645) Internet: [EMAIL PROTECTED] John Hawkins <[EMAIL P

Re: errno

2005-01-11 Thread Andrew Perry2
I always had to specify REENTRANT on HP-UX 11.00. Andrew Perry IBM C/C++ Web Services Client [EMAIL PROTECTED] Mail Point 127 IBM UK Laboratories. Hursley Park, Winchester, Hants. SO21 2JN Tel. Internal 249828 External + 44 (0)1962 819828 Fax. + 44(0)1962 818080

[jira] Assigned: (AXISCPP-332) The getOperationName() API doesn't work

2005-01-11 Thread John Hawkins (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-332?page=history ] John Hawkins reassigned AXISCPP-332: Assign To: John Hawkins > The getOperationName() API doesn't work > --- > > Key: AXISCPP-332 >

[jira] Closed: (AXISCPP-332) The getOperationName() API doesn't work

2005-01-11 Thread John Hawkins (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-332?page=history ] John Hawkins closed AXISCPP-332: Resolution: Fixed Fix Version: 1.5 Alpha Added setOperataionName to message when operation is set in call > The getOperationName() API doesn't w

Re: 1.5 release date.

2005-01-11 Thread Nadir Amra
+1 Sounds good to me! John Hawkins <[EMAIL PROTECTED]> wrote on 01/11/2005 07:30:19 AM: > > Hi Folks, > > I'm not sure we ever concluded on what date we were going for to release 1.5 > > May I suggest we head for end of Jan as alpha then release at end of > Feb? that gives us one month of

Re: 1.5 release date.

2005-01-11 Thread Roshan Weerasuriya
+1 Roshan On Wed, 2005-01-12 at 05:58, Nadir Amra wrote: > +1 > > Sounds good to me! > > > John Hawkins <[EMAIL PROTECTED]> wrote on 01/11/2005 07:30:19 AM: > > > > > Hi Folks, > > > > I'm not sure we ever concluded on what date we were going for to release > 1.5 > > > > May I suggest w

Re: 1.5 release date.

2005-01-11 Thread Nithyakala Thangaraja
+1 from me Nithya On 12 Jan 2005 09:11:47 +0600, Roshan Weerasuriya wrote > +1 > > Roshan > > On Wed, 2005-01-12 at 05:58, Nadir Amra wrote: > > +1 > > > > Sounds good to me! > > > > > > John Hawkins <[EMAIL PROTECTED]> wrote on 01/11/2005 07:30:19 AM: > > > > > > > >

Re: 1.5 release date.

2005-01-11 Thread Samisa Abeysinghe
+1 from me Samisa... On Tue, 11 Jan 2005 13:30:19 +, John Hawkins <[EMAIL PROTECTED]> wrote: > > Hi Folks, > > I'm not sure we ever concluded on what date we were going for to release 1.5 > > May I suggest we head for end of Jan as alpha then release at end of Feb? > that gives us one mo

Re: [VOTE] James Jose for committer

2005-01-11 Thread Samisa Abeysinghe
+1 Samisa... On Tue, 11 Jan 2005 12:53:52 +, John Hawkins <[EMAIL PROTECTED]> wrote: > > Hi Folks, > > I would like to nominate James for committer. > > His diligent test work is providing real value-add to the project and his > eye for detail is helping greatly in our API understanding

Re: Ant test framework - running a test

2005-01-11 Thread sanjaya singharage
The org/apache/axis/wsdl/symbolTable/TypeEntry class is in axis.jar. wsdl2ws.jar also contains the package org/apache/axis/wsdl/symbolTable/. When I copied the TypeEntry.class to this package in wsdl2ws.jar ant now gives NoClassDefFoundError for other classes that TypeEntry Class requires and the

RE: Platform specific class

2005-01-11 Thread Nadir Amra
I guess I would like to tackle the question of whether the "generated C stubs can be compiled by just using a C compiler?". I guess the person working on C stub generation needs to answer that. However, even if customer requires a C++ compiler, generating C stubs is still useful. Yes, the cust