HTTPTransport

2005-10-26 Thread Christopher S. Johnson
All - New to axis c but not new to axis, just a quick question so I can better understand how to build my own transport, I'm sure I'll have more later :) is the transport module is actually responsible for sending the bytes, in turn opening the real connection and reading and writing from the soc

Re: HTTPTransport

2005-10-26 Thread Fred Preston
managing these acts.  Depending on the action, you will see that the amount of interaction differs.  In reality, it is more tightly bound to a http sort of transport, so it should be renamed HTTPTransport, but that's another matter! Regards, Fred Preston. "Christopher S. Johnso

[jira] Created: (AXISCPP-822) Possible improvements to the HTTPTransport::getHTTPHeaders() and the HTTPTransport::flushOutput() methods - HTTPTransport.cpp file

2005-09-05 Thread Denis Linine (JIRA)
Possible improvements to the HTTPTransport::getHTTPHeaders() and the HTTPTransport::flushOutput() methods - HTTPTransport.cpp file --- Key: AXISCPP-822

[jira] Assigned: (AXISCPP-822) Possible improvements to the HTTPTransport::getHTTPHeaders() and the HTTPTransport::flushOutput() methods - HTTPTransport.cpp file

2005-10-20 Thread nadir amra (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-822?page=all ] nadir amra reassigned AXISCPP-822: -- Assign To: nadir amra > Possible improvements to the HTTPTransport::getHTTPHeaders() and the > HTTPTransport::flushOutput() methods - HTTPTranspo

[jira] Commented: (AXISCPP-822) Possible improvements to the HTTPTransport::getHTTPHeaders() and the HTTPTransport::flushOutput() methods - HTTPTransport.cpp file

2005-10-23 Thread nadir amra (JIRA)
a question whether on HTTPTransport::flushOutput() , if an exception happens should the the header and user data buffers be reset to null string? > Possible improvements to the HTTPTransport::getHTTPHeaders() and the > HTTPTransport::flushOutput() methods - HTTPTransport.cp

[jira] Commented: (AXISCPP-822) Possible improvements to the HTTPTransport::getHTTPHeaders() and the HTTPTransport::flushOutput() methods - HTTPTransport.cpp file

2005-10-24 Thread Fred Preston (JIRA)
creation/handling process, I would not reset any pointer to null, just their content. Regards, Fred Preston. > Possible improvements to the HTTPTransport::getHTTPHeaders() and the > HTTPTransport::flushO

[jira] Commented: (AXISCPP-822) Possible improvements to the HTTPTransport::getHTTPHeaders() and the HTTPTransport::flushOutput() methods - HTTPTransport.cpp file

2005-10-24 Thread nadir amra (JIRA)
. > Possible improvements to the HTTPTransport::getHTTPHeaders() and the > HTTPTransport::flushOutput() methods - HTTPTransport.cpp file > --- > > K

[jira] Closed: (AXISCPP-822) Possible improvements to the HTTPTransport::getHTTPHeaders() and the HTTPTransport::flushOutput() methods - HTTPTransport.cpp file

2005-10-25 Thread nadir amra (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-822?page=all ] nadir amra closed AXISCPP-822: -- Fix Version: 1.6 Alpha Resolution: Fixed > Possible improvements to the HTTPTransport::getHTTPHeaders() and the > HTTPTransport::flushOutput() m

[jira] Created: (AXISCPP-1059) HTTPTransport generates duplicate "Authentication: " headers

2008-10-14 Thread Michael Chen (JIRA)
HTTPTransport generates duplicate "Authentication: " headers Key: AXISCPP-1059 URL: https://issues.apache.org/jira/browse/AXISCPP-1059 Project: Axis-C++ Issue

[jira] Created: (AXISCPP-534) HTTPTransport::flushOutput should be declared throw(AxisException)

2005-03-11 Thread Tim Bartley (JIRA)
HTTPTransport::flushOutput should be declared throw(AxisException) -- Key: AXISCPP-534 URL: http://issues.apache.org/jira/browse/AXISCPP-534 Project: Axis-C++ Type: Bug Components: Transport (axis3

[jira] Assigned: (AXISCPP-534) HTTPTransport::flushOutput should be declared throw(AxisException)

2005-03-16 Thread Mark Whitlock (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-534?page=history ] Mark Whitlock reassigned AXISCPP-534: - Assign To: Mark Whitlock > HTTPTransport::flushOutput should be declared throw(AxisExcept

[jira] Closed: (AXISCPP-534) HTTPTransport::flushOutput should be declared throw(AxisException)

2005-03-16 Thread Mark Whitlock (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-534?page=history ] Mark Whitlock closed AXISCPP-534: - Resolution: Fixed I have updated HTTPTransport::flushOutput to throw(AxisException,HTTPTransportException). Although the code does catch

[jira] Created: (AXISCPP-689) SIGSEGV in HTTPTransport::FindTransportPropertyIndex when no SOAPAction set

2005-06-13 Thread Mark Whitlock (JIRA)
SIGSEGV in HTTPTransport::FindTransportPropertyIndex when no SOAPAction set --- Key: AXISCPP-689 URL: http://issues.apache.org/jira/browse/AXISCPP-689 Project: Axis-C++ Type: Bug Components

[jira] Resolved: (AXISCPP-689) SIGSEGV in HTTPTransport::FindTransportPropertyIndex when no SOAPAction set

2005-06-14 Thread Dushshantha Chandradasa (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-689?page=all ] Dushshantha Chandradasa resolved AXISCPP-689: - Resolution: Fixed Fixed. Made the do.. while loop a while loop with the same condition. > SIGSEGV in HTTPTransp

[jira] Closed: (AXISCPP-689) SIGSEGV in HTTPTransport::FindTransportPropertyIndex when no SOAPAction set

2005-06-14 Thread Dushshantha Chandradasa (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-689?page=all ] Dushshantha Chandradasa closed AXISCPP-689: --- Fixed and tested. > SIGSEGV in HTTPTransport::FindTransportPropertyIndex when no SOAPAction

[jira] Assigned: (AXISCPP-689) SIGSEGV in HTTPTransport::FindTransportPropertyIndex when no SOAPAction set

2005-06-14 Thread Dushshantha Chandradasa (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-689?page=all ] Dushshantha Chandradasa reassigned AXISCPP-689: --- Assign To: Dushshantha Chandradasa > SIGSEGV in HTTPTransport::FindTransportPropertyIndex when no SOAPAction

[jira] Created: (AXISCPP-1036) In HTTPTransport, CRLF is the http head separator

2007-08-16 Thread gaolijun (JIRA)
In HTTPTransport, CRLF is the http head separator - Key: AXISCPP-1036 URL: https://issues.apache.org/jira/browse/AXISCPP-1036 Project: Axis-C++ Issue Type: Bug Components: Transport

[jira] Closed: (AXISCPP-1036) In HTTPTransport, CRLF is the http head separator

2007-08-17 Thread nadir amra (JIRA)
say since the code is processing HTTP headers, searching for LF is valid since it does signify end of line. So it should really not make a difference. > In HTTPTransport, CRLF is the http head separator > - > > Key:

[jira] Created: (AXISCPP-518) Call to method getBytes of the class HTTPTransport never returns a value different from TRANSPORT_IN_PROGRESS

2005-03-08 Thread Arcangelo Di Balsamo (JIRA)
Call to method getBytes of the class HTTPTransport never returns a value different from TRANSPORT_IN_PROGRESS - Key: AXISCPP-518 URL: http://issues.apache.org/jira/browse

[jira] Updated: (AXISCPP-518) Call to method getBytes of the class HTTPTransport never returns a value different from TRANSPORT_IN_PROGRESS

2005-03-08 Thread Arcangelo Di Balsamo (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-518?page=history ] Arcangelo Di Balsamo updated AXISCPP-518: - Attachment: HTTPTrasportTestClient.zip HTTPTransport.cpp > Call to method getBytes of the class HTTPTransport ne

[jira] Updated: (AXISCPP-518) Call to method getBytes of the class HTTPTransport never returns a value different from TRANSPORT_IN_PROGRESS

2005-03-09 Thread Chinthana Danapala (JIRA)
the class HTTPTransport never returns a value > different from TRANSPORT_IN_PROGRESS > - > > Key: AXISCPP-518 > URL: http://issues.apache.org/jira/browse/AXISCPP-

[jira] Assigned: (AXISCPP-518) Call to method getBytes of the class HTTPTransport never returns a value different from TRANSPORT_IN_PROGRESS

2005-03-09 Thread Samisa Abeysinghe (JIRA)
[ http://issues.apache.org/jira/browse/AXISCPP-518?page=history ] Samisa Abeysinghe reassigned AXISCPP-518: - Assign To: Samisa Abeysinghe > Call to method getBytes of the class HTTPTransport never returns a value > differen

[jira] Closed: (AXISCPP-518) Call to method getBytes of the class HTTPTransport never returns a value different from TRANSPORT_IN_PROGRESS

2005-03-10 Thread Samisa Abeysinghe (JIRA)
tes of the class HTTPTransport never returns a value > different from TRANSPORT_IN_PROGRESS > - > > Key: AXISCPP-518 > URL: http://issues.apache.org/jira/