[B.A.T.M.A.N.] [PATCH 1/5] batman-adv: Rename bat_printk.c to compat.c

2011-05-04 Thread Sven Eckelmann
Signed-off-by: Sven Eckelmann s...@narfation.org --- Makefile.kbuild |2 +- bat_printk.c = compat.c |0 2 files changed, 1 insertions(+), 1 deletions(-) rename bat_printk.c = compat.c (100%) diff --git a/Makefile.kbuild b/Makefile.kbuild index 0a35006..d469668 100644 ---

[B.A.T.M.A.N.] [PATCH 4/5] batman-adv: convert call_rcu(neigh_node_free_rcu) to kfree()

2011-05-04 Thread Sven Eckelmann
From: Paul E. McKenney paul...@linux.vnet.ibm.com The RCU callback neigh_node_free_rcu() just calls kfree(), so we can use kfree_rcu() instead of call_rcu(). Signed-off-by: Paul E. McKenney paul...@linux.vnet.ibm.com Cc: Marek Lindner lindner_ma...@yahoo.de Cc: Simon Wunderlich

[B.A.T.M.A.N.] [PATCH 5/5] batman-adv: convert call_rcu(softif_neigh_free_rcu) to kfree_rcu

2011-05-04 Thread Sven Eckelmann
From: Paul E. McKenney paul...@linux.vnet.ibm.com The RCU callback softif_neigh_free_rcu() just calls kfree(), so we can use kfree_rcu() instead of call_rcu(). Signed-off-by: Paul E. McKenney paul...@linux.vnet.ibm.com Cc: Marek Lindner lindner_ma...@yahoo.de Cc: Simon Wunderlich

[B.A.T.M.A.N.] [PATCH] batman-adv: cosmetic: Use ethtool ethtool_cmd_speed API

2011-05-04 Thread Sven Eckelmann
From: David Decotigny de...@google.com This updates the network drivers so that they don't access the ethtool_cmd::speed field directly, but use ethtool_cmd_speed() instead. For most of the drivers, these changes are purely cosmetic and don't fix any problem, such as for those 1GbE/10GbE drivers

Re: [B.A.T.M.A.N.] [PATCHv2 3/4] batman-adv: improved roaming mechanism

2011-05-04 Thread Antonio Quartulli
On Wed, May 04, 2011 at 01:22:34PM +0200, Andrew Lunn wrote: +struct roam_adv_packet { + uint8_t packet_type; + uint8_t version; + uint8_t dst[6]; + uint8_t ttl; + uint8_t src[6]; + uint8_t client[6]; +} __packed; + Maybe put ttl at the end, to help with

Re: [B.A.T.M.A.N.] [PATCHv2 3/4] batman-adv: improved roaming mechanism

2011-05-04 Thread Andrew Lunn
On Wed, May 04, 2011 at 03:36:37PM +0200, Antonio Quartulli wrote: On Wed, May 04, 2011 at 01:22:34PM +0200, Andrew Lunn wrote: +struct roam_adv_packet { + uint8_t packet_type; + uint8_t version; + uint8_t dst[6]; + uint8_t ttl; + uint8_t src[6]; + uint8_t client[6];

Re: [B.A.T.M.A.N.] [PATCHv2 3/4] batman-adv: improved roaming mechanism

2011-05-04 Thread Antonio Quartulli
On Wed, May 04, 2011 at 03:52:23PM +0200, Andrew Lunn wrote: On Wed, May 04, 2011 at 03:36:37PM +0200, Antonio Quartulli wrote: On Wed, May 04, 2011 at 01:22:34PM +0200, Andrew Lunn wrote: +struct roam_adv_packet { + uint8_t packet_type; + uint8_t version; +

Re: [B.A.T.M.A.N.] [PATCH] batman-adv: remove misplaced comment

2011-05-04 Thread Marek Lindner
On Monday 02 May 2011 16:55:13 Sven Eckelmann wrote: On Monday 02 May 2011 16:38:17 Marek Lindner wrote: Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- originator.c |2 -- 1 files changed, 0 insertions(+), 2 deletions(-) diff --git a/originator.c b/originator.c

Re: [B.A.T.M.A.N.] [PATCHv2] batman-adv: multi vlan support for bridge loop detection

2011-05-04 Thread Marek Lindner
On Sunday 01 May 2011 16:41:13 Marek Lindner wrote: The bridge loop detection for batman-adv allows the bat0 interface to be bridged into an ethernet segment which other batman-adv nodes are connected to. In order to also allow multiple VLANs on top of the bat0 interface to be bridged into the

Re: [B.A.T.M.A.N.] [PATCH 1/2] batman-adv: Remove unnecessary hardif_list_lock

2011-05-04 Thread Marek Lindner
On Tuesday 03 May 2011 11:51:38 Linus Lüssing wrote: hardif_list_lock is unneccessary because we already ensure that no multiple admin operations can take place through rtnl_lock. hardif_list_lock only adds additional overhead and complexity. Critical functions now check whether they are

Re: [B.A.T.M.A.N.] [PATCH 2/2] batman-adv: Avoid deadlock between rtnl_lock and s_active

2011-05-04 Thread Marek Lindner
On Tuesday 03 May 2011 13:10:06 Linus Lüssing wrote: From: Sven Eckelmann s...@narfation.org The hard_if_event is called by the notifier with rtnl_lock and tries to remove sysfs entries when a NETDEV_UNREGISTER event is received. This will automatically take the s_active lock. The

[B.A.T.M.A.N.] [PATCH-Marek 2/5] batman-adv: Add compatibility code for kfree_rcu

2011-05-04 Thread Sven Eckelmann
Signed-off-by: Sven Eckelmann s...@narfation.org --- compat.c | 30 +- compat.h | 10 ++ 2 files changed, 39 insertions(+), 1 deletions(-) diff --git a/compat.c b/compat.c index f4561c3..67c5126 100644 --- a/compat.c +++ b/compat.c @@ -1,4 +1,4 @@

[B.A.T.M.A.N.] [PATCH] batman-adv: Fix rcu_lock imbalance in softif_neigh_get

2011-05-04 Thread Sven Eckelmann
Fix extra rcu_read_unlock after an failed softif_neigh_vid_get in softif_neigh_get introduced by 0281a6aab718965d7c0ef45c4ba22e305f6aefe7 Signed-off-by: Sven Eckelmann s...@narfation.org --- soft-interface.c |7 --- 1 files changed, 4 insertions(+), 3 deletions(-) diff --git

[B.A.T.M.A.N.] [PATCH] batctl: rename stuff from *hna* to *tt* (translation table)

2011-05-04 Thread Antonio Quartulli
To be coherent, all the functions/variables/constats have been renamed to the TranslationTable style Signed-off-by: Antonio Quartulli or...@autistici.org --- README | 18 +- packet.h |2 +- sys.c|2 +- vis.c| 34 +- 4 files

Re: [B.A.T.M.A.N.] [PATCH] batman-adv: Fix rcu_lock imbalance in softif_neigh_get

2011-05-04 Thread Marek Lindner
On Wednesday 04 May 2011 21:14:58 Sven Eckelmann wrote: Fix extra rcu_read_unlock after an failed softif_neigh_vid_get in softif_neigh_get introduced by 0281a6aab718965d7c0ef45c4ba22e305f6aefe7 Good catch! Applied in revision 3c56ec9. Thanks, Marek

[B.A.T.M.A.N.] [PATCHv2] batctl: rename stuff from *hna* to *tt* (translation table)

2011-05-04 Thread Antonio Quartulli
To be coherent, all the functions/variables/constats have been renamed to the TranslationTable style Signed-off-by: Antonio Quartulli or...@autistici.org --- README | 18 +- man/batctl.8 | 12 ++-- packet.h |2 +- sys.c|2 +- vis.c|