[PATCH 2/7] mtd: Fix mtdraw for Nand > 4GiB

2016-02-09 Thread Sascha Hauer
The mtdraw code has some casts to avoid 64bit divisions. For Chips >4GiB using 64bit types become necessary, so use them and to the necessary 64bit math. Signed-off-by: Sascha Hauer --- drivers/mtd/mtdraw.c | 53 1

[PATCH] mtd: >4GiB fixes

2016-02-09 Thread Sascha Hauer
This series has several fixes to make mtd devices >4GiB usable. We had several places where we still used 32bit types, these are converted to 64bit types here. Also included is a fix for 8KiB Nand page size. Sascha Sascha Hauer

Re: [PATCH 2/2] i.MX habv3: add some more status codes

2016-02-09 Thread Sascha Hauer
On Mon, Feb 08, 2016 at 11:15:24AM +0100, Marc Kleine-Budde wrote: > Signed-off-by: Marc Kleine-Budde > --- > drivers/hab/habv3.c | 4 > 1 file changed, 4 insertions(+) > > diff --git a/drivers/hab/habv3.c b/drivers/hab/habv3.c > index 204b9095b393..82ae245f8a03 100644

[PATCH 4/7] mtd: Fix mtd_op_read for devices >4GiB

2016-02-09 Thread Sascha Hauer
The mtd read file operation has a unnecessary conversion to unsigned long in the read offset. Remove it to make it work with chips >4GiB Signed-off-by: Sascha Hauer --- drivers/mtd/core.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git

[PATCH 3/7] mtd: Make erase_info structs 64bit where necessary

2016-02-09 Thread Sascha Hauer
Make the userspace structs 64bit where necessary. Since we do not have separated kernel/userspace in barebox we can just modifiy the original structs instead of adding separate 64bit structs. Signed-off-by: Sascha Hauer --- drivers/mtd/core.c | 2 +-

[PATCH 6/7] mtd: Fix erasing of devices >4GiB

2016-02-09 Thread Sascha Hauer
When a device >4GiB is erased, not only the offset can be bigger than 4GiB, but also the size. This happens with the simplest command to erase a device: erase /dev/nand0. Make the size argument a 64bit type to make this work. Signed-off-by: Sascha Hauer ---

[PATCH 7/7] mtd: mtdoob device: change name to have the chip name first

2016-02-09 Thread Sascha Hauer
Normally all device files assoctiated to a mtd device begin with the chip name itself. Only the mtdoob device is an exception: it begins with the chip name without the index end ends with the index. Change the name to be like the other names, i.e. change nand_oob0 to nand0.oob. Signed-off-by:

[PATCH 5/7] mtd: Fix mtd_op_erase for devices >4GiB

2016-02-09 Thread Sascha Hauer
The mtd erase file operation has a unnecessary conversion to unsigned long in the offset. Remove it to make it work with chips >4GiB. Signed-off-by: Sascha Hauer --- drivers/mtd/core.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH 1/7] mtd: nand-bb: Fix 8k page size nands

2016-02-09 Thread Sascha Hauer
As the comment states BB_WRITEBUF_SIZE must be a multiple of the largest NAND page size. Since this is 8192 and not 4096, change it accordingly. Signed-off-by: Sascha Hauer --- drivers/mtd/nand/nand-bb.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH 5/5] Documentation: commands: remove autogenerated directory on mrproper

2016-02-09 Thread Robert Schwebel
On 'make mrproper', remove the directory hierarchy autogenerated with 'make docs'. Signed-off-by: Robert Schwebel --- Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Makefile b/Makefile index 73fb09b..5c5b85c 100644 --- a/Makefile +++

[PATCH 1/5] Documentation: booting linux: improve wording

2016-02-09 Thread Robert Schwebel
'bootm' is the lowlevel boot command, in contrast to 'boot', which is more highlevel. Signed-off-by: Robert Schwebel --- Documentation/user/booting-linux.rst | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/Documentation/user/booting-linux.rst

[PATCH 2/5] Documentation: m25p80: include in documentation

2016-02-09 Thread Robert Schwebel
Fix this warning: checking consistency... [...]Documentation/devicetree/bindings/mtd/m25p80.rst:: WARNING: document isn't included in any toctree by including the document. Signed-off-by: Robert Schwebel --- Documentation/devicetree/index.rst | 1 + 1 file

[PATCH 4/5] ratp: remove unused ratp_close command

2016-02-09 Thread Robert Schwebel
This is a leftover from development, remove. Signed-off-by: Robert Schwebel --- common/ratp.c | 16 +--- 1 file changed, 1 insertion(+), 15 deletions(-) diff --git a/common/ratp.c b/common/ratp.c index 2fef3cc..e879e2b 100644 --- a/common/ratp.c +++

Re: [PATCH 1/5] Documentation: booting linux: improve wording

2016-02-09 Thread Sascha Hauer
On Tue, Feb 09, 2016 at 05:01:20PM +0100, Robert Schwebel wrote: > 'bootm' is the lowlevel boot command, in contrast to 'boot', which is > more highlevel. > > Signed-off-by: Robert Schwebel Applied, thanks Sascha -- Pengutronix e.K. |