Re: [PATCH v3 3/3] sandbox: add i2c and spi libftdi1 bit-bang example

2018-01-28 Thread Sascha Hauer
On Fri, Jan 26, 2018 at 11:37:46AM +0300, Antony Pavlov wrote: > On Thu, 25 Jan 2018 08:12:36 +0100 > Sascha Hauer wrote: > > > On Mon, Jan 22, 2018 at 12:59:18PM +0300, Antony Pavlov wrote: > > > Make necessary changes in sandbox_defconfig: > > > enable gpio, spi, i2c

Re: [PATCH] fs: Fix memory leak in mount()

2018-01-28 Thread Sascha Hauer
Hi Sam, On Fri, Jan 26, 2018 at 10:10:25PM +0100, Sam Ravnborg wrote: > Hi Sasha. > > On Fri, Jan 26, 2018 at 08:42:27PM +0100, Sascha Hauer wrote: > > "path" is allocated by normalise_path() and thus must be > > freed. This was done in the error path, but not in the success > > path. > > > >

[PATCH] ratp: remove unused list pointer from ratp_bb_pkt

2018-01-28 Thread Aleksander Morgado
This struct type is used in the RATP FS implementation, but was never used as a list element anywhere. Signed-off-by: Aleksander Morgado --- include/ratp_bb.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/include/ratp_bb.h b/include/ratp_bb.h index

[PATCH] ratp: move barebox-specific command to ratp_bb.h

2018-01-28 Thread Aleksander Morgado
The ratp_run_command() is really an implementation detail of the barebox ratp 'command' operation support. Move it to the barebox specific header and rename it with the correct prefix. Signed-off-by: Aleksander Morgado --- common/ratp.c | 2 +- include/ratp.h|

[PATCH] ratp: rename global context variable

2018-01-28 Thread Aleksander Morgado
The 'ratp_command_ctx' seems to specify that this variable is only used to process command operations, but it really is used in every async operation (e.g. also in FS), so just rename it to a more generic name for clarity. Signed-off-by: Aleksander Morgado ---

[PATCH] of: base: fix segfault in of_get_machine_compatible()

2018-01-28 Thread Aleksander Morgado
This is running the barebox sandbox: Thread 1 "barebox" received signal SIGSEGV, Segmentation fault. 0x55579e2b in _strchr (s=s@entry=0x0, c=c@entry=44) at lib/string.c:251 251 for(; *s != (char) c; ++s) (gdb) bt #0 0x55579e2b in _strchr (s=s@entry=0x0,

[PATCH] bbremote: rename command subparser variables

2018-01-28 Thread Aleksander Morgado
Don't reuse unrelated subparser variables for new command subparsers, make each subparser have its own variable. Just for consistency really, not a bugfix. Signed-off-by: Aleksander Morgado --- scripts/remote/main.py | 14 +++--- 1 file changed, 7