Re: [PATCH] version_string: Add toolchain and build host info

2019-10-07 Thread Andrey Smirnov
On Mon, Sep 30, 2019 at 11:03 PM Antony Pavlov wrote: > > On Mon, 30 Sep 2019 17:57:18 -0700 > Andrey Smirnov wrote: > > Hi! > > > Linux kernel reports the version of toolchain it was built with as a > > part of its version string, which can be extremely useful when > > debugging toolchain relate

[PATCH 2/2] ARM: dts: vf610-zii-scu4-aib: Add "i2c-mux-idle-disconnect" to I2C muxes

2019-10-07 Thread Andrey Smirnov
Add "i2c-mux-idle-disconnect" to I2C muxes to prevent identical slaves from different segments from interfering with each other. Signed-off-by: Andrey Smirnov --- arch/arm/dts/vf610-zii-scu4-aib.dts | 8 1 file changed, 8 insertions(+) diff --git a/arch/arm/dts/vf610-zii-scu4-aib.dts

[PATCH 1/2] i2c-mux-pca954x: Add support for "i2c-mux-idle-disconnect"

2019-10-07 Thread Andrey Smirnov
Add support for "i2c-mux-idle-disconnect" binding to match the behavior, already present in upstream kernel driver. This feature is a must have for I2C bus topologies with multiple muxes connected to child segments containing slaves with identical addresses (e.g. ZII's SCU4) Signed-off-by: Andrey

[PATCH] Documentation: zii-vf610-dev: Fix bogus DDR configuration values

2019-10-07 Thread Andrey Smirnov
There's a clear mismatch between actual TCL code and comment right next to it. Comments are definetly right, so fix the TCL code. Fixes: 02738f4b59 ("Documentation: zii-vf610-dev: Reconcile DDR setup with DCD") Signed-off-by: Andrey Smirnov --- Documentation/boards/imx/zii-vf610-dev/openocd.cfg

erroneous behavior for iMX+GPT

2019-10-07 Thread Middelschulte, Leif
Hi, setting up GPT on an iMX6, I noticed a small bug subject to CONFIG_PARTITION_DISK_EFI_GPT_NO_FORCE that leads to unparsed GPTs. Background: The iMX supports the mmc user partition as bootmedia source too. Problem: The (additional) filetype check[0] fails, if the given buffer contains multi

[PATCH] ARM: use system.h's get_cr() for cpuinfo

2019-10-07 Thread Ahmad Fatoum
Instead of open-coding the get_cr(), use the already available helper in same as we do for 64-bit ARMv8. The only difference is that the "memory" clobber is replaced by "cc". This is ok as we don't expect get_cr() to affect memory and because we do it elsewhere in barebox without a "memory" clobbe