Re: [PATCH 4/6] usb: string: Use le16_to_cpu for langid

2019-10-10 Thread Andrey Smirnov
On Thu, Oct 10, 2019 at 1:15 AM Jules Maselbas wrote: > > This might fix an endianness bug when the cpu is big-endian > as the string_langid will be converted with `cpu_to_le16` when > sending a control message to get a string descriptor. > > Signed-off-by: Jules Maselbas > --- >

MFGTools from NXP

2019-10-10 Thread Mihaita Ivascu
Hello all, Does anybody have experience with using MFGTools to flash the barebox and kernel in NAND for imx6ul platforms? Thanks, Mihaita ___ barebox mailing list barebox@lists.infradead.org

[PATCH 3/6] usb: string: Use dma_alloc instead of a local buffer

2019-10-10 Thread Jules Maselbas
Stack allocated buffer can cause difficulties for some SoCs use dma_alloc as done in usb_new_device. Signed-off-by: Jules Maselbas --- drivers/usb/core/usb.c | 15 ++- 1 file changed, 10 insertions(+), 5 deletions(-) diff --git a/drivers/usb/core/usb.c b/drivers/usb/core/usb.c

[PATCH 6/6] usb: string: Minor changes

2019-10-10 Thread Jules Maselbas
This is mostly cosmetic changes except it adds a test in case dma_alloc failed, the boolean have_langid will will now take the value 1 when set (instead of -1) and now characters with a value above 0x7f (outside ASCII range) will also be converted to '?'. Signed-off-by: Jules Maselbas ---

[PATCH 4/6] usb: string: Use le16_to_cpu for langid

2019-10-10 Thread Jules Maselbas
This might fix an endianness bug when the cpu is big-endian as the string_langid will be converted with `cpu_to_le16` when sending a control message to get a string descriptor. Signed-off-by: Jules Maselbas --- drivers/usb/core/usb.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH 1/6] usb: hub: Use more accurate struct name

2019-10-10 Thread Jules Maselbas
Both structures usb_hub_status and usb_port_status have the same fields, only the name differ. Signed-off-by: Jules Maselbas --- drivers/usb/core/hub.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c index d01a01607..91a938567

[PATCH 2/6] usb: hub: Only clear port reset status if set

2019-10-10 Thread Jules Maselbas
Signed-off-by: Jules Maselbas --- drivers/usb/core/hub.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c index 91a938567..910a87021 100644 --- a/drivers/usb/core/hub.c +++ b/drivers/usb/core/hub.c @@ -158,7 +158,8 @@ int

[PATCH 5/6] usb: string: size_t is unsigned

2019-10-10 Thread Jules Maselbas
Testing if size_t is negative is not needed as size_t is unsigned. Signed-off-by: Jules Maselbas --- drivers/usb/core/usb.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/usb/core/usb.c b/drivers/usb/core/usb.c index 5dc7993ac..e34cb5bf2 100644 ---