[PATCH v2 08/10] fastboot: rename usbgadget.fastboot_* variables to fastboot.*

2020-05-14 Thread Daniel Glöckner
There is nothing USB-specific in the defined usbgadget.fastboot_* variables. Rename them to be usable also for the UDP fastboot transport. The usbgadget.fastboot_function variable is used to define the files and devices accessible with the erase and flash commands. Since "function" is a term from

[PATCH v2 05/10] ratp: use poller to run ratp commands

2020-05-14 Thread Daniel Glöckner
With the new idle slice there is no longer a need to have a dedicated hook for RATP inside readline. Switch to a poller that depends on the idle slice to execute the commands received over RATP. Signed-off-by: Daniel Glöckner --- common/ratp/ratp.c | 12 +++- include/ratp_bb.h | 1 -

[PATCH v2 07/10] defconfigs: update renamed fastboot options

2020-05-14 Thread Daniel Glöckner
The split of the generic Fastboot code from the Fastboot USB gadget included renaming the CONFIG_USB_GADGET_FASTBOOT_* options to CONFIG_FASTBOOT_*. Update all defconfigs to use the new names. Signed-off-by: Daniel Glöckner --- arch/arm/configs/imx23_defconfig | 2 +-

[PATCH v2 00/10] Support for Fastboot over UDP

2020-05-14 Thread Daniel Glöckner
This v2 of the Fastboot over UDP code is based on the slice patch series posted on April 22. Strictly necessary for Fastboot over UDP are only the patches 4, 6, 8, and 9. The others touch related code but can be omitted if desired. Changes since v1: - Add idle slice to execute commands when

[PATCH v2 06/10] fastboot: split generic code from USB gadget

2020-05-14 Thread Daniel Glöckner
From: Edmund Henniges The fastboot specification describes other protocols beyond USB. Allow these to reuse the generic parts of the existing fastboot code when they are implemented. Most of the changes in common/fastboot.c are due to the renaming of struct f_fastboot *f_fb to struct fastboot

[PATCH v2 09/10] fastboot net: implement fastboot over UDP

2020-05-14 Thread Daniel Glöckner
From: Edmund Henniges This implements the UDP variant of the fastboot protocol. The only way to start the service for now is to compile with CONFIG_FASTBOOT_NET_ON_BOOT. The service will bind to the network interface that provides the IPv4 gateway. Sending an OKAY packet before performing a

[PATCH v2 10/10] fastboot: don't close fd 0 when downloading to ram

2020-05-14 Thread Daniel Glöckner
When downloading to a buffer, download_fd is never assigned a valid file descriptor. We should therefore avoid calling close on the value found in that variable. Signed-off-by: Daniel Glöckner --- common/fastboot.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git

[PATCH v2 03/10] poller: adapt remaining users to API change

2020-05-14 Thread Daniel Glöckner
poller_register now has a second parameter. Signed-off-by: Daniel Glöckner --- arch/arm/boards/mioa701/gpio0_poweroff.c | 2 +- arch/arm/boards/sama5d3xek/init.c| 2 +- drivers/net/usb/ax88179_178a.c | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) diff --git

[PATCH v2 04/10] Introduce idle slice

2020-05-14 Thread Daniel Glöckner
Some code can't foresee which resources will be used by its poller. This is the case especially in pollers that will execute arbitrary commands input by the user. With this commit a special slice is introduced that is released only when Barebox is waiting for console input and only when it is

[PATCH v2 02/10] net: fixed-link phys are never acquired

2020-05-14 Thread Daniel Glöckner
Fixed-link phys have their bus field set to NULL. This causes a crash when phy_acquired tries to check the slice of the bus. Signed-off-by: Daniel Glöckner --- include/linux/phy.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/phy.h b/include/linux/phy.h index

[PATCH v2 01/10] Remove CONFIG_SLICE

2020-05-14 Thread Daniel Glöckner
Since we are unconditionally compiling and linking the slice code, it does not make sense to have a config option that depends on CONFIG_POLLER. The CONFIG_SLICE option was also broken because it was missing the "bool" line to denote its type. Signed-off-by: Daniel Glöckner --- commands/Kconfig

[PATCH] ARM: dts: imx6: phycard: remove baseboard compatible

2020-05-14 Thread Robert Karszniewicz
This devicetree isn't baseboard-specific, so keep it compatible at SOM-level. Signed-off-by: Robert Karszniewicz --- arch/arm/dts/imx6q-phytec-phycard.dts | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/arm/dts/imx6q-phytec-phycard.dts