Re: [PATCH v1 3/9] net: add DSA framework to support basic switch functionality

2022-03-28 Thread Oleksij Rempel
On Mon, Mar 28, 2022 at 12:31:39PM +0200, Sascha Hauer wrote: > On Mon, Mar 21, 2022 at 10:26:00AM +0100, Oleksij Rempel wrote: > +static void dsa_port_set_ethaddr(struct eth_device *edev) > > +{ > > + struct dsa_port *dp = edev->priv; > > + struct dsa_switch *ds = dp->ds; > > + > > + if

[PATCH v1 1/1] ARM: boards: protonic-imx6: fix file system access warning

2022-03-28 Thread Oleksij Rempel
We should not access a file system from the poller. So, do it from the worker. This patch will fix warning on FS access for Protonic board code. Signed-off-by: Oleksij Rempel --- arch/arm/boards/protonic-imx6/board.c | 22 +++--- 1 file changed, 11 insertions(+), 11 deletions(-)

Re: [PATCH v1 9/9] net: dsa: add support for SJA11xx switches

2022-03-28 Thread Sascha Hauer
On Mon, Mar 21, 2022 at 10:26:06AM +0100, Oleksij Rempel wrote: > Port SJA11xx driver from u-boot v2022.04-rc2 to provide support for NXP > SJA11xx > series of switches. > > Signed-off-by: Oleksij Rempel > --- > drivers/net/Kconfig | 17 + > drivers/net/Makefile |1 + >

Re: [PATCH v1 3/9] net: add DSA framework to support basic switch functionality

2022-03-28 Thread Sascha Hauer
On Mon, Mar 21, 2022 at 10:26:00AM +0100, Oleksij Rempel wrote: > Add DSA based port multiplexing functionality for barebox. With this > framework we will be able to use different ports of as switch > separately. > > Signed-off-by: Oleksij Rempel > --- > drivers/net/Kconfig | 3 + >

Re: [PATCH] crypto: Followup to crypto symbol renaming for algo registration

2022-03-28 Thread Sascha Hauer
On Tue, Mar 22, 2022 at 10:00:07AM +0100, Uwe Kleine-König wrote: > The symbols were renamed to a nicer and consistent naming scheme, but I > missed to adapt a few usages. > > This was done using: > > perl -p -i -e >

Re: [PATCH 2/4] mci: mci_spi: extend driver for device tree probing

2022-03-28 Thread Ahmad Fatoum
Hello Sascha, On 28.03.22 11:44, Sascha Hauer wrote: > On Sat, Mar 19, 2022 at 08:24:08AM +0100, Ahmad Fatoum wrote: >> Driver has been matched by name only so far, add optional support for >> the device tree binding. >> >> Signed-off-by: Ahmad Fatoum >> --- >> drivers/mci/mci_spi.c | 31

Re: [PATCH 1/4] spi: Port SiFive SPI controller driver

2022-03-28 Thread Sascha Hauer
On Sat, Mar 19, 2022 at 08:24:07AM +0100, Ahmad Fatoum wrote: > Import the U-Boot v2022.04-rc2 driver to enable access to SPI flash and > SD over SPI on the HiFive Unleashed. Tested with QEMU. > > Signed-off-by: Ahmad Fatoum > --- > drivers/spi/Kconfig | 6 + > drivers/spi/Makefile |

Re: [PATCH 2/4] mci: mci_spi: extend driver for device tree probing

2022-03-28 Thread Sascha Hauer
On Sat, Mar 19, 2022 at 08:24:08AM +0100, Ahmad Fatoum wrote: > Driver has been matched by name only so far, add optional support for > the device tree binding. > > Signed-off-by: Ahmad Fatoum > --- > drivers/mci/mci_spi.c | 31 +++ > 1 file changed, 31 insertions(+)

Re: [PATCH] sandbox: board: add stickypage.bin into .gitignore

2022-03-28 Thread Sascha Hauer
On Fri, Mar 18, 2022 at 04:30:47PM +0100, Ahmad Fatoum wrote: > Otherwise, it shows up in version control for in-tree builds. > > Signed-off-by: Ahmad Fatoum > --- > arch/sandbox/board/.gitignore | 1 + > 1 file changed, 1 insertion(+) Applied, thanks Sascha > > diff --git

Re: [PATCH] scripts: remove non-existent bareboxstate binaries from .gitignore

2022-03-28 Thread Sascha Hauer
On Fri, Mar 18, 2022 at 04:28:51PM +0100, Ahmad Fatoum wrote: > barebox builds no tools with these names. The normal barebox-state > utility comes from dt-utils, so drop the unnecessary entries. > > Signed-off-by: Ahmad Fatoum > --- > scripts/.gitignore | 2 -- > 1 file changed, 2 deletions(-)

Re: [PATCH] libfile: implement new pread_full

2022-03-28 Thread Sascha Hauer
On Fri, Mar 18, 2022 at 03:49:42PM +0100, Ahmad Fatoum wrote: > We already have pwrite_full, add pread_full for symmetry. > > Signed-off-by: Ahmad Fatoum > --- > include/libfile.h | 1 + > lib/libfile.c | 25 + > 2 files changed, 26 insertions(+) Applied, thanks

Re: [PATCH] scripts: constify wirte_full input buffer

2022-03-28 Thread Sascha Hauer
On Fri, Mar 18, 2022 at 03:49:24PM +0100, Ahmad Fatoum wrote: > Buffer written is read-only, so align prototype with . > > Signed-off-by: Ahmad Fatoum > --- > scripts/common.c | 2 +- > scripts/common.h | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) Applied with

Re: [PATCH] partitions: efi: print GPT offset in debug message

2022-03-28 Thread Sascha Hauer
On Sat, Mar 19, 2022 at 08:24:27AM +0100, Ahmad Fatoum wrote: > This debug message is printed for the alternative GPT header as well, > which may not exist at that location, because the medium has a different > length than what's in the GPT header. Make it easier to differentiate, > whether the

Re: [PATCH] ARM: asm: setjmp: add missing .pop_section

2022-03-28 Thread Sascha Hauer
On Sat, Mar 19, 2022 at 08:43:35AM +0100, Ahmad Fatoum wrote: > This fixes a mismatched .push_section. This had no effect, because the > file ended after the follow-up .push_section. > > Signed-off-by: Ahmad Fatoum > --- > arch/arm/lib32/setjmp.S | 1 + > 1 file changed, 1 insertion(+)

Re: [PATCH master 0/6] usb: gadget: multi: fix bind error path

2022-03-28 Thread Sascha Hauer
On Sat, Mar 19, 2022 at 12:02:40PM +0100, Ahmad Fatoum wrote: > USB mass storage gadget may fail during bind. USB multi gadget error > path for failed bind is broken. USB mass storage gadget unbind leaks > resources. Fix these three issues. > > Ahmad Fatoum (6): > usb: gadget: implement and use

Re: [PATCH v1 1/2] ARM: boards: protonic-imx6: add board specific BBU SD handlers

2022-03-28 Thread Sascha Hauer
On Mon, Mar 21, 2022 at 10:21:02AM +0100, Oleksij Rempel wrote: > Add barebox update handler for the SD ports. > > Signed-off-by: Oleksij Rempel > --- > arch/arm/boards/protonic-imx6/board.c | 34 +++ > 1 file changed, 34 insertions(+) Applied, thanks Sascha > > diff

Re: [PATCH] gpio: include header for BIT() used in

2022-03-28 Thread Sascha Hauer
On Mon, Mar 21, 2022 at 12:11:15PM +0100, Ahmad Fatoum wrote: > From: Ahmad Fatoum > > e.g. GPIOF_ACTIVE_HIGH/LOW uses currently depend on another header > defining BIT(). Remedy this. > > Signed-off-by: Ahmad Fatoum > --- > include/gpio.h | 1 + > 1 file changed, 1 insertion(+) Applied,

Re: [PATCH 1/2] net: phy: mv88e6xxx: implement port_set_speed for mv88e6250

2022-03-28 Thread Sascha Hauer
On Mon, Mar 21, 2022 at 02:16:31PM +0100, Steffen Trumtrar wrote: > From: Steffen Trumtrar > > barebox port of the linux patch: > > commit a528e5be6b5f8026eda029b03340dcfa23c70824 > Author: Rasmus Villemoes > Date: Tue Jun 4 07:34:29 2019 + > > net: dsa: mv88e6xxx: implement

Re: [PATCH v2 1/3] ARM: webasto-ccbv2: consider the available memory size for optee

2022-03-28 Thread Sascha Hauer
On Mon, Mar 21, 2022 at 03:08:54PM +0100, Juergen Borleis wrote: > Signed-off-by: Juergen Borleis > --- > arch/arm/boards/webasto-ccbv2/lowlevel.c | 8 > 1 file changed, 4 insertions(+), 4 deletions(-) Applied, thanks Sascha > > diff --git a/arch/arm/boards/webasto-ccbv2/lowlevel.c

Re: [PATCH] ARM: dts: stm32mp: remove no-longer required DT override

2022-03-28 Thread Sascha Hauer
On Tue, Mar 22, 2022 at 02:25:45PM +0100, Ahmad Fatoum wrote: > These same properties have been available in the upstream DT since > Linux commit c9669b4692ce ("ARM: dts: stm32: add usbphyc vdda1v1 > and vdda1v8 supplies on stm32mp151") imported to barebox with > commit f826d85b7ab0 ("dts: update