Re: [Beignet] [PATCH] correct L3 cache settings for baytrail

2014-05-22 Thread Guo, Yejun
, May 22, 2014 5:06 PM To: Guo, Yejun; Song, Ruiling; beignet@lists.freedesktop.org Subject: RE: [Beignet] [PATCH] correct L3 cache settings for baytrail I agree with both of you. The gpgpu_l3_config_reg magic number array is really too confusing to understand. If those registers' definition

[Beignet] [PATCH V2] correct L3 cache settings for baytrail

2014-05-22 Thread Guo Yejun
baytrail and ivb have different register bits layout for L3 cache, so, add a special path for baytrail. Signed-off-by: Guo Yejun yejun@intel.com --- src/intel/intel_gpgpu.c | 30 +- 1 file changed, 29 insertions(+), 1 deletion(-) diff --git a/src/intel

[Beignet] [PATCH] separate runtime(libcl.so) and compiler(libgbe.so)

2014-05-09 Thread Guo Yejun
other .cpp files; to make libinterp.a small (the purpose to make libcl.so small), the macro GBE_COMPILER_AVAILABLE is used to make only the needed code active when build for libinterp.a. Signed-off-by: Guo Yejun yejun@intel.com --- backend/CMakeLists.txt | 3 ++ backend/src

[Beignet] [PATCH] do not serialize zero image/sampler info into binary

2014-05-06 Thread Guo Yejun
if there is no image/sampler used in kernel source, it is not necessary to serialize the zero image/sampler info into kernel binary. Signed-off-by: Guo Yejun yejun@intel.com --- backend/src/backend/program.cpp | 8 ++-- backend/src/backend/program.hpp | 4 ++-- backend/src/ir/image.hpp

[Beignet] [PATCH] fix typo when check local size with work dim

2014-04-24 Thread Guo Yejun
Signed-off-by: Guo Yejun yejun@intel.com --- src/cl_command_queue_gen7.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/cl_command_queue_gen7.c b/src/cl_command_queue_gen7.c index 891d6f1..90e275d 100644 --- a/src/cl_command_queue_gen7.c +++ b/src

Re: [Beignet] [PATCH] fix typo when check local size with work dim

2014-04-24 Thread Guo, Yejun
oh, yes, you are right, it is not a typo. Thanks Yejun -Original Message- From: Zhigang Gong [mailto:zhigang.g...@linux.intel.com] Sent: Friday, April 25, 2014 11:35 AM To: Guo, Yejun; beignet@lists.freedesktop.org Subject: RE: [Beignet] [PATCH] fix typo when check local size with work

[Beignet] [PATCH] add support for cross compiler

2014-04-23 Thread Guo Yejun
Signed-off-by: Guo Yejun yejun@intel.com --- CMake/FindLLVM.cmake | 2 +- backend/src/CMakeLists.txt | 8 2 files changed, 5 insertions(+), 5 deletions(-) diff --git a/CMake/FindLLVM.cmake b/CMake/FindLLVM.cmake index 97ee7db..556b3a9 100644 --- a/CMake/FindLLVM.cmake +++ b

[Beignet] [PATCH 2/2] add test for __gen_ocl_simd_any and __gen_ocl_simd_all

2014-04-18 Thread Guo Yejun
Signed-off-by: Guo Yejun yejun@intel.com --- kernels/compiler_simd_all.cl | 12 kernels/compiler_simd_any.cl | 15 +++ utests/CMakeLists.txt| 2 ++ utests/compiler_simd_all.cpp | 43 +++ utests/compiler_simd_any.cpp

[Beignet] [PATCH 1/2] support __gen_ocl_simd_any and __gen_ocl_simd_all

2014-04-18 Thread Guo Yejun
: for(; ; ) { ... if (__gen_ocl_simd_any(...)) break; //the whole SIMD stop the searching } Signed-off-by: Guo Yejun yejun@intel.com --- backend/src/backend/gen_insn_selection.cpp | 63 ++ backend/src/ir/instruction.hpp | 4 ++ backend/src/ir/instruction.hxx | 2

Re: [Beignet] [PATCH] merge some state buffers into one buffer

2014-03-06 Thread Guo, Yejun
, March 07, 2014 11:14 AM To: Guo, Yejun; beignet@lists.freedesktop.org Cc: Guo, Yejun Subject: RE: [Beignet] [PATCH] merge some state buffers into one buffer 2 comments. -Original Message- From: beignet-boun...@lists.freedesktop.org [mailto:beignet-boun...@lists.freedesktop.org] On Behalf

[Beignet] [PATCH] GBE: show correct line number in build log

2014-02-27 Thread Guo Yejun
Sometimes, we insert some code into the kernel, it makes the line number reported in build log mismatch with the line number in the kernel from programer's view, use #line to correct it. Signed-off-by: Guo Yejun yejun@intel.com --- backend/src/backend/program.cpp |5 + 1 file changed

[Beignet] [PATCH] GBE: support getelementptr with ConstantExpr operand

2014-02-26 Thread Guo Yejun
Add support during LLVM IR - Gen IR period when the first operand of getelementptr is ConstantExpr. utest is also added. Signed-off-by: Guo Yejun yejun@intel.com --- backend/src/llvm/llvm_gen_backend.cpp | 10 +- kernels/compiler_getelementptr_bitcast.cl | 18 +++ utests

[Beignet] [PATCH V3] GBE: add param to switch the behavior of math func

2014-02-17 Thread Guo Yejun
support will be added later. Signed-off-by: Guo Yejun yejun@intel.com --- backend/src/backend/program.cpp | 12 backend/src/builtin_vector_proto.def |4 backend/src/ocl_stdlib.tmpl.h|8 3 files changed, 24 insertions(+) diff --git a/backend/src

Re: [Beignet] [PATCH V2] GBE: add param to switch the behavior of math func

2014-02-14 Thread Guo, Yejun
use the function name like __gen_ocl_internal_fastpath_sin, do you think is it ok? Thanks. Thanks Yejun -Original Message- From: Zhigang Gong [mailto:zhigang.g...@linux.intel.com] Sent: Friday, February 14, 2014 3:04 PM To: Guo, Yejun Cc: beignet@lists.freedesktop.org Subject: Re

Re: [Beignet] [PATCH V2] GBE: add param to switch the behavior of math func

2014-02-14 Thread Guo, Yejun
[mailto:zhigang.g...@linux.intel.com] Sent: Friday, February 14, 2014 4:09 PM To: Guo, Yejun Cc: beignet@lists.freedesktop.org Subject: Re: [Beignet] [PATCH V2] GBE: add param to switch the behavior of math func On Fri, Feb 14, 2014 at 08:20:47AM +, Guo, Yejun wrote: With this design, we can

Re: [Beignet] [PATCH] BGE: add param to switch the behavior of math func

2014-02-13 Thread Guo, Yejun
, :( Thanks Yejun -Original Message- From: Zhigang Gong [mailto:zhigang.g...@linux.intel.com] Sent: Thursday, February 13, 2014 3:11 PM To: Guo, Yejun Cc: beignet@lists.freedesktop.org Subject: Re: [Beignet] [PATCH] BGE: add param to switch the behavior of math func One typo in the subject

[Beignet] [PATCH V2] GBE: add param to switch the behavior of math func

2014-02-13 Thread Guo Yejun
will be added later. Signed-off-by: Guo Yejun yejun@intel.com --- backend/CMakeLists.txt |3 ++- backend/src/CMakeLists.txt | 13 ++--- backend/src/GBEConfig.h.in |1 + backend/src/backend/program.cpp | 12 +++- backend/src/ocl_stdlib.tmpl.h

Re: [Beignet] [PATCH V2] GBE: add param to switch the behavior of math func

2014-02-13 Thread Guo, Yejun
error is very big. Thanks Yejun -Original Message- From: Sun, Yi Sent: Friday, February 14, 2014 9:28 AM To: Guo, Yejun; beignet@lists.freedesktop.org Cc: Guo, Yejun Subject: RE: [Beignet] [PATCH V2] GBE: add param to switch the behavior of math func BTW, what kind of precision can

[Beignet] [PATCH V2] GBE: use native exp instruction when enough precision

2014-01-20 Thread Guo Yejun
for the input data with enough precision, use the native exp instruction, otherwise, use the software path to emulate the exp function. Signed-off-by: Guo Yejun yejun@intel.com --- backend/src/backend/gen_insn_selection.cpp |1 + backend/src/ir/instruction.hpp |2

<    1   2   3   4