Re: gnulib-tool --lgpl exception for self tests?

2005-10-24 Thread Paul Eggert
Simon Josefsson <[EMAIL PROTECTED]> writes: > I think it would be fine to include GPL self tests in a LGPL > project Me too. > Should there be a "gnulib-tool --lgpl --gpl-is-fine-for-tests" mode? Shouldn't --gpl-is-fine-for-tests be the default, at least at first? So you wouldn't need to add an

gnulib-tool --lgpl exception for self tests?

2005-10-24 Thread Simon Josefsson
I'm using gnulib-tool --lgpl in some projects. All of the *-tests modules that I wrote recently are GPL. There isn't really a need for these self tests to be available under LGPL, but gnulib-tool complain because I used --lgpl. I think it would be fine to include GPL self tests in a LGPL project

inet_ntop fix for mingw32

2005-10-24 Thread Simon Josefsson
A GnuTLS user reported that inet_ntop did not build on mingw32, so I took a look at it. The patch below fixes: * Add "restrict" keywords, as per POSIX. * Don't include sys/socket.h or netinet/in.h, as they didn't appear to be necessary? The sys/socket.h file was the one causing problems her

Re: namespace conflict for des

2005-10-24 Thread Simon Josefsson
Simon Josefsson <[EMAIL PROTECTED]> writes: > Oh. There is a POSIX "setkey" function. It is not thread safe, so I > can't use it. But GNU has setkey_r and encrypt_r in crypt.h. I think > gnulib should duplicate that API instead. I changed my mind -- that API uses as input 64 byte long strings

md4 fix

2005-10-24 Thread Simon Josefsson
Installed. 2005-10-24 Simon Josefsson <[EMAIL PROTECTED]> * md4.h: Shrink buffer size, now that we changed the type. --- md4.h 22 Oct 2005 17:28:46 +0200 1.2 +++ md4.h 23 Oct 2005 17:01:02 +0200 @@ -34,7 +34,7 @@ uint32_t total[2]; uint32_t buflen; - uin

Re: namespace conflict for des

2005-10-24 Thread Simon Josefsson
Paul Eggert <[EMAIL PROTECTED]> writes: > Simon Josefsson <[EMAIL PROTECTED]> writes: > >> I get this on freebsd 4.11: >> >> In file included from smbutil.c:34: >> lib/des.h:62: conflicting types for `des_setkey' >> /usr/include/unistd.h:128: previous declaration of `des_setkey' >> *** Error code

Re: md5 cleanup

2005-10-24 Thread Simon Josefsson
Stepan Kasal <[EMAIL PROTECTED]> writes: > wouldn't the following be more readable? Yes. > Do I understand correctly that this is only executed for the last block, > so that it's not necessary to be so careful about each tick? Yes. Paul Eggert <[EMAIL PROTECTED]> writes: > Also, in some other

Re: Don't bother checking for unistd.h

2005-10-24 Thread Simon Josefsson
Jim Meyering <[EMAIL PROTECTED]> writes: [unistd.h] > How about adding an accompanying `make check' rule (or similar > mechanism) to help ensure that new/modified .m4 files don't > include that check? Yes, please! I think there is now plenty of stuff gnulib module authors have to think about, th

Re: Don't bother checking for unistd.h

2005-10-24 Thread Jim Meyering
Stepan Kasal <[EMAIL PROTECTED]> wrote: > would the following patch be welcome? > I haven't noticed any of the files in config/srclist.txt. I would welcome it. How about adding an accompanying `make check' rule (or similar mechanism) to help ensure that new/modified .m4 files don't include that

Don't bother checking for unistd.h

2005-10-24 Thread Stepan Kasal
Hi, would the following patch be welcome? I haven't noticed any of the files in config/srclist.txt. Stepan 2005-10-24 Stepan Kasal <[EMAIL PROTECTED]> * c-stack.m4, copy-file.m4, execute.m4, fatal-signal.m4, findprog.m4, getlogin_r.m4, pagealign_alloc.m4, pipe.m4, wait-process

Re: namespace conflict for des

2005-10-24 Thread Stepan Kasal
Hello, On Sun, Oct 23, 2005 at 10:25:48PM -0700, Paul Eggert wrote: > Simon Josefsson <[EMAIL PROTECTED]> writes: > > In file included from smbutil.c:34: > > lib/des.h:62: conflicting types for `des_setkey' ... > If they are supposed to have the same semantics but the FreeBSD > versions are buggy,

sha1 to LGPL (was: Re: [gnu.org #253254] Re: Integrating crypto functions?)

2005-10-24 Thread Simon Josefsson
I have installed this. --- ChangeLog 23 Oct 2005 19:31:20 +0200 1.438 +++ ChangeLog 24 Oct 2005 13:47:39 +0200 @@ -1,3 +1,7 @@ +2005-10-24 Simon Josefsson <[EMAIL PROTECTED]> + + * modules/sha1: Relicense to LGPL. + 2005-10-23 Simon Josefsson <[EMAIL PROTECTED]>

Re: md5 cleanup

2005-10-24 Thread Stepan Kasal
Hello, On Sun, Oct 23, 2005 at 10:34:18PM -0700, Paul Eggert wrote: > uint32_t *p = (uint32_t *) ((char *) ctx->buffer + bytes + pad); > p[0] = SWAP (ctx->total[0] << 3); > p[1] = SWAP ((ctx->total[1] << 3) | (ctx->total[0] >> 29)); wouldn't the following be more readable? uint32_t bytes