Re: Alternative name for controller using Auth (instead of Users) problem

2009-09-18 Thread rboers
Brian, Thank you for your response. I added the Router::connect and use "Users". This works fine. I only wanted to show the user an "logical" url. Problem solved. On 18 sep, 03:26, brian wrote: > One other thing: if you do the above, you might need to adjust how you > retrieve user info. You c

Re: Alternative name for controller using Auth (instead of Users) problem

2009-09-17 Thread brian
One other thing: if you do the above, you might need to adjust how you retrieve user info. You can still use $this->Auth->user('whatever') but, if getting it from the session, do $session->read('Auth.Member.whatever'). On Thu, Sep 17, 2009 at 9:19 PM, brian wrote: > Is the issue here that you do

Re: Alternative name for controller using Auth (instead of Users) problem

2009-09-17 Thread brian
Is the issue here that you don't want to use a User model, or that you don't want the URL to be /users/login? Or both? For the former, you just need to do this in AppController::beforeFilter() $this->Auth->userModel = 'Member'; // or whatever For the latter, you can set a route like so: Router

Alternative name for controller using Auth (instead of Users) problem

2009-09-17 Thread rboers
I've created a simple login system using Auth in cakephp 1.2.5. I have the model, app_controller, users_controller and 2 views (index.ctp, login.ctp) in place and everything works fine when I use /users/login. I want to change /users/login to //logins. Lets say I want to call it logins instead of