Hello,

     I did some searching through the Archives and the last time that i have 
seen that is issue was brought up was November of 2011, but it was not 
resolved.  I'm hoping someone can help me resolve my issue here.

I am trying to implement class-based cRTP on a Frame-Relay link with 
fragmenting being done in the map-class.  I can see where my RTP packets are 
being matched in the output of show policy-map interface  , but the cRTP 
counters remain at 0.  Below is my configuration , any help is very much 
appreciated.


HQ RTR Config....

class-map match-any RTP
 match access-group 101
class-map match-any SIG
 match protocol sip
 match protocol skinny
 match protocol mgcp
 match protocol h323
 match protocol rsvp
!
!
policy-map LLQ
 class SIG
    priority 18
 class RTP
    priority 24
   compress header ip rtp
 class class-default
    fair-queue
policy-map SHAPE
 class class-default
    shape average 384000 9600 0   !!! this is a 2801 router so minimum is 25 
millisecond delay
  service-policy LLQ
!
interface Serial0/1/0:4
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0/1/0:4.1 point-to-point
 bandwidth 384
 ip address 10.10.111.1 255.255.255.0
 ip ospf mtu-ignore
 snmp trap link-status
 frame-relay interface-dlci 201
  class HQtoBR1
!
!
!
map-class frame-relay HQtoBR1
 frame-relay fragment 480
 frame-relay fair-queue
 service-policy output SHAPE
!
!
access-list 101 permit udp any any range 16384 32767
!
HQ-RTR#show policy-map interface
 Serial0/1/0:4.1: DLCI 201 -

  Service-policy output: SHAPE

    Class-map: class-default (match-any)
      1312 packets, 89214 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 1313/89278
      shape (average) cir 384000, bc 9600, be 0
      target shape rate 384000
        lower bound cir 0,  adapt to fecn 0

      Service-policy : LLQ

        queue stats for all priority classes:
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 89/4880

        Class-map: SIG (match-any)
          89 packets, 4880 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: protocol sip
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: protocol skinny
            89 packets, 4880 bytes
            5 minute rate 0 bps
          Match: protocol mgcp
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: protocol h323
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: protocol rsvp
            0 packets, 0 bytes
            5 minute rate 0 bps
          Priority: 18 kbps, burst bytes 1500, b/w exceed drops: 0


        Class-map: RTP (match-any)
          1104 packets, 70656 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
            1104 packets, 70656 bytes
            5 minute rate 0 bps
          Priority: 24 kbps, burst bytes 1500, b/w exceed drops: 0

          compress:
              header ip rtp
              UDP/RTP (compression on, Cisco, RTP)
                Sent:    0 total, 0 compressed,
                         0 bytes saved, 0 bytes sent
                         rate 0 bps


        Class-map: class-default (match-any)
          119 packets, 13678 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0
          (pkts output/bytes output) 120/13742
          Fair-queue: per-flow queue limit 16




BR1 RTR config....

class-map match-any RTP
 match access-group 101
class-map match-any SIG
 match protocol skinny
 match protocol h323
 match protocol mgcp
 match protocol sip
 match protocol rsvp
!
!
policy-map LLQ
 class SIG
    priority 18
 class RTP
    priority 24
   compress header ip rtp
 class class-default
    fair-queue
policy-map SHAPE
 class class-default
    shape average 384000 9600 0
  service-policy LLQ
!
!
!
interface Serial0/1/0:4
 no ip address
 encapsulation frame-relay IETF
 frame-relay lmi-type ansi
!
interface Serial0/1/0:4.1 point-to-point
 bandwidth 384
 ip address 10.10.111.2 255.255.255.0
 ip ospf mtu-ignore
 snmp trap link-status
 frame-relay interface-dlci 101
  class BR1toHQ
!
map-class frame-relay BR1toHQ
 frame-relay fragment 480
 frame-relay fair-queue
 service-policy output SHAPE
!
!
access-list 101 permit udp any any range 16384 32767

BR1-RTR#show policy-map interface
 Serial0/1/0:4.1: DLCI 101 -

  Service-policy output: SHAPE

    Class-map: class-default (match-any)
      3524 packets, 229814 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 3525/229878
      shape (average) cir 384000, bc 9600, be 0
      target shape rate 384000
        lower bound cir 0,  adapt to fecn 0

      Service-policy : LLQ

        queue stats for all priority classes:
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 147/7512

        Class-map: SIG (match-any)
          147 packets, 7512 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: protocol skinny
            147 packets, 7512 bytes
            5 minute rate 0 bps
          Match: protocol h323
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: protocol mgcp
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: protocol sip
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: protocol rsvp
            0 packets, 0 bytes
            5 minute rate 0 bps
          Priority: 18 kbps, burst bytes 1500, b/w exceed drops: 0


        Class-map: RTP (match-any)
          3257 packets, 208448 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
            3257 packets, 208448 bytes
            5 minute rate 0 bps
          Priority: 24 kbps, burst bytes 1500, b/w exceed drops: 0

          compress:
              header ip rtp
              UDP/RTP (compression on, Cisco, RTP)
                Sent:    0 total, 0 compressed,
                         0 bytes saved, 0 bytes sent
                         rate 0 bps


        Class-map: class-default (match-any)
          120 packets, 13854 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0
          (pkts output/bytes output) 121/13918
          Fair-queue: per-flow queue limit 16



Thanks,
Justin McIntyre

This email and any files transmitted with it are confidential and are intended 
for the sole use of the individual to whom they are addressed. Black Box 
Corporation reserves the right to scan all e-mail traffic for restricted 
content and to monitor all e-mail in general. If you are not the intended 
recipient or you have received this email in error, any use, dissemination or 
forwarding of this email is strictly prohibited. If you have received this 
email in error, please notify the sender by replying to this email.
_______________________________________________
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

Reply via email to