[PATCH] D51281: [libclang] Return the proper pointee type for 'auto' deduced to pointer

2018-08-26 Thread Ivan Donchevskii via Phabricator via cfe-commits
yvvan created this revision. yvvan added reviewers: erikjv, arphaman, michaelwu. Currently the resulting type is always invalid in such case. https://reviews.llvm.org/D51281 Files: tools/libclang/CXType.cpp Index: tools/libclang/CXType.cpp ===

r340719 - [X86] Add intrinsics for kand/kandn/knot/kor/kxnor/kxor with 8, 32, and 64-bit mask registers.

2018-08-26 Thread Craig Topper via cfe-commits
Author: ctopper Date: Sun Aug 26 23:20:22 2018 New Revision: 340719 URL: http://llvm.org/viewvc/llvm-project?rev=340719&view=rev Log: [X86] Add intrinsics for kand/kandn/knot/kor/kxnor/kxor with 8, 32, and 64-bit mask registers. This also adds a second intrinsic name for the 16-bit mask versions

r340718 - [X86] Remove min_vector_width 512 from some intrinsics that operate only on k-registers.

2018-08-26 Thread Craig Topper via cfe-commits
Author: ctopper Date: Sun Aug 26 23:20:20 2018 New Revision: 340718 URL: http://llvm.org/viewvc/llvm-project?rev=340718&view=rev Log: [X86] Remove min_vector_width 512 from some intrinsics that operate only on k-registers. Modified: cfe/trunk/lib/Headers/avx512bwintrin.h Modified: cfe/trunk

r340717 - [X86] Rename __DEFAULT_FN_ATTRS to a__DEFAULT_FN_ATTRS512 in avx512dqintrin.h and avx512bwintrin.h.

2018-08-26 Thread Craig Topper via cfe-commits
Author: ctopper Date: Sun Aug 26 23:20:19 2018 New Revision: 340717 URL: http://llvm.org/viewvc/llvm-project?rev=340717&view=rev Log: [X86] Rename __DEFAULT_FN_ATTRS to a__DEFAULT_FN_ATTRS512 in avx512dqintrin.h and avx512bwintrin.h. This is preparation for adding removing min_vector_width 512 f

r340714 - [X86] Undef __DEFAULT_FN_ATTRS in avx512fintrin.h.

2018-08-26 Thread Craig Topper via cfe-commits
Author: ctopper Date: Sun Aug 26 22:44:45 2018 New Revision: 340714 URL: http://llvm.org/viewvc/llvm-project?rev=340714&view=rev Log: [X86] Undef __DEFAULT_FN_ATTRS in avx512fintrin.h. Fixes test failure after r340713 Modified: cfe/trunk/lib/Headers/avx512fintrin.h Modified: cfe/trunk/lib/H

[PATCH] D50958: [clangd] WIP: xrefs for dynamic index.

2018-08-26 Thread Haojian Wu via Phabricator via cfe-commits
hokein added a comment. Thanks for the comments. In https://reviews.llvm.org/D50958#1212221, @sammccall wrote: > I do have some questions there that would be good to discuss. Meanwhile, > @hokein can you rebase this patch against head? Yes, I'd love to, but since this patch is quite large, I

[PATCH] D51279: [clangd] Implement findOccurrences interface in dynamic index.

2018-08-26 Thread Haojian Wu via Phabricator via cfe-commits
hokein added a comment. Some numbers of memory usage from running this on my machine: | File | Preamble AST | Main AST | | SemaDecl.cpp | 14.5MB | 108.1KB (symbols) + 16.5KB (occurrences) | | CodeComplete.cpp | 15.4MB | 53.9KB (symbols)

[PATCH] D51279: [clangd] Implement findOccurrences interface in dynamic index.

2018-08-26 Thread Haojian Wu via Phabricator via cfe-commits
hokein created this revision. hokein added a reviewer: sammccall. Herald added subscribers: kadircet, arphaman, jkorous, MaskRay, ioeric, ilya-biryukov. Implement the interface in - FileIndex - MemIndex - MergeIndex Depends on https://reviews.llvm.org/D50385. Repository: rCTE Clang Tools Ex

r340713 - [X86] Don't set min_vector_width to 512 on intrinsics that only operate on k registers.

2018-08-26 Thread Craig Topper via cfe-commits
Author: ctopper Date: Sun Aug 26 22:27:15 2018 New Revision: 340713 URL: http://llvm.org/viewvc/llvm-project?rev=340713&view=rev Log: [X86] Don't set min_vector_width to 512 on intrinsics that only operate on k registers. Modified: cfe/trunk/lib/Headers/avx512fintrin.h Modified: cfe/trunk/l

[PATCH] D50385: [clangd] Collect symbol occurrences from AST.

2018-08-26 Thread Haojian Wu via Phabricator via cfe-commits
hokein updated this revision to Diff 162611. hokein marked 7 inline comments as done. hokein added a comment. Update the patch based on our new discussion - SymbolOccurrenceSlab for storing underlying occurrence data - reuse SymbolCollector to collect symbol occurrences Repository: rCTE Clang

r340712 - [Xray] Darwin - Enable in the driver side

2018-08-26 Thread David Carlier via cfe-commits
Author: devnexen Date: Sun Aug 26 22:16:09 2018 New Revision: 340712 URL: http://llvm.org/viewvc/llvm-project?rev=340712&view=rev Log: [Xray] Darwin - Enable in the driver side Reviewers: dberris Reviered By: dberris Differential Revision: https://reviews.llvm.org/D51269 Modified: cfe/trun

[PATCH] D51269: [Xray] Darwin - Enable in the driver side

2018-08-26 Thread David CARLIER via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL340712: [Xray] Darwin - Enable in the driver side (authored by devnexen, committed by ). Herald added a subscriber: llvm-commits. Changed prior to commit: https://reviews.llvm.org/D51269?vs=162583&id=16

[PATCH] D51269: [Xray] Darwin - Enable in the driver side

2018-08-26 Thread David CARLIER via Phabricator via cfe-commits
devnexen added a comment. Good point :-) Repository: rL LLVM https://reviews.llvm.org/D51269 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D51234: [Driver] Change MipsLinux default linker from "lld" to "ld.lld"

2018-08-26 Thread Rui Ueyama via Phabricator via cfe-commits
ruiu added a comment. If this piece of code used to be working correctly, there is another piece of code that adds `-flavor ld` to the command line. But if that's the case, this change wouldn't work because it constructs something like "ld.lld -flavor ld ...". ld.lld doesn't accept `-flavor` op

[PATCH] D51269: [Xray] Darwin - Enable in the driver side

2018-08-26 Thread Dean Michael Berris via Phabricator via cfe-commits
dberris accepted this revision. dberris added a comment. This revision is now accepted and ready to land. Thanks for this @devnexen -- but do any of the tests actually run on Darwin yet? Repository: rC Clang https://reviews.llvm.org/D51269 ___ cf

[PATCH] D51239: [ubsan] Enable -fsanitize=vptr on Apple devices and simulators

2018-08-26 Thread Dan Liew via Phabricator via cfe-commits
delcypher requested changes to this revision. delcypher added inline comments. This revision now requires changes to proceed. Comment at: clang/lib/Driver/ToolChains/Darwin.cpp:2254 Res |= SanitizerKind::Function; + if (!isTargetMacOS() || !isMacosxVersionLT(10, 9)) +Res

Re: r340709 - [Driver] Change MipsLinux default linker from "lld" to "ld.lld"

2018-08-26 Thread Chandler Carruth via cfe-commits
FYI, test cases also seem to need updating: http://lab.llvm.org:8011/builders/clang-ppc64le-linux/builds/19575/steps/ninja%20check%201/logs/FAIL%3A%20Clang%3A%3Amips-mti-linux.c On Sun, Aug 26, 2018 at 12:48 PM Fangrui Song via cfe-commits < cfe-commits@lists.llvm.org> wrote: > Author: maskray >

[PATCH] D50455: Continue emitting diagnostics after a fatal error

2018-08-26 Thread Dmitry via Phabricator via cfe-commits
Dmitry.Kozhevnikov marked an inline comment as done. Dmitry.Kozhevnikov added a comment. In https://reviews.llvm.org/D50455#1193468, @ilya-biryukov wrote: > Nevertheless, I think this is moving clangd in the right direction and if we > see too many irrelevant errors, we should look into improvin

[PATCH] D51234: [Driver] Change MipsLinux default linker from "lld" to "ld.lld"

2018-08-26 Thread Fangrui Song via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL340709: [Driver] Change MipsLinux default linker from "lld" to "ld.lld" (authored by MaskRay, committed by ). Herald added a subscriber: llvm-commits. Repository: rL LLVM https://reviews.llvm.org/D5123

r340709 - [Driver] Change MipsLinux default linker from "lld" to "ld.lld"

2018-08-26 Thread Fangrui Song via cfe-commits
Author: maskray Date: Sun Aug 26 12:47:23 2018 New Revision: 340709 URL: http://llvm.org/viewvc/llvm-project?rev=340709&view=rev Log: [Driver] Change MipsLinux default linker from "lld" to "ld.lld" Reviewers: kzhuravl, atanasyan Reviewed By: atanasyan Subscribers: sdardis, arichardson, jrtc27,

[PATCH] D50766: Fix false positive unsequenced access and modification warning in array subscript expression.

2018-08-26 Thread Nicolas Lesser via Phabricator via cfe-commits
Rakete added a comment. > What do you think? Good idea! Comment at: test/SemaCXX/warn-unsequenced-cxx17.cpp:7 + // expected-no-diagnostics + p[(long long unsigned)(p = 0)] // ok +} Oh no, you forgot a semicolon there! :) https://reviews.llvm.org/D50766

[PATCH] D50766: Fix false positive unsequenced access and modification warning in array subscript expression.

2018-08-26 Thread Mateusz Janek via Phabricator via cfe-commits
stryku updated this revision to Diff 162585. stryku added a comment. Added test cases for the code. Here I think I need your assistance. AFAIK in C++ 17 a couple more sequence related rules appeared. If we would like to cover them in current //warn-unsequenced.cpp// file, I think we would end u

[PATCH] D51269: [Xray] Enable in the driver side

2018-08-26 Thread David CARLIER via Phabricator via cfe-commits
devnexen created this revision. devnexen added a reviewer: dberris. devnexen created this object with visibility "All Users". Herald added a subscriber: cfe-commits. Repository: rC Clang https://reviews.llvm.org/D51269 Files: lib/Driver/ToolChains/Darwin.cpp lib/Driver/ToolChains/Darwin.h

[PATCH] D34329: [clang-diff] Initial implementation.

2018-08-26 Thread Sylvestre Ledru via Phabricator via cfe-commits
sylvestre.ledru added a comment. Herald added subscribers: llvm-commits, kadircet, mgrang. @arphaman @johannes Is that normal that clang-diff isn't installed by cmake? (like clang-format?) Repository: rL LLVM https://reviews.llvm.org/D34329 ___

[PATCH] D51234: [Driver] Change MipsLinux default linker from "lld" to "ld.lld"

2018-08-26 Thread Simon Atanasyan via Phabricator via cfe-commits
atanasyan accepted this revision. atanasyan added a comment. This revision is now accepted and ready to land. LGTM Repository: rC Clang https://reviews.llvm.org/D51234 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/