[PATCH] D86412: [clang][Driver] Implement AddClangSystemIncludeArgs and HasNativeLLVMSupport for the OpenBSD clang driver.

2020-08-22 Thread Brad Smith via Phabricator via cfe-commits
brad added a comment. Looks reasonable. I'm a little surprised I don't see this in the FreeBSD driver. What about FreeBSD, NetBSD and DragonFly? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86412/new/ https://reviews.llvm.org/D86412 ___

[PATCH] D86412: [clang][Driver] Implement AddClangSystemIncludeArgs and HasNativeLLVMSupport for the OpenBSD clang driver.

2020-08-22 Thread dana koch via Phabricator via cfe-commits
3405691582 updated this revision to Diff 287238. 3405691582 added a comment. Finally got the formatting fixed properly. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86412/new/ https://reviews.llvm.org/D86412 Files: clang/lib/Driver/ToolChains/OpenBSD.cpp

[PATCH] D86412: [clang][Driver] Implement AddClangSystemIncludeArgs and HasNativeLLVMSupport for the OpenBSD clang driver.

2020-08-22 Thread dana koch via Phabricator via cfe-commits
3405691582 updated this revision to Diff 287237. Herald added a subscriber: fedor.sergeev. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86412/new/ https://reviews.llvm.org/D86412 Files: clang/lib/Driver/ToolChains/OpenBSD.cpp clang/lib/Driver/ToolChains/OpenBSD.h Index:

[PATCH] D86412: [clang][Driver] Implement AddClangSystemIncludeArgs and HasNativeLLVMSupport for the OpenBSD clang driver.

2020-08-22 Thread dana koch via Phabricator via cfe-commits
3405691582 created this revision. 3405691582 added a reviewer: brad. Herald added a project: clang. Herald added a subscriber: cfe-commits. 3405691582 requested review of this revision. If not overridden, `AddClangSystemIncludeArgs`'s implementation is empty, so by default, no system include

[libunwind] 3c1b2e3 - [libunwind] Make findUnwindSectionsByPhdr static

2020-08-22 Thread Ryan Prichard via cfe-commits
Author: Ryan Prichard Date: 2020-08-22T17:12:52-07:00 New Revision: 3c1b2e338dfdf4f305b1cb40e2ebcb93a7e470c3 URL: https://github.com/llvm/llvm-project/commit/3c1b2e338dfdf4f305b1cb40e2ebcb93a7e470c3 DIFF: https://github.com/llvm/llvm-project/commit/3c1b2e338dfdf4f305b1cb40e2ebcb93a7e470c3.diff

[PATCH] D86398: [X86] Enable constexpr on _cast fp<-> uint intrinsics (PR31446)

2020-08-22 Thread Richard Smith - zygoloid via Phabricator via cfe-commits
rsmith accepted this revision. rsmith added a comment. It would be useful to include in our documentation a brief list of which of these intrinsics can be used in constant expressions. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86398/new/

[clang] cc7bf9b - [X86] Allow 32-bit mode only CPUs with -mtune on 64-bit targets

2020-08-22 Thread Craig Topper via cfe-commits
Author: Craig Topper Date: 2020-08-22T16:38:05-07:00 New Revision: cc7bf9bcbfbc8d8188d9fe540c2bc1aee23824af URL: https://github.com/llvm/llvm-project/commit/cc7bf9bcbfbc8d8188d9fe540c2bc1aee23824af DIFF: https://github.com/llvm/llvm-project/commit/cc7bf9bcbfbc8d8188d9fe540c2bc1aee23824af.diff

[PATCH] D85097: [Sema] add warning for comparisons like 'x<=y<=z'

2020-08-22 Thread Dávid Bolvanský via Phabricator via cfe-commits
xbolva00 added inline comments. Comment at: clang/test/Sema/warn-compare-op-parentheses.c:49 + b = p1 > p2 < p3; + // expected-warning@-1 {{comparisons like 'x<=y<=z' are interpreted as '(x<=y ? 1 : 0) <= z'}} + // expected-note@-2 {{place parentheses around the '>'

[PATCH] D86398: [X86] Enable constexpr on _cast fp<-> uint intrinsics (PR31446)

2020-08-22 Thread Craig Topper via Phabricator via cfe-commits
craig.topper accepted this revision. craig.topper added a comment. This revision is now accepted and ready to land. LGTM Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86398/new/ https://reviews.llvm.org/D86398

[PATCH] D85097: [Sema] add warning for comparisons like 'x<=y<=z'

2020-08-22 Thread Roman Lebedev via Phabricator via cfe-commits
lebedev.ri added a comment. In D85097#2201609 , @vabridgers wrote: > Thanks for the recent comments. I just pushed a few improvements over the > last patch that didn't comprehend latest comments from @rsmith and > @Quuxplusone. I'll read through those

[libunwind] 542db87 - [libunwind] Ensure enough alignment for unw_cursor_t for SEH build configurations

2020-08-22 Thread Martin Storsjö via cfe-commits
Author: Martin Storsjö Date: 2020-08-22T22:48:57+03:00 New Revision: 542db87f1ac67087aeb5cf572b1f9744d482da69 URL: https://github.com/llvm/llvm-project/commit/542db87f1ac67087aeb5cf572b1f9744d482da69 DIFF:

[PATCH] D80197: [DebugInfo] Upgrade DISubrange to support Fortran dynamic arrays

2020-08-22 Thread Josh Stone via Phabricator via cfe-commits
cuviper added inline comments. Comment at: llvm/lib/CodeGen/AsmPrinter/CodeViewDebug.cpp:1595 const DISubrange *Subrange = cast(Element); -assert(Subrange->getLowerBound() == 0 && +assert(!Subrange->getRawLowerBound() && "codeview doesn't support

[PATCH] D85528: [analyzer] Fix cast evaluation on scoped enums in ExprEngine

2020-08-22 Thread Gábor Horváth via Phabricator via cfe-commits
xazax.hun added a comment. In D85528#2229309 , @steakhal wrote: > It would be nice to have this fix in clang11. > Do you think it's qualified for it? Unfortunately, this is not a fix only change. This is a fix for refutation, but also a behavioral

[PATCH] D86295: [analyzer] Reorder the layout of MemRegion and cache by hand for optimal size

2020-08-22 Thread Balázs Benics via Phabricator via cfe-commits
steakhal added a comment. In D86295#2231760 , @NoQ wrote: > I mean, like, you can measure the entire process with `time` or something > like that. I believe @vsavchenko's docker thingy already knows how to do that. I tried to measure this with `time`,

[PATCH] D86223: [analyzer][z3] Use more elaborate z3 variable names in debug build

2020-08-22 Thread Balázs Benics via Phabricator via cfe-commits
steakhal added inline comments. Comment at: clang/include/clang/StaticAnalyzer/Core/PathSensitive/SMTConv.h:335 +llvm::raw_svector_ostream OS(Str); +OS << PRETTY_SYMBOL_KIND << ID; +#undef PRETTY_SYMBOL_KIND xazax.hun wrote: > Maybe, in this case, it is

[PATCH] D86223: [analyzer][z3] Use more elaborate z3 variable names in debug build

2020-08-22 Thread Balázs Benics via Phabricator via cfe-commits
steakhal updated this revision to Diff 287197. steakhal marked 2 inline comments as done. steakhal edited the summary of this revision. steakhal added a comment. In D86223#2231959 , @mikhail.ramalho wrote: > I don't mind having it for release builds as

[PATCH] D86400: [NFC][compiler-rt] Factor out __div[sdt]i3 and __mod[dt]i3 implementations

2020-08-22 Thread Anatoly Trosinenko via Phabricator via cfe-commits
atrosinenko created this revision. atrosinenko added reviewers: MaskRay, aykevl, uabelho. Herald added subscribers: Sanitizers, dberris. Herald added a project: Sanitizers. atrosinenko requested review of this revision. An attempt was made to generically recreate these functions as close to the

[PATCH] D86293: [analyzer] Add modeling of Eq operator in smart ptr

2020-08-22 Thread Gábor Horváth via Phabricator via cfe-commits
xazax.hun added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/SmartPtrModeling.cpp:351 +bool SmartPtrModeling::handleEqOp(const CallEvent , + CheckerContext ) const { I'd prefer to call this AssignOp to avoid

[PATCH] D86223: [analyzer][z3] Use more elaborate z3 variable names in debug build

2020-08-22 Thread Mikhail Ramalho via Phabricator via cfe-commits
mikhail.ramalho added a comment. I don't mind having it for release builds as well, why are you applying it only for debug builds? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86223/new/ https://reviews.llvm.org/D86223

[PATCH] D86027: [analyzer] Add bool operator modeling for unque_ptr

2020-08-22 Thread Gábor Horváth via Phabricator via cfe-commits
xazax.hun requested changes to this revision. xazax.hun added a comment. This revision now requires changes to proceed. Please add a test case, where the unique_ptr is initialized from a pointer parameter that has no assumptions. I think that case is not handled correctly.

[PATCH] D86223: [analyzer][z3] Use more elaborate z3 variable names in debug build

2020-08-22 Thread Gábor Horváth via Phabricator via cfe-commits
xazax.hun added inline comments. Comment at: clang/test/Analysis/z3/pretty-dump.c:15 +// CHECK: "constraints": [ +// CHECK-NEXT: { "symbol": "(reg_$[[#]]) == 3", "range": "(= reg_$[[#]] #x0003)" } + } Will this test case work with non-debug builds?

[PATCH] D86223: [analyzer][z3] Use more elaborate z3 variable names in debug build

2020-08-22 Thread Gábor Horváth via Phabricator via cfe-commits
xazax.hun accepted this revision. xazax.hun added a comment. This is what I had in mind, thanks! Comment at: clang/include/clang/StaticAnalyzer/Core/PathSensitive/SMTConv.h:335 +llvm::raw_svector_ostream OS(Str); +OS << PRETTY_SYMBOL_KIND << ID; +#undef

[PATCH] D79219: [CMake] Simplify CMake handling for zlib

2020-08-22 Thread Mateusz Mikuła via Phabricator via cfe-commits
mati865 added a comment. @phosek in MSYS2 (targeting x86_64-w64-windows-gnu) Zlib works properly for LLVM 10 but with master I'm now seeing: -- Constructing LLVMBuild project information -- DEBUG zlib_library=D:/msys64/mingw64/lib/libz.dll.a CMake Error at lib/Support/CMakeLists.txt:9

[PATCH] D86223: [analyzer][z3] Use more elaborate z3 variable names in debug build

2020-08-22 Thread Balázs Benics via Phabricator via cfe-commits
steakhal updated this revision to Diff 287192. steakhal edited the summary of this revision. steakhal added a comment. Use virtual getKindStr method for acquiring the kind name. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86223/new/

[PATCH] D86398: [X86] Enable constexpr on _cast fp<-> uint intrinsics (PR31446)

2020-08-22 Thread Simon Pilgrim via Phabricator via cfe-commits
RKSimon created this revision. RKSimon added reviewers: rsmith, craig.topper, erichkeane. Herald added a project: clang. RKSimon requested review of this revision. As suggested by @rsmith on PR47267, by replacing the __builtin_memcpy bitcast pattern with __builtin_bit_cast we can use

[clang] 42b993d - [X86] ia32intrin.h - pull out common attributes used in cast helpers into define. NFCI.

2020-08-22 Thread Simon Pilgrim via cfe-commits
Author: Simon Pilgrim Date: 2020-08-22T15:25:15+01:00 New Revision: 42b993d97d31d7810fa3c1f7f2e79f72baa02416 URL: https://github.com/llvm/llvm-project/commit/42b993d97d31d7810fa3c1f7f2e79f72baa02416 DIFF: https://github.com/llvm/llvm-project/commit/42b993d97d31d7810fa3c1f7f2e79f72baa02416.diff

[clang] e7d9182 - Enable constexpr on BITREVERSE builtin intrinsics (PR47249)

2020-08-22 Thread Simon Pilgrim via cfe-commits
Author: Simon Pilgrim Date: 2020-08-22T14:43:22+01:00 New Revision: e7d9182a666a2a8f903bd330c82d7c623b783371 URL: https://github.com/llvm/llvm-project/commit/e7d9182a666a2a8f903bd330c82d7c623b783371 DIFF: https://github.com/llvm/llvm-project/commit/e7d9182a666a2a8f903bd330c82d7c623b783371.diff

[PATCH] D86339: Enable constexpr on BITREVERSE builtin intrinsics (PR47249)

2020-08-22 Thread Simon Pilgrim via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGe7d9182a666a: Enable constexpr on BITREVERSE builtin intrinsics (PR47249) (authored by RKSimon). Changed prior to commit: https://reviews.llvm.org/D86339?vs=286999=287182#toc Repository: rG LLVM

[clang] 2ceac91 - Enable constexpr on ROTATELEFT/ROTATERIGHT builtin intrinsics (PR47249)

2020-08-22 Thread Simon Pilgrim via cfe-commits
Author: Simon Pilgrim Date: 2020-08-22T14:43:21+01:00 New Revision: 2ceac91ec0fc186ff503402e7b88e4576a69008d URL: https://github.com/llvm/llvm-project/commit/2ceac91ec0fc186ff503402e7b88e4576a69008d DIFF: https://github.com/llvm/llvm-project/commit/2ceac91ec0fc186ff503402e7b88e4576a69008d.diff

[PATCH] D86342: Enable constexpr on ROTATELEFT/ROTATERIGHT builtin intrinsics (PR47249)

2020-08-22 Thread Simon Pilgrim via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG2ceac91ec0fc: Enable constexpr on ROTATELEFT/ROTATERIGHT builtin intrinsics (PR47249) (authored by RKSimon). Changed prior to commit: https://reviews.llvm.org/D86342?vs=287006=287181#toc Repository:

[clang] 436a35a - [docs] Replace "constexpr expressions" with "constant expressions".

2020-08-22 Thread Simon Pilgrim via cfe-commits
Author: Simon Pilgrim Date: 2020-08-22T14:14:36+01:00 New Revision: 436a35a77313598eedad867a0f086aeb1b5b6eb2 URL: https://github.com/llvm/llvm-project/commit/436a35a77313598eedad867a0f086aeb1b5b6eb2 DIFF: https://github.com/llvm/llvm-project/commit/436a35a77313598eedad867a0f086aeb1b5b6eb2.diff

[PATCH] D86176: [clang-tidy] readability-simplify-boolean-expr detects negated literals

2020-08-22 Thread Nathan James via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGdf5335a36d3d: [clang-tidy] readability-simplify-boolean-expr detects negated literals (authored by njames93). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[clang-tools-extra] df5335a - [clang-tidy] readability-simplify-boolean-expr detects negated literals

2020-08-22 Thread Nathan James via cfe-commits
Author: Nathan James Date: 2020-08-22T13:57:36+01:00 New Revision: df5335a36d3d70927d1834f31c705e31b4b3701f URL: https://github.com/llvm/llvm-project/commit/df5335a36d3d70927d1834f31c705e31b4b3701f DIFF: https://github.com/llvm/llvm-project/commit/df5335a36d3d70927d1834f31c705e31b4b3701f.diff

[PATCH] D86027: [analyzer] Add bool operator modeling for unque_ptr

2020-08-22 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/SmartPtrModeling.cpp:130 +// Returns empty type if not found valid inner pointer type. +static QualType getInnerPointerType(const CallEvent , CheckerContext ) { + QualType InnerType{};

[PATCH] D86029: [analyzer] Add modeling for unque_ptr::get()

2020-08-22 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ accepted this revision. NoQ added a comment. This patch looks correct to me at a glance. I think we should land it as is and debug/improve later. Comment at: clang/lib/StaticAnalyzer/Checkers/SmartPtrModeling.cpp:362-363 + const auto *InnerPointVal =

[PATCH] D86295: [analyzer] Reorder the layout of MemRegion and cache by hand for optimal size

2020-08-22 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ added a comment. In D86295#2230603 , @steakhal wrote: > In D86295#2229712 , @NoQ wrote: > >> Heh, nice! Did you try to measure the actual impact of this change on memory >> and/or performance? > > Eh, I don't