[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-07-27 Thread Matheus Izvekov via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG4819b751bd87: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value` (authored by mizvekov). Changed prior to commit: https://reviews.llvm.org/D100733?vs=351123&id=362254#toc Repository: rG

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-06-10 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov added a comment. Also by the way D100713 is not really a dependency here, this DR can land on it's own if that is not clear. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D100733/new/ https://reviews.llvm

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-06-10 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov updated this revision to Diff 351123. mizvekov added a comment. Rebase. Now that we have isPRValue, this is hopefully less controversial now :) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D100733/new/ https://reviews.llvm.org/D100733 Fi

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-06-05 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov added a comment. I created a DR which proposes the renaming as rsmith suggested: https://reviews.llvm.org/D103720 In D100733#2773944 , @aaronpuchert wrote: > A new value category feels like a global change for a local problem. We can > explai

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-05-21 Thread Aaron Puchert via Phabricator via cfe-commits
aaronpuchert added a comment. In D100733#2760890 , @mizvekov wrote: > - I still think a new value category is simpler than the two phase overload > resolution it replaces :D Not sure if it's simpler, but it'll produce less confusing results. > - This n

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-05-14 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov added a comment. In D100733#2761031 , @rsmith wrote: > What do we think about renaming `isRValue()` to `isPRValue()` and renaming > `VK_RValue` to `VK_PRValue`, adding a "real" `isRValue()`, and then > performing this cleanup? I think the curre

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-05-14 Thread Richard Smith - zygoloid via Phabricator via cfe-commits
rsmith added a comment. I don't think out-of-tree experiments on possibilities for move semantics are especially motivating for this, one way or the other, but I do think it would be nice to make some kind of change here. What do we think about renaming `isRValue()` to `isPRValue()` and renamin

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-05-14 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov added a comment. In D100733#2759592 , @aaronpuchert wrote: > Not sure how to feel about this, the value categories are already hard to > grasp for most C++ programmers. To solve the implicit move concerns with a > new value category seems like

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-05-14 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman added a reviewer: rsmith. aaron.ballman added a comment. In D100733#2759592 , @aaronpuchert wrote: > @aaron.ballman, what do you think about this? We can't really prevent anyone > from writing `.getValueKind() == VK_*Value` instead of `.is

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-05-14 Thread Aaron Puchert via Phabricator via cfe-commits
aaronpuchert added a subscriber: aaron.ballman. aaronpuchert added a comment. @aaron.ballman, what do you think about this? We can't really prevent anyone from writing `.getValueKind() == VK_*Value` instead of `.is*Value()`, so this change will make things consistent only for now. In D100733#26

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-04-18 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov added a comment. In D100733#2697537 , @aaronpuchert wrote: > The change seems to be correct, but I'm wondering if `x.getValueKind() == > VK_*Value` doesn't have one advantage over `x.is*Value()`: it's obvious that > this is exclusive with the

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-04-18 Thread Aaron Puchert via Phabricator via cfe-commits
aaronpuchert added a comment. The change seems to be correct, but I'm wondering if `x.getValueKind() == VK_*Value` doesn't have one advantage over `x.is*Value()`: it's obvious that this is exclusive with the other values. Especially with `isRValue()` it might not be so obvious, because Clang do

[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`

2021-04-18 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov created this revision. Herald added a subscriber: lxfind. mizvekov requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. Signed-off-by: Matheus Izvekov Repository: rG LLVM Github Monorepo https://reviews.llvm.org/D100733 Files: