rsmith closed this revision.
rsmith added a comment.
Committed as r317032, thanks!
https://reviews.llvm.org/D36101
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Rakete updated this revision to Diff 120977.
Rakete added a comment.
Added some more tests.
If this patch is still ok can you please commit it @rsmith ? Thanks!
https://reviews.llvm.org/D36101
Files:
include/clang/Parse/Parser.h
lib/Parse/ParseExpr.cpp
test/Parser/cxx1z-fold-expre
Rakete updated this revision to Diff 120966.
Rakete added a comment.
Used Parser's `GreaterThanIsOperator` just to be sure. :)
https://reviews.llvm.org/D36101
Files:
include/clang/Parse/Parser.h
lib/Parse/ParseExpr.cpp
test/Parser/cxx1z-fold-expressions.cpp
Index: test/Parser/cx
rsmith accepted this revision.
rsmith added a comment.
This revision is now accepted and ready to land.
Thanks!
Comment at: lib/Parse/ParseExpr.cpp:273
static bool isFoldOperator(tok::TokenKind Kind) {
- return isFoldOperator(getBinOpPrecedence(Kind, false, true));
+ return
Rakete updated this revision to Diff 119767.
Rakete added a comment.
Used the naming convention of LLVM + friendly ping. :)
https://reviews.llvm.org/D36101
Files:
lib/Parse/ParseExpr.cpp
test/Parser/cxx1z-fold-expressions.cpp
Index: test/Parser/cxx1z-fold-expressions.cpp
=
Rakete updated this revision to Diff 115846.
Rakete added a comment.
Used the correct return type, even if it doesn't really matter to the compiler.
https://reviews.llvm.org/D36101
Files:
lib/Parse/ParseExpr.cpp
test/Parser/cxx1z-fold-expressions.cpp
Index: test/Parser/cxx1z-fold-
Rakete updated this revision to Diff 115842.
Rakete added a project: clang.
Rakete added a comment.
Added the tests to the existing test file for fold operators that I didn't
notice before :)
https://reviews.llvm.org/D36101
Files:
lib/Parse/ParseExpr.cpp
test/Parser/cxx1z-fold-
Rakete updated this revision to Diff 113020.
Rakete added a comment.
Updated test to use the -std=c++17 option + friendly ping
https://reviews.llvm.org/D36101
Files:
lib/Parse/ParseExpr.cpp
test/CXX/expr/expr.prim/expr.prim.fold/p2.cpp
Index: test/CXX/expr/expr.prim/expr.prim.fold
Rakete added a comment.
Ping?
https://reviews.llvm.org/D36101
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Rakete created this revision.
The right shift operator was not seen as a valid operator in a fold expression,
which is PR32563.
https://reviews.llvm.org/D36101
Files:
lib/Parse/ParseExpr.cpp
test/CXX/expr/expr.prim/expr.prim.fold/p2.cpp
Index: test/CXX/expr/expr.prim/expr.prim.fold/p
10 matches
Mail list logo