[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-04-11 Thread Aaron Smith via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL358219: [DebugInfo] Combine Trivial and NonTrivial flags (authored by asmith, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to commit: https://revi

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-04-10 Thread David Blaikie via Phabricator via cfe-commits
dblaikie accepted this revision. dblaikie added a comment. This revision is now accepted and ready to land. Approved pending the LLVM side changes/discussion. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59347/new/ https://reviews.llvm.org/D59347

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-04-09 Thread Aaron Smith via Phabricator via cfe-commits
asmith marked 2 inline comments as done. asmith added a comment. This should be ready to commit CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59347/new/ https://reviews.llvm.org/D59347 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-04-08 Thread Aaron Smith via Phabricator via cfe-commits
asmith updated this revision to Diff 194249. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59347/new/ https://reviews.llvm.org/D59347 Files: lib/CodeGen/CGDebugInfo.cpp test/CodeGenCXX/debug-info-composite-triviality.cpp Index: test/CodeGenCXX/debug-info-composite-triviality.cpp ==

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-04-07 Thread Paul Robinson via Phabricator via cfe-commits
probinson added inline comments. Comment at: test/CodeGenCXX/debug-info-composite-triviality.cpp:88 - -// CHECK-DAG: !DICompositeType({{.*}}, name: "NonTrivialE",{{.*}}flags: {{.*}}DIFlagNonTrivial -struct NonTrivialE : Trivial, NonTrivial { Hui wrote: > probins

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-04-03 Thread Hui Huang via Phabricator via cfe-commits
Hui added inline comments. Comment at: test/CodeGenCXX/debug-info-composite-triviality.cpp:88 - -// CHECK-DAG: !DICompositeType({{.*}}, name: "NonTrivialE",{{.*}}flags: {{.*}}DIFlagNonTrivial -struct NonTrivialE : Trivial, NonTrivial { probinson wrote: > This on

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-27 Thread Paul Robinson via Phabricator via cfe-commits
probinson added a comment. In D59347#1444819 , @dblaikie wrote: > In D59347#1443051 , @dblaikie wrote: > > > @asmith: Where's the LLVM-side change/review that goes with this, btw? > > > > In D59347#1442970

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-27 Thread David Blaikie via Phabricator via cfe-commits
dblaikie added a comment. In D59347#1443051 , @dblaikie wrote: > @asmith: Where's the LLVM-side change/review that goes with this, btw? > > In D59347#1442970 , @probinson wrote: > > > As a rule I would prefer flags

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-26 Thread Aaron Smith via Phabricator via cfe-commits
asmith added a comment. Okay if we change the flag then I believe the tests under llvm/tests/lib/DebugInfo/CodeView must be updated. If we use NonTrivial all the existing tests work as expected. LLVM change is here (you are all reviewers). https://reviews.llvm.org/D59348 Repository: rC Clan

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-26 Thread David Blaikie via Phabricator via cfe-commits
dblaikie added a comment. @asmith: Where's the LLVM-side change/review that goes with this, btw? In D59347#1442970 , @probinson wrote: > As a rule I would prefer flags with positive names, as it's slightly easier > to read `!isTrivial` than `!isNonTrivia

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-26 Thread Paul Robinson via Phabricator via cfe-commits
probinson added a comment. As a rule I would prefer flags with positive names, as it's slightly easier to read `!isTrivial` than `!isNonTrivial`. And trivially shorter. :-) Repository: rC Clang CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59347/new/ https://reviews.llvm.org/D59347

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-25 Thread Aaron Smith via Phabricator via cfe-commits
asmith added a comment. Either way. It was fewer changes to use FlagNonTrivial. Which flag do people want to keep? Repository: rC Clang CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59347/new/ https://reviews.llvm.org/D59347 ___ cfe-com

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-14 Thread David Blaikie via Phabricator via cfe-commits
dblaikie added a comment. Would it be simpler/better to revert all the FlagTrivial work? & use the FlagNonTrivial+composite type to imply trivial? (since FlagnonTrivial has been in-tree longer) Repository: rC Clang CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59347/new/ https://re

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-14 Thread Paul Robinson via Phabricator via cfe-commits
probinson added a comment. I'd preserve the trivial test cases and show that the NonTrivial flag is *not* present. I can suggest ways to achieve this if you like (note there is no CHECK-DAG-NOT combined directive). Comment at: test/CodeGenCXX/debug-info-composite-triviality.

[PATCH] D59347: [DebugInfo] Combine Trivial and NonTrivial flags

2019-03-13 Thread Aaron Smith via Phabricator via cfe-commits
asmith created this revision. asmith added reviewers: rnk, zturner, dblaikie, probinson. Herald added subscribers: cfe-commits, jdoerfert, aprantl. Herald added a project: clang. These flags are used when emitting debug info and needed to initialize subprogram and member function attributes (func