I proposed last week writing several short speed-drill configurations.  This
was in response to several CCIE-Lab-experience-bios that mentioned being
really familiar with the basic stuff so you would have time left to figure
out the strange stuff.  Also, most of the lab scenarios I've seen out there
are huge projects with everything the author can think to throw in the mix,
and sometimes I think it's just good to practice a quick drill.

I thought that if I could find volunteers to write a few speed-drills
covering basic technologies, I'm sure we could find a website to post them
for future group members.  

This is my first attempt, and I hope perhaps this will serve as a model if
anybody wants to help out.  First there's the equipment requirements, then a
paragraph defining the drill, and below that is the configuration I came up
with to meet the requirements.  Comments are more then welcome...

Thanks   --- Dennis

-------------------

Speed Drill #1, Basic ISDN

Requirements - 
Two routers with BRI ports (such as Cisco 2503's)
An ISDN simulator or two BRI lines

Configure DDR between the two routers using OSPF as the routing protocol,
and configuring one of the routers using a Dialer Profile and Map-Class, and
the other Legacy.  Ether router should be able to initiate the conversation,
and the line should go idle when not needed.  Use CHAP authentication, and
minimize the load required to bring up the second B Channel.  Create several
loopback interfaces on each router and verify the routes are being
propagated. This should take no more then 15 minutes.  Good luck...


My configuration:


routera#s run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname routera
!
no logging console
enable password cisco
!
username rb password 0 cisco
username routerb password 0 cisco
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-dms100
!
!
!
interface Loopback0
 ip address 172.16.2.1 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
!
interface Loopback1
 ip address 172.16.3.1 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
 ip ospf demand-circuit
 dialer pool-member 1
 isdn switch-type basic-dms100
 isdn spid1 3840000001 384000
 isdn spid2 3840000002 384010
 ppp multilink
!
interface Dialer0
 ip address 172.16.1.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
 dialer remote-name routerb
 dialer string 384020 class adams
 dialer load-threshold 1 outbound
 dialer pool 1
 dialer-group 1
 ppp authentication chap
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
!
ip classless
!
!
map-class dialer adams
 dialer idle-timeout 90
 dialer fast-idle 15
dialer-list 1 protocol ip permit
alias exec co config t
!
line con 0
 password cisco
 login
 transport input none
line aux 0
 password cisco
 login
line vty 0 4
 password cisco
 login
!
end


termserv#2
[Resuming connection 2 to rb ... ]


routerb#s run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname routerb
!
no logging console
enable password cisco
!
username routera password 0 cisco
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-dms100
!
!
!
interface Loopback0
 ip address 172.16.11.2 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
!
interface Loopback1
 ip address 172.16.12.2 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip address 172.16.1.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf interface-retry 0
 ip ospf demand-circuit
 dialer idle-timeout 90
 dialer map ip 172.16.1.1 name routera broadcast 384000
 dialer load-threshold 1 outbound
 dialer-group 1
 isdn switch-type basic-dms100
 isdn spid1 3840200001 384020
 isdn spid2 3840200002 384030
 ppp authentication chap
 ppp multilink
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
!
ip classless
!
dialer-list 1 protocol ip permit
alias exec co config t
!
line con 0
 password cisco
 login
 transport input none
line aux 0
 password cisco
 login
line vty 0 4
 password cisco
 login
!
end

**NOTE** All LAB SWAP messages should now be sent to the
LAB SWAP Message board on groupstudy.com.
_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
[EMAIL PROTECTED] with the body containing:
unsubscribe ccielab

_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to