I just had mine working.

Cola#show run
Building configuration...

Current configuration : 2615 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname Cola
!
redundancy
 no keepalive-enable
 mode hsa
enable secret 5 $1$4gPI$wcQKNzXJpTT3ibtsj.nLY0
!
ip subnet-zero
ip cef distributed
ip host jazz 192.168.100.53
mpls ldp logging neighbor-changes
no mpls traffic-eng auto-bw timers frequency 0
l2tp-class mc_l2tp_contr
 hello 30
 password 0 secret
 cookie size 8
!
pseudowire-class mc_l2tp_path
 encapsulation l2tpv3
 protocol l2tpv3 mc_l2tp_contr
 ip local interface Loopback3
 ip pmtu
 ip dfbit set
 ip tos reflect
!
!
!
!
interface Loopback0
 ip address 30.30.30.1 255.255.255.255
 no ip directed-broadcast
!
interface Loopback3
 ip address 192.168.100.43 255.255.255.255
 no ip directed-broadcast
!
interface Loopback4
 ip address 50.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface FastEthernet3/0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet3/1/0
 ip address 200.100.100.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet3/1/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet3/1/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet3/1/3
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet3/1/4
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet3/1/5
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet3/1/6
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Ethernet3/1/7
 no ip address
 no ip directed-broadcast
 shutdown
!
interface FastEthernet9/0/0
 no ip address
 no ip directed-broadcast
 full-duplex
!
interface FastEthernet9/0/0.1
 encapsulation dot1Q 101
 ip address 13.0.1.1 255.255.255.252
 no ip directed-broadcast
!
interface FastEthernet9/0/1
 no ip address
 no ip directed-broadcast
 full-duplex
!
interface FastEthernet9/0/1.1
 encapsulation dot1Q 101
 no ip directed-broadcast
 no cdp enable
 xconnect 192.168.100.53 101 pw-class mc_l2tp_path
!
interface FastEthernet9/1/0
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 media-type MII
 full-duplex
!
router bgp 10
 no synchronization
 bgp log-neighbor-changes
 network 50.0.0.0
 redistribute connected
 neighbor 20.20.20.1 remote-as 10
 neighbor 20.20.20.1 update-source Loopback0
 no auto-summary
!
ip classless
ip route 10.2.2.0 255.255.255.0 10.1.1.2
ip route 20.20.20.1 255.255.255.255 13.0.1.2
ip route 192.168.100.53 255.255.255.255 10.1.1.2
!
!
!
!
alias exec ff show ip int brief
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

router2#

Building configuration...

Current configuration : 3888 bytes
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname blabla2
!
redundancy
 no keepalive-enable
 mode hsa
enable secret 5 $1$j7en$FoJXnn8QFW18jod4ncYzi.
!
ip subnet-zero
ip cef distributed
ip host cola 192.168.100.43
no mpls ldp logging neighbor-changes
no mpls traffic-eng auto-bw timers frequency 0
l2tp-class mc_l2tp_contr
 hello 30
 password 0 secret
 cookie size 8
!
pseudowire-class mc_l2tp_path
 encapsulation l2tpv3
 protocol l2tpv3 mc_l2tp_contr
 ip local interface Loopback3
 ip pmtu
 ip dfbit set
 ip tos reflect
!
!
!
!
interface Loopback0
 ip address 20.20.20.1 255.255.255.255
 no ip directed-broadcast
!
interface Loopback3
 ip address 192.168.100.53 255.255.255.255
 no ip directed-broadcast
!
!
interface FastEthernet5/1/0
 ip address 10.2.2.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache distributed
 full-duplex
!
interface FastEthernet8/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 full-duplex
!
interface FastEthernet8/1/0.1
 encapsulation dot1Q 101
 ip address 13.0.1.2 255.255.255.252
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface FastEthernet8/1/1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 full-duplex
!
interface FastEthernet8/1/1.1
 encapsulation dot1Q 101
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 no cdp enable
 xconnect 192.168.100.43 101 pw-class mc_l2tp_path
!

!
ip classless
ip route 10.1.1.0 255.255.255.0 10.2.2.1
ip route 192.168.100.43 255.255.255.255 10.2.2.1
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Cisco has a messed up way of implementing the L2TPv3 tunnels like this. 
Basically you looped two FE ports together.  Pick 1 port for your layer 3
routing and the other port to cross connect your layer two tunnels.  The
vlan ID for the two FE ports must match.  The tunnels reference the loopback
of the endpoint router.  Hope this helps.

-Doan







Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=75266&t=75255
--------------------------------------------------
**Please support GroupStudy by purchasing from the GroupStudy Store:
http://shop.groupstudy.com
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html

Reply via email to