Policying simply drops (or marks) the excess traffic, so it is not suprising
that it didn't trigger the queueing mechanism.

Traffic shaping does trigger queueing mechanism if the traffic exceeds the
specified amount, but the type of queueing you can use with traffic shaping
is limited. I think generic traffic shaping supports only WFQ, so again it
is not suprising that your priority queueing didn't take effect. You could
use Frame Relay traffic shaping with priority queueing, but if you had a
serial interface to run FR over, then you could also set the clock rate low
enough to make the interface really congested, so I guess this won't help
much.

There is also a thing called class-based traffic shaping, which is in effect
traffic shaping inside CBWFQ. There you use a policy map to specify the
bandwidth a certain traffic class is allowed to use, not the 'traffic-shape'
command under the interface, and then (still from withing the policy map)
you point to another policy map using the 'service-policy' command. I am not
sure however if that is a good emulation of a real, congested interface.

Thanks,

Zsombor

Vijayanand ballapuram wrote:
> 
> Dear Members,
> 
> I am new member of this group. If my below problem is outside
> the scope of this group, please suggest me a suitable group
> where I can post the same below proble.
> 
> 
> I am trying to give priority to voice over other traffic by
> setting up a below test bed in my lab.
> 
> Explanation of my test bed :
> 
> (voicereceiver/background receiver)-E0-Router- 
> E1-(Voicegenerator/background generator)
> 
> 
> Voice receiver, Background receiver and router 1’s EO interface
> forms one Ethernet segment.
> (Actually I am using three routers. But for easy debugging
> presently I am working with one router)
> 
> Router 1’s E1 interface, Voice generator and background traffic
> generator form other Ethernet LAN.
> 
> I am limiting bandwidth of router E0 interface to 48kbps by
> below commands:
> 
> ***********
> I am sniffing at the interface E0 using Ethereal
> sniffer-protocol analyzer. But I am unable to get better
> results for voice application over background traffic. For both
> Testing without QoS and with QoS I am getting the same results.
> 
> FOR EVERY VOICE PACKET I GET ONE BACKGROUND PACKET- SAME
> RESULTS FOR BOTH WITH AND WITHOUT QOS DEPLOYED
> ***********
> 
> The voice application is generating at 32 kbps with packet size
> frame size of 876 bytes.
> It uses UDP port no 60600. It uses TCP port# 8896 for
> connection activeness. I am using these details in my QoS
> configurations.
> 
> For initial testing, I am also generating background traffic
> also with 32kbps rate and frame size of 876 bytes.
> 
> Since total net traffic voice + background = 32 + 32 = 64 Kbps,
> so I am reducing the bandwidth of the interface using ‘traffic
> shape’ and ‘rate-limit’ commands.
> 
> 
> 
> Router 1:
> 
> Option 1:
> 
> Conf  t
> int e 0
> rate-limit output 48000 6000 6000 conform-action transmit
> exceed-action drop
> 
> Option 2:
> 
> Conf t
> int e 0
> traffic-shape rate 48000 6000 6000 1000
> 
> I think with the above configuration, all traffic above 48000
> bps are dropped.
> So there are good chances that 24000 bps of both voice and data
> are sent, and remaining s 8000bps for both voice and background
> are dropped. So, therefore QoS does not come into picture
> because now total traffic is 48 but NOW actual interface
> bandwidth is 10 Mbps after the ‘rate-limit’ or ‘traffic-shape’
> phase.
> 
> IS THERE OTHER WAY TO REDUCE THE BANDWIDTH OF THE ETHERnet
> 
> InTERFACE.?
> 
> 
> My router configs for Priority queuing and class based weighted
> fair queuing
> 
> My Full router configuration: 
> Policy : Priority Queuing
> 
> ONE#show run
> Building configuration...
> 
> Current configuration : 1279 bytes
> !
> 
> hostname ONE
> !
> enable password cisco
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> !
> interface Ethernet0
> ip address 10.0.0.2 255.255.255.0
> rate-limit output 48000 6000 6000 conform-action transmit
> exceed-action drop
> priority-group 1
> !
> interface Ethernet1
>  ip address 10.10.0.1 255.255.255.0
> !
> !
> ip classless
> ip route 10.20.0.0 255.255.255.0 10.10.0.2
> ip route 10.30.0.0 255.255.255.0 10.10.0.2
> no ip http server
> ip pim bidir-enable
> !
> priority-list 1 protocol ip high tcp 8896
> priority-list 1 protocol ip high udp 60600
> no cdp run
> !
> !
> line con 0
>  escape-character BREAK
> line aux 0
> line vty 0 4
>  no login
> !
> end
> 
> +++++++++++
> CLASS BASED WEIGTED FAIR QUEUING
> 
> ONE#show run
> Building configuration...
> 
> Current configuration : 1279 bytes
> !
> 
> hostname ONE
> !
> enable password cisco
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> class-map match-all voice
>   match access-group 101
> !
> !
> policy-map catalyst
>   class voice
>     priority 36
>   class class-default
>    fair-queue 16
> !
> !
> !
> !
> interface Ethernet0
>  ip address 10.0.0.2 255.255.255.0
>  rate-limit output 48000 6000 6000 conform-action transmit
> exceed-action drop
>  service-policy output catalyst
> !
> interface Ethernet1
>  ip address 10.10.0.1 255.255.255.0
> !
> interface Serial0
>  ip address 10.10.10.10 255.255.255.0
> !
> interface Serial1
>  ip address 22.22.22.22 255.0.0.0
> !
> ip classless
> ip route 10.20.0.0 255.255.255.0 10.10.0.2
> ip route 10.30.0.0 255.255.255.0 10.10.0.2
> no ip http server
> ip pim bidir-enable
> !
> access-list 101 permit udp any any eq 60600
> access-list 101 permit tcp any any eq 8896
> no cdp run
> !
> !
> line con 0
>  escape-character BREAK
> line aux 0
> line vty 0 4
>  no login
> !
> end
> 
> ++++
> 
> Please explain me possible changes in my config/testbed  and
> any suggestion.
> 
> Thanks in Advance,
> 
> Vijay
> 
> 
> 
> 


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=74062&t=74036
--------------------------------------------------
**Please support GroupStudy by purchasing from the GroupStudy Store:
http://shop.groupstudy.com
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html

Reply via email to