> Date: Thu, 19 Jul 2001 15:50:38 -0400
> From: "Paul Werner" 
> Subject: Re: Subject: Why ISDN backup line come up ? [7:12920]
> 
------SNIP-------------

I will see if I can post an 
> improved/enhanced config in a separate post, possibly later 
> today as time permits.

I went ahead and took your existing configs and preserved as 
much as I could from them.  I added the functionality of dialer 
profiles to the config.  This gave three direct benefits.  
First, your ISDN interface will no longer be in a down status 
because it is a named standby interface.  Second, it allows you 
to use the ISDN interface to possibly back up a second serial 
line should you install one later.  Lastly, through the use of 
Cisco magic and a few extra lines of configuration, I was also 
able to set up your BRI interface to act as a Bandwidth on 
demand interface in the event that your primary WAN link gets 
congested.  Here they are:

RouterA#sh ru
Building configuration...

Current configuration : 1497 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
enable password cisco
!
username RouterB password 0 cisco
ip subnet-zero
no ip finger
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
interface Loopback0
 ip address 172.16.128.49 255.255.255.255
!
interface Ethernet0
 ip address 192.168.1.83 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 description "Leased link to RouterB"
 bandwidth 128
 backup delay 5 10
 backup interface Dialer1
 backup load 50 10
 ip address 172.16.128.17 255.255.255.252
 no ip route-cache
 no ip mroute-cache
 clockrate 148000
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0
 description "Backup link to RouterB"
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-5ess
 ppp authentication chap
 no fair-queue
 ppp multilink
!
interface Dialer1
 ip unnumbered Loopback0
 dialer pool 1
 dialer remote-name RouterB
 dialer string 88001
 dialer-group 1
!
router rip
 network 172.16.0.0
 network 192.168.1.0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end


Here is B:

RouterB#sh ru
Building configuration...

Current configuration : 1790 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
enable password cisco
!
username RouterA password 0 cisco
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
isdn switch-type basic-5ess
!
!
interface Loopback0
 ip address 172.16.128.50 255.255.255.255
!
interface Ethernet0
 mac-address 0000.0c00.2520
 ip address 192.168.2.83 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 description "Leased link to RouterA"
 bandwidth 128
 backup delay 5 10
 backup interface Dialer1
 backup load 50 10
 ip address 172.16.128.18 255.255.255.252
 no ip route-cache
 no ip mroute-cache
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0
 description "Backup connectivity to RouterA "
 no ip address
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool-member 1
 isdn switch-type basic-5ess
 no fair-queue
 ppp authentication chap
 ppp multilink
!
interface Dialer1
 ip unnumbered Loopback0
 dialer pool 1
 dialer remote-name RouterA
 dialer string 87001
 dialer-group 1
!
router rip
 network 172.16.0.0
 network 192.168.2.0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

The testing for the first part was to get an autoping going for 
20,000 pings.  Once it go started, I pulled out the serial 
connection.  Prior to doing this, I turned on the following 
debugs:

debug isdn q931
debug dialer
debug ppp neg

None of the debugs were necessary, unless something didn't 
work; I just thought it was fascinating to watch so much 
business go by while the interface was changing state.  For 
brevity, I omitted all debugs.  Here goes:

RouterB#pi
Protocol [ip]:
Target IP address: 192.168.1.83
Repeat count [5]: 20000
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 20000, 100-byte ICMP Echos to 192.168.1.83, timeout is 
2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!..................!!!!!!!!!!!!!!!!!!
!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!

The dots above represented several things.  It was the time 
required for the router to figure out the primary interface was 
down and the time I ordered it to wait until the backup came 
online.  Keep in mind the typical keepalive is set for 10 
seconds.  When I plugged the serial interface back in, the 
transition was seamless and no packets were dropped.

To simulate the second test, I telnetted to the loopback 
interface of each router and got a TTCP session going between 
the routers over the serial interface. if you are unfamiliar 
with TTCP, I recommend you do a search on CCO for this testing 
tool. I monitored the serial interface and when the load hit 
approximately 126/255, it brought the BRI link online.  It 
stayed online until the load dropped down to my preset value.

Since this config essentially frees up the BRI interface, it 
can also do the same duty for serial 1 if it is brought 
online.  Through the use of the priority command in the dialer 
pool statement, you can bias which dialer interface will have 
priority of operation should bandwidth on demand on Serial 0 be 
needed while backup interface operations on Serial 1 are 
required.

HTH,

Paul Werner

________________________________________________
Get your own "800" number
Voicemail, fax, email, and a lot more
http://www.ureach.com/reg/tag




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=13061&t=13061
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to