Re: [cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-28 Thread Pekka Enberg
On Thu, 2011-01-27 at 23:28 +0300, Ivan Maidanski wrote: 2. I hope (when you were composing this test case) that you produced the result value for abc\\E123\E manually by reading the spec, not by executing quote() and copy-pasting its result to this test case code ;) I copy-pasted the result

Re: [cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-27 Thread Pekka Enberg
On Fri, 2011-01-28 at 00:31 +, Dr Andrew John Hughes wrote: On 01:13 Fri 28 Jan , Ivan Maidanski wrote: Hi, Ok, since even if OpenJDK quote() is buggy, nonetheless we should reproduce its behavior in the Classpath. ;) Sadly, this is usually true, though obviously the

Re: [cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-26 Thread Pekka Enberg
) 2011 Pekka Enberg // This file is part of Mauve. // Mauve is free software; you can redistribute it and/or modify // it under the terms of the GNU General Public License as published by // the Free Software Foundation; either version 2, or (at your option) // any later version. // Mauve

[cp-patches] [PATCH v2] Implement Pattern.quote() API method

2011-01-26 Thread Pekka Enberg
/ChangeLog @@ -1,3 +1,8 @@ +2010-07-02 Ivan Maidanski iv...@mail.ru + + * java/util/regex/Pattern.java: + (quote): Implement new 1.5 Java API method. + 2011-01-21 Pekka Enberg penb...@kernel.org * java/lang/Class.java: diff --git a/java/util/regex/Pattern.java b/java/util

Re: [cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-26 Thread Pekka Enberg
On Wed, Jan 26, 2011 at 10:25 PM, Dr Andrew John Hughes ahug...@redhat.com wrote: On 22:15 Wed 26 Jan     , Pekka Enberg wrote: On Wed, 2011-01-26 at 20:10 +, Dr Andrew John Hughes wrote: On 22:41 Wed 26 Jan     , Ivan Maidanski wrote: Hi, It's ok but: 1. I'd better rewrote

Re: [cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-26 Thread Pekka Enberg
On Wed, 2011-01-26 at 23:33 +0300, Ivan Maidanski wrote: Please add a test for a string containing \E, e.g, abc\\E123\E Here's a new version of the test case. Pekka // Tags: JDK1.5 // Copyright (C) 2011 Pekka Enberg // This file is part of Mauve. // Mauve is free

[commit-cp] classpath ChangeLog java/util/regex/Pattern.java

2011-01-26 Thread Pekka Enberg
CVSROOT:/sources/classpath Module name:classpath Changes by: Pekka Enberg penberg 11/01/26 21:32:08 Modified files: . : ChangeLog java/util/regex: Pattern.java Log message: Implement Pattern.quote() API method Reviewed

Re: [cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-25 Thread Pekka Enberg
On Tue, Jan 25, 2011 at 1:36 AM, Dr Andrew John Hughes ahug...@redhat.com wrote: On 23:22 Mon 24 Jan     , Pekka Enberg wrote: On 22 January 2011 19:38, Pekka Enberg penb...@kernel.org wrote: From: Ivan Maidanski iv...@mail.ru 2010-07-02  Ivan Maidanski  iv...@mail.ru        * java

Re: [cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-25 Thread Pekka Enberg
. Here's a test case I came up with. Ivan, anything else I should test for? Pekka // Tags: JDK1.5 // Copyright (C) 2011 Pekka Enberg // This file is part of Mauve. // Mauve is free software; you can redistribute it and/or modify // it under the terms of the GNU General

Re: [cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-24 Thread Pekka Enberg
On 22 January 2011 19:38, Pekka Enberg penb...@kernel.org wrote: From: Ivan Maidanski iv...@mail.ru 2010-07-02  Ivan Maidanski  iv...@mail.ru        * java/util/regex/Pattern.java:        (quote): Implement new 1.5 Java API method. ---  ChangeLog                    |    5 +  java/util

Re: [cp-patches] [PATCH] Fix PrintStream constructor API differences for null

2011-01-23 Thread Pekka Enberg
On Sun, 2011-01-23 at 00:36 +, Dr Andrew John Hughes wrote: public PrintStream (OutputStream out, boolean auto_flush, String encoding) throws UnsupportedEncodingException { super (out); +if (out == null || encoding == null) + throw new NullPointerException();

Re: [cp-patches] [PATCH] Fix PrintStream constructor API differences for null

2011-01-23 Thread Pekka Enberg
went wrong e.g. The specified output stream was null.. I've included an updated patch below. Pekka From 264f44315ba45e1ecd95b5d6aee0ec8b7ce22db0 Mon Sep 17 00:00:00 2001 From: Pekka Enberg penb...@kernel.org Date: Sat, 22 Jan 2011 18:19:08 +0200 Subject: [PATCH] Fix

[commit-cp] classpath java/io/PrintStream.java ChangeLog

2011-01-23 Thread Pekka Enberg
CVSROOT:/sources/classpath Module name:classpath Changes by: Pekka Enberg penberg 11/01/23 13:00:52 Modified files: java/io: PrintStream.java . : ChangeLog Log message: Fix PrintStream constructor API differences for null

[cp-patches] [PATCH] Fix PrintStream constructor API differences for null

2011-01-22 Thread Pekka Enberg
2011-01-22 Pekka Enberg penb...@kernel.org * java/io/PrintStream.java (PrintStream): Throw NullPointerException if out or encoding is null to be compatible with OpenJDK. --- java/io/PrintStream.java |9 + 1 files changed, 9 insertions(+), 0 deletions(-) diff

[cp-patches] [PATCH] Implement Pattern.quote() API method

2011-01-22 Thread Pekka Enberg
. + 2011-01-21 Pekka Enberg penb...@kernel.org * java/lang/Class.java: diff --git a/java/util/regex/Pattern.java b/java/util/regex/Pattern.java index 7d1fc84..2aae9bb 100644 --- a/java/util/regex/Pattern.java +++ b/java/util/regex/Pattern.java @@ -1,5 +1,6 @@ /* Pattern.java -- Compiled

[commit-cp] classpath ChangeLog native/jni/java-lang/java_l...

2011-01-22 Thread Pekka Enberg
CVSROOT:/sources/classpath Module name:classpath Changes by: Pekka Enberg penberg 11/01/22 19:20:16 Modified files: . : ChangeLog native/jni/java-lang: java_lang_VMSystem.c Log message: Rename currentTimeMillis to currentTimeMicros

[commit-cp] classpath ChangeLog native/jni/java-lang/java_l...

2011-01-22 Thread Pekka Enberg
CVSROOT:/sources/classpath Module name:classpath Changes by: Pekka Enberg penberg 11/01/22 19:28:02 Modified files: . : ChangeLog native/jni/java-lang: java_lang_VMSystem.c Log message: Fix clock_gettime() fallback

Re: [cp-patches] [PATCH] Fix java.lang.Class field and method API for null names

2011-01-21 Thread Pekka Enberg
On Mon, Dec 13, 2010 at 5:41 PM, Pekka Enberg penb...@kernel.org wrote: On Mon, Dec 13, 2010 at 2:53 PM, Dr Andrew John Hughes ahug...@redhat.com wrote: OK, I'm sorry I'm having some difficulties adjusting to GNU style of working. I'll update the patch and resend. Please just post

[commit-cp] classpath java/lang/Class.java ChangeLog

2011-01-21 Thread Pekka Enberg
CVSROOT:/sources/classpath Module name:classpath Changes by: Pekka Enberg penberg 11/01/21 19:59:15 Modified files: java/lang : Class.java . : ChangeLog Log message: Fix java.lang.Class field and method API for null names

Re: gij: unrecognized option -- `-o'

2010-12-16 Thread Pekka Enberg
On Thu, Dec 16, 2010 at 12:36 PM, Andrew Haley a...@redhat.com wrote: On 05/19/2010 09:13 PM, KessiMC wrote: Hi everyone Having finally become somewhat more confident in trying to cross-compile GNU Classpath, I dastardly failed on my most recent attempt with the following error message:

Re: [cp-patches] [PATCH] Fix java.lang.Class field and method API for null names

2010-12-13 Thread Pekka Enberg
On Mon, Dec 13, 2010 at 12:08 PM, Andrew Haley a...@redhat.com wrote: On 12/12/2010 11:46 AM, Pekka Enberg wrote: This patch fixes Class getDeclaredField, getDeclaredMethod, getField, and getMethod API to throw NullPointerException if given name is null. Thanks, but two things: a.  What

Re: [cp-patches] [PATCH] Fix java.lang.Class field and method API for null names

2010-12-13 Thread Pekka Enberg
to apply. 2010-12-13 Pekka Enberg penb...@kernel.org * java/lang/Class.java: (getDeclaredField): Throw NullPointerException instead of NoSuchFieldException if name is null. (getField): Likewise. (getDeclaredMethod): Throw NullPointerException instead

[cp-patches] [PATCH] Fix java.lang.Class field and method API for null names

2010-12-12 Thread Pekka Enberg
This patch fixes Class getDeclaredField, getDeclaredMethod, getField, and getMethod API to throw NullPointerException if given name is null. Signed-off-by: Pekka Enberg penb...@kernel.org --- java/lang/Class.java | 12 1 files changed, 12 insertions(+), 0 deletions(-) diff --git

Re: Future blog

2010-12-12 Thread Pekka Enberg
for getSimpleName(). Pekka From 3637ab8ec4f866da6fadc092eab1f99ce4adb417 Mon Sep 17 00:00:00 2001 From: Pekka Enberg penb...@kernel.org Date: Sun, 12 Dec 2010 10:52:27 +0200 Subject: [PATCH] mauve: Add test case for Class.getSimpleName() Signed-off-by: Pekka Enberg penb

[cp-patches] [PATCH v2] Fix VMClass#getSimpleName() implementation

2010-12-08 Thread Pekka Enberg
This patch replaces VMClass#getSimpleName() implementation with JamVM's version that supposedly comes from GCJ. This fixes a compatibility problem found by Malva. Signed-off-by: Pekka Enberg penb...@kernel.org --- vm/reference/java/lang/VMClass.java | 29 +++-- 1 files

Re: Future blog

2010-12-08 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 12:32 PM, Andrew Haley a...@redhat.com wrote: Anyway, I don't mind that as long as someone else does it.  (Clearly, the issue of developers without commit access is a red herring, as every developer should have commit access.) But it's not a red herring! I don't expect

Re: Future blog

2010-12-08 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 12:32 PM, Andrew Haley a...@redhat.com wrote: I hereby offer to review some patches.  Please send pointers to the list. http://developer.classpath.org/pipermail/classpath-patches/2010-November/006511.html

Re: Future blog

2010-12-08 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 12:32 PM, Andrew Haley a...@redhat.com wrote: But I'm afraid people are looking at the things they think might make a difference, but won't make a difference.  I read the list, and haven't seen a huge number of unreviewed patches, but I admit I haven't been paying close

Re: Future blog

2010-12-08 Thread Pekka Enberg
Hi Andrew, On Wed, Dec 8, 2010 at 1:06 PM, Andrew Haley a...@redhat.com wrote: On 12/08/2010 10:56 AM, Pekka Enberg wrote: On Wed, Dec 8, 2010 at 12:32 PM, Andrew Haley a...@redhat.com wrote: Anyway, I don't mind that as long as someone else does it.  (Clearly, the issue of developers without

Re: Future blog

2010-12-08 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 1:13 PM, Andrew Haley a...@redhat.com wrote: There's also 10-15 patches from Ivan sitting in the archives Hmm, I had seen some discussion around those and thought they were being addressed.  Bring them on! I'm not sure if this is all of it but it's a start anyway:

Re: Future blog

2010-12-08 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 1:13 PM, Andrew Haley a...@redhat.com wrote: http://developer.classpath.org/pipermail/classpath-patches/2010-November/006512.html What compatibility problem does this fix? That the result is not what we get with OpenJDK. JamVM, for example, (and I guess CACAO) has fixed

Re: Future blog

2010-12-08 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 1:41 PM, Andrew Haley a...@redhat.com wrote: I'm not sure if this is all of it but it's a start anyway: http://developer.classpath.org/pipermail/classpath-patches/2010-June/006411.html Ah, yes, these were the patches that were sent hex encoded with a MIME type of

Re: Future blog

2010-12-08 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 1:47 PM, Andrew Haley a...@redhat.com wrote: That the result is not what we get with OpenJDK. JamVM, for example, (and I guess CACAO) has fixed this in their tree as has GCJ. The test case I used for this is ClassTest.testGetSimpleName() here:

Re: Future blog

2010-12-08 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 2:03 PM, Andrew Haley a...@redhat.com wrote: No need to live with it, I'll fix it up and resend. This is truly weird.  The gcj patch says: 2008-05-22  Andrew Haley  a...@redhat.com        PR libgcj/35020        * java/lang/Class.java (getSimpleName): Import from GNU

Re: [cp-patches] Fwd: Patch for parse() of DecimalFormat and SimpleDateFormat

2010-12-07 Thread Pekka Enberg
On Tue, Dec 7, 2010 at 3:25 PM, Dr Andrew John Hughes ahug...@redhat.com wrote: I meant applications relying on the current behavior of OpenJDK so it's probably not worth it to make the behavior correct in either of the projects. But sure, I do think your patch is an improvement as-is so I'm

Re: Future blog

2010-12-07 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 1:53 AM, Dr Andrew John Hughes gnu_and...@member.fsf.org wrote: As soon as I am back I would like us to at least start moving to mercurial on savannah if people don't mind. Yes, I do mind. We already discussed this some time back:

Re: Future blog

2010-12-07 Thread Pekka Enberg
On Wed, Dec 8, 2010 at 1:53 AM, Dr Andrew John Hughes gnu_and...@member.fsf.org wrote: For those who didn't see Pekka's blog on planet.classpath.org you can find it here: http://penberg.posterous.com/whats-the-future-of-gnu-classpath He makes some very good points. I agree with all of them.

Re: [cp-patches] Fwd: Patch for parse() of DecimalFormat and SimpleDateFormat

2010-12-06 Thread Pekka Enberg
[ Sorry for the delay. ] On Sat, 27 Nov 2010, Ivan Maidanski wrote: Sorry for the provided test below - it doesn't test the things that are fixed by the attached patch. In fact, the test is for a bug that has been already fixed since Classpath v0.93 (by not relying on setMaximumIntegerDigits

Re: [cp-patches] Minor refactoring of PrintStream

2010-12-06 Thread Pekka Enberg
/classpath-patches/2010-June/006410.html [ There's still constructor throwing IllegalArgumentException where NPE happens with Oracle JDK. ] The patch looks good to me apart from the line_separator static modifier removal so FWIW, Reviewed-by: Pekka Enberg penb...@kernel.org

Re: [cp-patches] Fwd: Patch for parse() of DecimalFormat and SimpleDateFormat

2010-12-06 Thread Pekka Enberg
Hi Ivan, 2010/12/6 Ivan Maidanski iv...@mail.ru: Sorry for the provided test below - it doesn't test the things that are fixed by the attached patch. In fact, the test is for a bug that has been already fixed since Classpath v0.93 (by not relying on setMaximumIntegerDigits implementation).

Re: [cp-patches] Fwd: Patch for parse() of DecimalFormat and SimpleDateFormat

2010-12-06 Thread Pekka Enberg
2010/12/6 Ivan Maidanski iv...@mail.ru: I'm bit surprised, though, that we'd want behavior that doesn't match Sun JRE. To me, any API behavior (even if it's a bug) that has lived long enough in Sun JRE is what Classpath ought to aim at. Compatibility is not just following the specification

Re: [cp-patches] Fwd: Patch for parse() of DecimalFormat and SimpleDateFormat

2010-12-06 Thread Pekka Enberg
2010/12/6 Ivan Maidanski iv...@mail.ru: Googling around doesn't seem to bring anything on the topic which makes me think this is an old bug that nobody really cares about but there can be applications out there that rely on the current behavior that would be broken under GNU Classpath. Not

[cp-patches] [PATCH 1/3] Rename currentTimeMillis to currentTimeMicros

2010-11-23 Thread Pekka Enberg
This patch renames currentTimeMillis to currentTimeMicros in java_lang_VMSystem.c to reflect what the function returns. Cc: Andrew Hughes gnu_and...@members.fsf.org Cc: Ivan Maidanski iv...@mail.ru Signed-off-by: Pekka Enberg penb...@kernel.org --- native/jni/java-lang/java_lang_VMSystem.c

[cp-patches] [PATCH 3/3] Fix VMClass#getSimpleName() implementation

2010-11-23 Thread Pekka Enberg
This patch replaces VMClass#getSimpleName() implementation with JamVM's version that supposedly comes from GCJ. This fixes a compatibility problem found by Malva. Signed-off-by: Pekka Enberg penb...@kernel.org --- vm/reference/java/lang/VMClass.java | 34 +- 1

[cp-patches] [PATCH 2/3] Fix clock_gettime() fallback

2010-11-23 Thread Pekka Enberg
: Ivan Maidanski iv...@mail.ru Signed-off-by: Pekka Enberg penb...@kernel.org --- native/jni/java-lang/java_lang_VMSystem.c |4 +--- 1 files changed, 1 insertions(+), 3 deletions(-) diff --git a/native/jni/java-lang/java_lang_VMSystem.c b/native/jni/java-lang/java_lang_VMSystem.c index 44f789f

Re: [cp-patches] Fwd: Re[2]: [PATCH v2] Use CLOCK_MONOTONIC for System.nanoTime

2010-11-23 Thread Pekka Enberg
On Sun, 21 Nov 2010, Ivan Maidanski wrote: Some issues to be corrected in you patch: 1. currentTimeMillis() should be renamed to currentTimeMicros() as it returns microseconds (not milliseconds). 2. clock_gettime(CLOCK_MONOTONIC) may fail on some machines (even if _POSIX_MONOTONIC_CLOCK has

Re: [cp-patches] [PATCH v2] Use CLOCK_MONOTONIC for System.nanoTime

2010-11-04 Thread Pekka Enberg
On 11/4/10 3:18 PM, Dr Andrew John Hughes wrote: Sorry for the delay on this, but I'm unsure about the copyright situation. From reading http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44411, it seems to be the work of Roland Brand, it's his first patch and both myself and Mark agree it's trivial

Re: [cp-patches] [PATCH v2] Use CLOCK_MONOTONIC for System.nanoTime

2010-10-26 Thread Pekka Enberg
On 26.10.2010 23.00, Pekka Enberg wrote: Hi everyone, I'm now carrying this and one other patch in my github branch: http://github.com/penberg/classpath/tree/maint/penberg It's frustrating that CVS trunk doesn't build out of the box and that reviewed patches are not getting merged

[cp-patches] [PATCH] native: Use CLOCK_MONOTONIC for System.nanoTime

2010-09-23 Thread Pekka Enberg
roland.br...@ergon.ch Bugzilla-URL: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44411 Signed-off-by: Pekka Enberg penb...@kernel.org --- native/jni/java-lang/java_lang_VMSystem.c | 26 +- vm/reference/java/lang/VMSystem.java |5 + 2 files changed, 26 insertions

[cp-patches] [PATCH v2] Use CLOCK_MONOTONIC for System.nanoTime

2010-09-23 Thread Pekka Enberg
Wielaard m...@klomp.org Cc: Roland Brand roland.br...@ergon.ch Bugzilla-URL: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44411 Signed-off-by: Pekka Enberg penb...@kernel.org --- v1 - v2: Use strerror() to pass human readable error message to FatalError() as suggested by Andrew Hughes

[ANNOUNCE] Jato v0.1.1 - a JIT-only virtual machine for Java

2010-09-18 Thread Pekka Enberg
when there's nothing to load x86-64: fix call to fixup_vtable() from trampolines Jim Huang (1): vm: Update URL to Java online documentation Pekka Enberg (146): runtime: Implement Runtime.availableProcessors() runtime: Implement Runtime.freeMemory() and Runtime.totalMemory

[ANNOUNCE] Jato v0.0.1 - a simple JIT-only virtual machine for Java

2009-09-09 Thread Pekka Enberg
Hi all, I am proud to announce the release of Jato v0.0.1 buy more RAM-edition! Jato is a JIT-only virtual machine for Java that can run some simple programs under GNU/Linux on modern 32-bit x86 CPUs. A port to the x86-64 machine architecture is currently being developed. Jato depends on GNU

<    1   2