Re: [cp-patches] [generics] RFC: new Enum java.math.RoundingMode

2006-02-21 Thread Andrew John Hughes
On Mon, 2006-02-20 at 17:33 -0500, Anthony Balkissoon wrote: On Mon, 2006-02-20 at 15:09 -0500, Anthony Balkissoon wrote: This is RFC because it's my first commit to the generics branch and I just want to make sure there aren't any special procedures I forgot. 2006-02-20 Anthony

[cp-patches] [Patch] Removed empty file

2006-02-21 Thread Michael Koch
Hello list, I removed the attached file as its empty, no java class inside. And it confuses GCJ when using current classpath CVS as snapshot when building gcj 4.1 or gcj trunk. Cheers, Michael 2006-02-21 Michael Koch [EMAIL PROTECTED] * gnu/javax/net/ssl/provider/PRNG.java:

Re: [cp-patches] [generics] RFC: new Enum java.math.RoundingMode

2006-02-21 Thread Tom Tromey
Anthony == Anthony Balkissoon [EMAIL PROTECTED] writes: Anthony Also, I forgot to put the GNU Classpath header in Anthony RoundingMode, but this patch includes it. For some reason the generics branch doesn't have this header template... some merge problem I supposed, but I haven't looked.

[cp-patches] FYI: ZipConstants patch

2006-02-21 Thread Jeroen Frijters
Hi, I committed Stuart's patch. Regards, Jeroen 2006-02-20 Stuart Ballard [EMAIL PROTECTED] * java/util/zip/ZipConstants.java (LOCSIG): Change type to long. (EXTSIG): Likewise. (CENSIG): Likewise. (ENDSIG): Likewise. *

[cp-patches] RFC: fixed implemented highlighting - 2nd try

2006-02-21 Thread Robert Schuster
Hi all. I fixed to small errors in this patch that lead to strange behavior: + // Last line, from beginning-of-line to p1. + r0.width = r1.x + r1.width; Had to add -1 to the calculation above otherwise there were drawing differences between single line and multi line selections. +

Re: [cp-patches] RFC: fixed implemented highlighting - 2nd try

2006-02-21 Thread Robert Schuster
Committed - Roman reviewed the first version. cya Robert Robert Schuster wrote: Hi all. I fixed to small errors in this patch that lead to strange behavior: + // Last line, from beginning-of-line to p1. + r0.width = r1.x + r1.width; Had to add -1 to the calculation above

Re: [cp-patches] RFC: fixed implemented highlighting - 2nd try

2006-02-21 Thread Lillian Angel
On Tue, 2006-02-21 at 11:56 +0100, Robert Schuster wrote: Committed - Roman reviewed the first version. cya Robert I get this when I run the swing demo. Any idea why? [EMAIL PROTECTED] examples]$ jamvm gnu/classpath/examples/swing/Demo Exception during event dispatch:

[cp-patches] FYI: new NavigationFilter method

2006-02-21 Thread Roman Kennke
The last missing methods in Swing vs Japi are falling. Here comes NavigationFilter.getNextVisualPositionFrom(), which was quite trivial. 2006-02-21 Roman Kennke [EMAIL PROTECTED] * javax/swing/text/NavigationFilter.java (getNextVisualPositionFrom): New method. /Roman Index:

Re: [cp-patches] RFC: fixed implemented highlighting - 2nd try

2006-02-21 Thread Lillian Angel
On Tue, 2006-02-21 at 09:45 -0500, Lillian Angel wrote: I get this when I run the swing demo. Any idea why? [EMAIL PROTECTED] examples]$ jamvm gnu/classpath/examples/swing/Demo Exception during event dispatch: java.lang.NullPointerException at

Re: [cp-patches] RFC: Fixlets for java.awt.CardLayout

2006-02-21 Thread Wolfgang Baer
Wolfgang Baer wrote: Hi, I tested an application here which called CardLayout's show method with a null parameter triggering a wrong NPE. The changes are backed by the recently committed mauve tests for this class. 2006-02-11 Wolfgang Baer [EMAIL PROTECTED] *

Re: [cp-patches] [generics] RFC: new Enum java.math.RoundingMode

2006-02-21 Thread Anthony Balkissoon
This is committed as: 2006-02-21 Anthony Balkissoon [EMAIL PROTECTED] * java/math/MathContext.java: New class. * java/math/RoundingMode: New Enum. In response to Andrew and Tom: Andrew: Yes, the only thing restricting this to the generics branch is the Enum. But reading

[cp-patches] Re: RFC: LightweightPeers reworked

2006-02-21 Thread Lillian Angel
On Tue, 2006-02-21 at 10:28 -0500, Lillian Angel wrote: Hello, Tom F. and I worked on changing how we handle Container lightweights and Component lightweights. This bug showed up in MegaMek and several test cases. Attached is the test case that we used to fix this. Try it without the patch

[cp-patches] RFC: LightweightPeers reworked

2006-02-21 Thread Lillian Angel
Hello, Tom F. and I worked on changing how we handle Container lightweights and Component lightweights. This bug showed up in MegaMek and several test cases. It appeared that Containers should be handled differently. When a Container was placed in a Window, and contained Heavyweight components,

[cp-patches] FYI: WrappedPlainView fixlet

2006-02-21 Thread Roman Kennke
One of my last fixes showed up a problem with WrappedPlainView, which is fixed by this patch. 2006-02-21 Roman Kennke [EMAIL PROTECTED] * javax/swing/text/WrappedPlainView.java (calculateBreakPosition): Changed to use the view's allocation instead of the container's

[cp-patches] FYI: Documentation update for StreamPrintService

2006-02-21 Thread Wolfgang Baer
Hi, changelog says all. 2006-02-21 Wolfgang Baer [EMAIL PROTECTED] * javax/print/StreamPrintService.java: Added and enhanced documentation. Wolfgang Index: javax/print/StreamPrintService.java === RCS file:

Re: [cp-patches] [generics] RFC: new Enum java.math.RoundingMode

2006-02-21 Thread Andrew John Hughes
On Tue, 2006-02-21 at 10:42 -0500, Anthony Balkissoon wrote: This is committed as: 2006-02-21 Anthony Balkissoon [EMAIL PROTECTED] * java/math/MathContext.java: New class. * java/math/RoundingMode: New Enum. In response to Andrew and Tom: Andrew: Yes, the only

Re: [cp-patches] RFC: LightweightPeers reworked

2006-02-21 Thread Scott Gilbertson
I wonder if you could have a look at this change, half of which I claim is related: http://developer.classpath.org/pipermail/classpath/2006-February/000157.html I originally submitted it for GCJ (hence the superfluous libjava/ on all the paths), but it needs to go in Classpath before checking in

Re: [cp-patches] RFC: LightweightPeers reworked

2006-02-21 Thread Thomas Fitzsimmons
On Tue, 2006-02-21 at 10:28 -0500, Lillian Angel wrote: Hello, Tom F. and I worked on changing how we handle Container lightweights and Component lightweights. This bug showed up in MegaMek and several test cases. It appeared that Containers should be handled differently. When a Container

Re: [cp-patches] RFC: LightweightPeers reworked

2006-02-21 Thread Lillian Angel
On Tue, 2006-02-21 at 12:19 -0500, Scott Gilbertson wrote: I wonder if you could have a look at this change, half of which I claim is related: http://developer.classpath.org/pipermail/classpath/2006-February/000157.html Attached is a newly updated patch to incorporate Scott's patch, Mark

Re: [cp-patches] RFC: LightweightPeers reworked

2006-02-21 Thread Thomas Fitzsimmons
On Tue, 2006-02-21 at 13:09 -0500, Lillian Angel wrote: GLightweightPeer should probably be renamed to LightweightComponentPeer though, and GtkLightweightPeer should be GtkLightweightContainerPeer. Attached is the updated patch. OK, a few comments: +public class LightweightComponentPeer

Re: [cp-patches] RFC: LightweightPeers reworked

2006-02-21 Thread Scott Gilbertson
Update - my JamVM setup is working now (Thanks Robert Lougher) so I can confirm that the LightweightRepaintTest program fails with JamVM + Classpath (recent from cvs) + GTK peers. So it looks like my GLightweightPeer.repaint changes are indeed required to pass that test. Without the patch, the

[cp-patches] [generics] new BigDecimal methods.

2006-02-21 Thread Anthony Balkissoon
Here are some of the missing BigDecimal methods. More are coming but I'm committing these now so the JAPI results will be more readable. 2006-02-21 Anthony Balkissoon [EMAIL PROTECTED] * java/math/BigDecimal.java: (mathContext): New field. (precision): Likewise.

Re: [cp-patches] RFC: LightweightPeers reworked

2006-02-21 Thread Thomas Fitzsimmons
On Tue, 2006-02-21 at 19:11 -0500, Lillian Angel wrote: +// This should be overridden by default Toolkit (eg. GtkToolkit). +// If target is an instance of Container, then a GtkLightweightContainerPeer +// should be returned. Otherwise, an instance of LightweightComponentPeer is +