[cp-patches] FYI: small Swing demo fix

2006-06-07 Thread Robert Schuster
Hi, with this patch the Look and Feel radion buttons in the Swing demo are put into the same button group. ChangeLog: 2006-06-07 Robert Schuster [EMAIL PROTECTED] * examples/gnu/classpath/examples/swing/Demo.java: (mkMenuBar): Put look and feel radio buttons into

RE: [cp-patches] RFC: qt-peer: remove INIT_LOAD_LIBRARY

2006-06-07 Thread Jeroen Frijters
Tom Tromey wrote: (It is kind of lame to have INIT_LOAD_LIBRARY floating around just for libgcj... but I suppose it isn't a very big maintenance burden. Or does IKVM use it too?) IKVM doesn't use it, because it replaces all VM classes that have native methods. As a long term goal, I'd still

[cp-patches] XML streams debugging and partial workaround for #27664

2006-06-07 Thread Chris Burdess
I committed this patch which adds support for debugging XML streams via a system property (other suggestions welcomed) and also provides a workaround for a mark/reset problem somewhere in BufferedReader or CRLFReader by not reading more characters than are necessary in XMLParser.tryRead.

Re: [cp-patches] RFC: fix for PR27864

2006-06-07 Thread Robert Schuster
Hi, unfortunately the fix you proposed yesterday on IRC did not work. I have further investigate the problem to find out about your consideration about an NPE happening because of my patch: I found out that if root is null, the code will not reach that code location because then 'here' would be

[cp-patches] Re: FYI: GlyphVector reimplementation

2006-06-07 Thread Sven de Marothy
Finally, 2006-06-05 Sven de Marothy [EMAIL PROTECTED] * gnu/java/awt/peer/gtk/GdkGlyphVector: Removed file.

[cp-patches] FYI: GlyphVector reimplementation

2006-06-07 Thread Sven de Marothy
2006-06-05 Sven de Marothy [EMAIL PROTECTED] * gnu/java/awt/peer/gtk/FreetypeGlyphVector.java * include/gnu_java_awt_peer_gtk_FreetypeGlyphVector.h * native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c New files. *

[cp-patches] FYI: more JTree fixes

2006-06-07 Thread Roman Kennke
I fixed a couple more problems with JTree that showed up in OpenJump (yesterday I made a mistake and started OpenJump with the wrong VM). Mostly they have to do with dealing with null pointers in the UI and tree related classes. One important piece is that in the VariableHeightLayoutCache we need

Re: [cp-patches] FYI: GlyphVector reimplementation

2006-06-07 Thread Roman Kennke
Hi Sven, Am Mittwoch, den 07.06.2006, 15:50 +0200 schrieb Sven de Marothy: 2006-06-05 Sven de Marothy [EMAIL PROTECTED] * gnu/java/awt/peer/gtk/FreetypeGlyphVector.java ... You don't loose much words except for the ChangeLog entries, eh? ;-) It would be helpful to add some

Re: [cp-patches] RFC: fix for PR27864

2006-06-07 Thread Chris Burdess
Robert Schuster wrote: unfortunately the fix you proposed yesterday on IRC did not work. I have further investigate the problem to find out about your consideration about an NPE happening because of my patch: I found out that if root is null, the code will not reach that code location

[cp-patches] FYI: rewrite File.toCanonicalPath()

2006-06-07 Thread Gary Benson
Hi all, I just checked in a rewrite of File.toCanonicalPath() for GNU/Posix systems to make it correctly handle symbolic links. It's basically a JNIified version of the one I committed yesterday for GCJ. This fixes PR 24895. Cheers, Gary Index: ChangeLog

[cp-patches] Patch: FreetypeGlyphVector and String fix

2006-06-07 Thread Lillian Angel
I have started working on limewire. This patch fixes the exceptions that were thrown at startup. 2006-06-07 Lillian Angel [EMAIL PROTECTED] * gnu/java/awt/peer/gtk/FreetypeGlyphVector.java (FreetypeGlyphVector): Removed assignment. Caused compilation error. *

Re: [cp-patches] RFC: Move gnu.regexp to gnu.java.util.regex

2006-06-07 Thread Andrew John Hughes
On Wed, 2006-06-07 at 17:35 +0200, Roman Kennke wrote: Hi there, I'd like to propose to rename the gnu.regexp package to gnu.java.util.regex or something. I have a problem here with JEdit which obviously uses an old version of gnu regexp and no hit some AbstractMethodError with this setup.

[cp-patches] RFC: small JMenuBar fix

2006-06-07 Thread Francis Kung
Hi, While writing some Mauve tests, I came across a small bug in JMenuBar's getSubElements() method: instead of returning an array of only menu's, we currently insert null values for non-menu components as well. A patch is attached. Regards, Francis 2006-06-07 Francis Kung [EMAIL PROTECTED]

[cp-patches] Patch: BasicTabbedPaneUI fixlet

2006-06-07 Thread Lillian Angel
Small fix for limewire. Prevents an ArrayOutofBoundsException 2006-06-07 Lillian Angel [EMAIL PROTECTED] * javax/swing/plaf/basic/BasicTabbedPaneUI.java (getTabBounds): If this method is called with a tab index that is not in the rects array, we need to re-layout the

[cp-patches] FYI: CairoGraphics clipping fix

2006-06-07 Thread Roman Kennke
The clip(Shape) method wasn't implemented correctly. It simply called setClip(), but it really should intersect the current clip with the specified shape. I adapted this method from AbstractGraphics2D. This fixes all remaining Swing painting problems (at least for me). 2006-06-07 Roman Kennke

[cp-patches] FYI: [generics] Document InputMismatchException

2006-06-07 Thread Andrew John Hughes
This patch documents java.util.InputMismatchException. AFAICS, this represents the final file that a) needs documenting and b) sending over to HEAD. Roll on gcj+ecj for the rest... Changelog: 2006-06-07 Andrew John Hughes [EMAIL PROTECTED] * java/util/InputMismatchException.java:

[cp-patches] Patch: FYI: PR 27905

2006-06-07 Thread Tom Tromey
I'm checking this in. This fixes PR 27905. We weren't registering all the nio charsets we implement. Tom 2006-06-07 Tom Tromey [EMAIL PROTECTED] PR classpath/27905: * gnu/java/nio/charset/Provider.java (loadExtended): Now synchronized. Added missing charsets.

Re: [cp-patches] [generics] Patch: RFC: import jsr166

2006-06-07 Thread Mark Wielaard
Hi Tom, On Thu, 2006-05-25 at 09:55 -0600, Tom Tromey wrote: This patch imports the jsr166 reference implementation. This is implements java.util.concurrency. Nice. I'll write fsf legal to let them know how we are importing this for the records. Please wait with the actual import till we get

[cp-patches] Re: RFC: add a cacerts file under resource/java/security

2006-06-07 Thread Mark Wielaard
Hi Raif, I CCed the devjam list on which a couple of different distribution packagers are subscribed. Devjam people, Raif added support for importing trusted ca-certs to GNU Classpath so our tls/ssl implementation for example can just reuse the ca-certs that are already packaged for an

Re: [cp-patches] RFC: Move gnu.regexp to gnu.java.util.regex

2006-06-07 Thread Tom Tromey
Roman == Roman Kennke [EMAIL PROTECTED] writes: Roman I'd like to propose to rename the gnu.regexp package to Roman gnu.java.util.regex or something. I have a problem here with JEdit which Roman obviously uses an old version of gnu regexp and no hit some Roman AbstractMethodError with this

Re: [cp-patches] RFC: Move gnu.regexp to gnu.java.util.regex

2006-06-07 Thread Casey Marshall
On Jun 7, 2006, at 8:35 AM, Roman Kennke wrote: Hi there, I'd like to propose to rename the gnu.regexp package to gnu.java.util.regex or something. I have a problem here with JEdit which obviously uses an old version of gnu regexp and no hit some AbstractMethodError with this setup. I think

Re: [cp-patches] RFC: small JMenuBar fix

2006-06-07 Thread Lillian Angel
On Wed, 2006-06-07 at 14:37 -0400, Francis Kung wrote: Hi, While writing some Mauve tests, I came across a small bug in JMenuBar's getSubElements() method: instead of returning an array of only menu's, we currently insert null values for non-menu components as well. A patch is attached.

Re: [cp-patches] Re: RFC: add a cacerts file under resource/java/security

2006-06-07 Thread Casey Marshall
One nice way to do this ca-certs stuff is to write a keystore implementation that just reads certificates out of a directory, and with each certificate stored in its own file. This would make it a lot easier for Classpath to use the certificates already installed on the system (like

[cp-patches] FYI: BasicTreeUI

2006-06-07 Thread Roman Kennke
I've implemented a few more methods in BasicTreeUI. 2006-06-07 Roman Kennke [EMAIL PROTECTED] * javax/swing/plaf/basic/BasicTreeUI.java (completeUIUninstall): Implemented. (uninstallUI): Moved some bits to completeUIUninstall(). Complete editing before

[cp-patches] FYI: Merge java.util.InputMismatchException

2006-06-07 Thread Andrew John Hughes
Final class (I hope...) Changelog: 2006-06-07 Andrew John Hughes [EMAIL PROTECTED] * java/util/InputMismatchException.java: Documented. 2005-04-20 Tom Tromey [EMAIL PROTECTED] * java/util/InputMismatchException.java: New file. -- Andrew :-) Please avoid sending

[cp-patches] FYI: remove INIT_LOAD_LIBRARY from Qt peers

2006-06-07 Thread Thomas Fitzsimmons
Hi, I committed this patch that removes the INIT_LOAD_LIBRARY check from the Qt peers. libgcj no longer requires INIT_LOAD_LIBRARY for the peers because of a change in how they are loaded. Tom 2006-06-07 Thomas Fitzsimmons [EMAIL PROTECTED] * gnu/java/awt/peer/qt/QtToolkit.java

Re: [cp-patches] FYI: GlyphVector reimplementation

2006-06-07 Thread Sven de Marothy
On Wed, 2006-06-07 at 16:45 +0200, Roman Kennke wrote: You don't loose much words except for the ChangeLog entries, eh? ;-) It would be helpful to add some descriptive text too, so others can get up to what you did. Otherwise we wouldn't need this ML and could depend on commit-classpath for

[cp-patches] RFC: First steps to address PR27649

2006-06-07 Thread Vivek Lakshmanan
For PR27649: making it easy to separate crypto specific classes into an independent jar, by removing direct calls to gnu.classpath.SystemProperties. These calls have been replaced by AccessController.doPrivileged calls using GetPropertyAction (for improving readability). Thanks, Vivek

[cp-patches] FYI: Glyphvector kerning.

2006-06-07 Thread Sven de Marothy
2006-06-08 Sven de Marothy [EMAIL PROTECTED] * gnu/java/awt/peer/gtk/FreetypeGlyphVector.java (defaultLayout): Do kerning. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c (getKerning): Correct class name, removed unused variable. Index:

[cp-patches] Stub TextLayout

2006-06-07 Thread Sven de Marothy
Time to remove this unnecessary peer interface and replace the stub peer with a stubbed actual impl. Yay! This makes our JAPI scores more honest. Ok? /Sven 2006-06-08 Sven de Marothy [EMAIL PROTECTED] * java/awt/font/TextLayout: Replace methods with stubs. *

Re: [cp-patches] RFC: First steps to address PR27649

2006-06-07 Thread Casey Marshall
On Jun 7, 2006, at 4:20 PM, Vivek Lakshmanan wrote: For PR27649: making it easy to separate crypto specific classes into an independent jar, by removing direct calls to gnu.classpath.SystemProperties. These calls have been replaced by AccessController.doPrivileged calls using