Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Alan Bateman
On Wed, 30 Aug 2023 17:38:01 GMT, Stefan Karlsson wrote: > I wouldn't be opposed to a change that: > > * Keeps the `createJavaProcessBuilder` name > * Renames `createTestJvm` to `createJavaProcessBuilderPrependTestOpts` > * Renames `executeTestJvm` to `executeJavaPrependTestOpts` > * Removes `cr

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread David Holmes
On Wed, 30 Aug 2023 11:31:20 GMT, Mark Sheppard wrote: > So you could create a single createJavaProcessBuilder with add an additional > parameter boolean addTestOpts e.g. createJavaProcessBuilder(List command, boolean addTestOpts) { ... } @msheppar that is actually where we started, and it was

Re: RFR: 8311585: Add JRadioButtonMenuItem to bug8031573.java [v4]

2023-08-30 Thread Rajat Mahajan
On Wed, 30 Aug 2023 20:36:45 GMT, Alexey Ivanov wrote: >> Rajat Mahajan has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Update bug8031573.java >> >> remove macosx from summary . > > test/jdk/javax/swing/JMenuItem/8031573/bug8031573.

Re: RFR: JDK-8311113: Remove invalid pointer cast and clean up setLabel() in awt_MenuItem.cpp

2023-08-30 Thread Sergey Bylokhov
On Thu, 31 Aug 2023 00:42:35 GMT, Harshitha Onkar wrote: >I'll have to check this further It will get it via javaaccessbridge we provided(kind of native interface) and this native lib uses our a11y java code for each component. - PR Comment: https://git.openjdk.org/jdk/pull/15276

Re: RFR: JDK-8311113: Remove invalid pointer cast and clean up setLabel() in awt_MenuItem.cpp

2023-08-30 Thread Harshitha Onkar
On Wed, 30 Aug 2023 21:09:39 GMT, Alexey Ivanov wrote: > Hmm, so where does JAWS get that info if we no longer set it ? It isn't > scraping pixels and doing OCR. I'll have to check this further. - PR Comment: https://git.openjdk.org/jdk/pull/15276#issuecomment-1700104549

Re: RFR: JDK-8311113: Remove invalid pointer cast and clean up setLabel() in awt_MenuItem.cpp

2023-08-30 Thread Harshitha Onkar
On Wed, 30 Aug 2023 23:38:01 GMT, Sergey Bylokhov wrote: > > Isn't JAWS using Accessible interfaces? > > What about Narrator? I think it will use the actuall data from the windows, > same as for other "native" awt components. Unlike JAWS which know how to use > our internal a11y interface. Ch

Re: RFR: JDK-8311113: Remove invalid pointer cast and clean up setLabel() in awt_MenuItem.cpp

2023-08-30 Thread Sergey Bylokhov
On Wed, 30 Aug 2023 21:09:39 GMT, Alexey Ivanov wrote: >Isn't JAWS using Accessible interfaces? What about Narrator? I think it will use the actuall data from the windows, same as for other "native" awt components. Unlike JAWS which know how to use our internal a11y interface. -

Re: RFR: 8311585: Add JRadioButtonMenuItem to bug8031573.java [v5]

2023-08-30 Thread Rajat Mahajan
> I have made the test changes to include radio button in menu and tested the > same and it works fine. Rajat Mahajan has updated the pull request incrementally with two additional commits since the last revision: - Update test/jdk/javax/swing/JMenuItem/8031573/bug8031573.java Co-author

Re: RFR: JDK-8311113: Remove invalid pointer cast and clean up setLabel() in awt_MenuItem.cpp

2023-08-30 Thread Alexey Ivanov
On Wed, 30 Aug 2023 18:42:20 GMT, Phil Race wrote: > > > Please double-check how the external tools like jaws/narrator will work > > > after this change, will they be able to read the correct content of the > > > menu item? > > > > > > The updating of the label works correctly since the appli

Re: RFR: JDK-8311113: Remove invalid pointer cast and clean up setLabel() in awt_MenuItem.cpp [v3]

2023-08-30 Thread Alexey Ivanov
On Wed, 30 Aug 2023 18:40:57 GMT, Phil Race wrote: > > I would also add that the pointer saved to `mii.dwTypeData` becomes invalid > > as soon as `m->SetLabel(labelPtr)` returns because the code in `_SetLabel` > > releases the pointer `labelPtr`. > > Essentially, this was the code flow in `_Set

Re: RFR: 8311585: Add JRadioButtonMenuItem to bug8031573.java [v4]

2023-08-30 Thread Alexey Ivanov
On Wed, 30 Aug 2023 18:21:11 GMT, Rajat Mahajan wrote: >> I have made the test changes to include radio button in menu and tested the >> same and it works fine. > > Rajat Mahajan has updated the pull request incrementally with one additional > commit since the last revision: > > Update bug80

Re: RFR: JDK-8311113: Remove invalid pointer cast and clean up setLabel() in awt_MenuItem.cpp [v3]

2023-08-30 Thread Phil Race
On Fri, 25 Aug 2023 19:18:45 GMT, Harshitha Onkar wrote: >> In awt_MenuItem.cpp (712,22): ` mii.dwTypeData = (LPTSTR)(*sb)` produces >> invalid pointer cast warning when complied on clang and moreover this is a >> no-op. >> >> `mii.dwTypeData` is used only when **MIIM_STRING** flag is set i

Re: RFR: JDK-8311113: Remove invalid pointer cast and clean up setLabel() in awt_MenuItem.cpp

2023-08-30 Thread Phil Race
On Wed, 16 Aug 2023 03:57:29 GMT, Sergey Bylokhov wrote: >> In awt_MenuItem.cpp (712,22): ` mii.dwTypeData = (LPTSTR)(*sb)` produces >> invalid pointer cast warning when complied on clang and moreover this is a >> no-op. >> >> `mii.dwTypeData` is used only when **MIIM_STRING** flag is set i

Re: RFR: 8311922: [macOS] right-Option key fails to generate release event [v5]

2023-08-30 Thread Damon Nguyen
> Previously, a new key combination involving the option key was added to Aqua > LAF for JTextAreas. In doing so, some code was removed that created this > regression. The regression caused the right option key on Mac OS to > incorrectly show another KeyPressed event instead of a KeyReleased eve

Re: RFR: 8311585: Add JRadioButtonMenuItem to bug8031573.java [v4]

2023-08-30 Thread Rajat Mahajan
> I have made the test changes to include radio button in menu and tested the > same and it works fine. Rajat Mahajan has updated the pull request incrementally with one additional commit since the last revision: Update bug8031573.java remove macosx from summary . - Changes

Re: Notification no longer appears in the Windows 11 notification center

2023-08-30 Thread Aleksei Ivanov
Hi Davide, On 30/08/2023 15:42, Davide Perini wrote: Ok, thanks for the answer Aleksei, now it's clear to me, I would say that it is now the Microsoft desired behaviour by default. I looks like it's what Windows does. It may change in the future. Another thing I noticed is that the icon on t

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Stefan Karlsson
On Wed, 30 Aug 2023 09:23:55 GMT, Leo Korinth wrote: >> Rename createJavaProcessBuilder so that it is not used by mistake instead of >> createTestJvm. >> >> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed >> -i -e >> "s/createJavaProcessBuilder(/createJavaProcessBu

Re: RFR: 8311585: Add JRadioButtonMenuItem to bug8031573.java [v3]

2023-08-30 Thread Harshitha Onkar
On Tue, 29 Aug 2023 21:17:51 GMT, Rajat Mahajan wrote: >> I have made the test changes to include radio button in menu and tested the >> same and it works fine. > > Rajat Mahajan has updated the pull request incrementally with one additional > commit since the last revision: > > make changes

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Leo Korinth
On Wed, 30 Aug 2023 09:23:55 GMT, Leo Korinth wrote: >> Rename createJavaProcessBuilder so that it is not used by mistake instead of >> createTestJvm. >> >> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed >> -i -e >> "s/createJavaProcessBuilder(/createJavaProcessBu

Re: RFR: 8312165: Fix typos in java.desktop Swing [v3]

2023-08-30 Thread Alexey Ivanov
On Wed, 30 Aug 2023 14:09:20 GMT, Alexey Ivanov wrote: >> Andrey Turbanov has updated the pull request with a new target base due to a >> merge or a rebase. The incremental webrev excludes the unrelated changes >> brought in by the merge/rebase. The pull request contains six additional >> comm

Re: RFR: 8312165: Fix typos in java.desktop Swing [v3]

2023-08-30 Thread Alexey Ivanov
On Wed, 30 Aug 2023 08:43:40 GMT, Andrey Turbanov wrote: >> Found many typos in java.desktop by IDEA's inspection `Proofreading | Typo` > > Andrey Turbanov has updated the pull request with a new target base due to a > merge or a rebase. The incremental webrev excludes the unrelated changes > b

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Roger Riggs
On Wed, 30 Aug 2023 09:23:55 GMT, Leo Korinth wrote: >> Rename createJavaProcessBuilder so that it is not used by mistake instead of >> createTestJvm. >> >> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed >> -i -e >> "s/createJavaProcessBuilder(/createJavaProcessBu

Re: RFR: 8312075: FileChooser.win32.newFolder is not updated when changing Locale [v4]

2023-08-30 Thread Alexey Ivanov
On Thu, 10 Aug 2023 07:39:06 GMT, Tejesh R wrote: >> On `NewFolderAction`, plain String is added `Action.ACTION_COMMAND_KEY`. >> Converting the `String `to `locale` before adding as command key fix the >> issue. >> I have verified the test in all other platforms and Look and Feel which has >>

Re: Notification no longer appears in the Windows 11 notification center

2023-08-30 Thread Davide Perini
Ok, thanks for the answer Aleksei, now it's clear to me, I would say that it is now the Microsoft desired behaviour by default. Another thing I noticed is that the icon on the notitification is now "corrupted" even if the icon on the tray icon is correctly shown. ... any idea on this? Same

Re: RFR: JDK-8314731 : Add support for the alt attribute in the image type input HTML tag [v2]

2023-08-30 Thread ScientificWare
> This is referenced in Java Bug Database as > - [JDK-8314731 : Adds support for the alt attribute in the image type input > HTML tag.](https://bugs.java.com/bugdatabase/view_bug?bug_id=8314731) > > This is tracked in JBS as > - [JDK-8314731 : Add support for the alt attribute in the image type i

Re: RFR: 8312165: Fix typos in java.desktop Swing

2023-08-30 Thread Alexey Ivanov
On Wed, 30 Aug 2023 08:33:47 GMT, Andrey Turbanov wrote: > I reverted changes in non-Swing parts to reduce amount of files to review. I'm unsure it's the right decision, I reviewed them already. On the other hand, 100 files is a smaller chunk, someone could also take a look. Thanks for fixing

Re: Notification no longer appears in the Windows 11 notification center

2023-08-30 Thread Aleksei Ivanov
Hi Davide, I ran your test again on Windows 10 and 11, and the results are different. In both cases, I used a recent build of Java 22, which is the mainline. On Windows 10, the notification goes to the Action Center, it stays there until I explicitly dismiss it. On Windows 11, the notifica

Notification no longer appears in the Windows 11 notification center

2023-08-30 Thread Davide Perini
Hi all, I noticed that since the latest Windows 11 updates, AWT notifications no longer appears in the Windows notification center and automatically disappear. This means that if you are able to read the notification because you are in front of the monitor, it's ok, if you are not in front of

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Mark Sheppard
On Wed, 30 Aug 2023 09:23:55 GMT, Leo Korinth wrote: >> Rename createJavaProcessBuilder so that it is not used by mistake instead of >> createTestJvm. >> >> I have used the following sed script: `find -name "*.java" | xargs -n 1 sed >> -i -e >> "s/createJavaProcessBuilder(/createJavaProcessBu

Re: RFR: 8315097: Rename createJavaProcessBuilder [v3]

2023-08-30 Thread Leo Korinth
> Rename createJavaProcessBuilder so that it is not used by mistake instead of > createTestJvm. > > I have used the following sed script: `find -name "*.java" | xargs -n 1 sed > -i -e > "s/createJavaProcessBuilder(/createJavaProcessBuilderIgnoreTestJavaOpts(/g"` > > Then I have manually modifi

Re: RFR: JDK-8314731 : Add support for the alt attribute in the image type input HTML tag

2023-08-30 Thread Andrey Turbanov
On Thu, 17 Aug 2023 00:16:07 GMT, ScientificWare wrote: > This is referenced in Java Bug Database as > - [JDK-8314731 : Adds support for the alt attribute in the image type input > HTML tag.](https://bugs.java.com/bugdatabase/view_bug?bug_id=8314731) > > This is tracked in JBS as > - [JDK-83147

Re: RFR: 8312165: Fix typos in java.desktop Swing [v3]

2023-08-30 Thread Andrey Turbanov
> Found many typos in java.desktop by IDEA's inspection `Proofreading | Typo` Andrey Turbanov has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains six additi

Re: RFR: 8312165: Fix typos in java.desktop Swing [v2]

2023-08-30 Thread Andrey Turbanov
On Tue, 29 Aug 2023 18:41:05 GMT, Alexey Ivanov wrote: >> Andrey Turbanov has updated the pull request incrementally with two >> additional commits since the last revision: >> >> - 8312165: Fix typos in java.desktop Swing >> >>apply suggestions from review >> - 8312165: Fix typos in j

Re: RFR: 8312165: Fix typos in java.desktop Swing [v2]

2023-08-30 Thread Andrey Turbanov
> Found many typos in java.desktop by IDEA's inspection `Proofreading | Typo` Andrey Turbanov has updated the pull request incrementally with two additional commits since the last revision: - 8312165: Fix typos in java.desktop Swing apply suggestions from review - 8312165: Fix typos in

Re: RFR: 8312165: Fix typos in java.desktop Swing

2023-08-30 Thread Andrey Turbanov
On Wed, 12 Jul 2023 08:33:30 GMT, Andrey Turbanov wrote: > Found many typos in java.desktop by IDEA's inspection `Proofreading | Typo` I reverted changes in non-Swing parts to reduce amount of files to review. - PR Comment: https://git.openjdk.org/jdk/pull/14847#issuecomment-169873

Re: RFR: 8312165: Fix typos in java.desktop

2023-08-30 Thread Andrey Turbanov
On Tue, 29 Aug 2023 18:16:35 GMT, Alexey Ivanov wrote: >> Found many typos in java.desktop by IDEA's inspection `Proofreading | Typo` > > src/java.desktop/share/classes/javax/swing/plaf/nimbus/InnerShadowEffect.java > line 48: > >> 46: * painted. OVER means the result of apply effect shoul

Re: RFR: 8312165: Fix typos in java.desktop

2023-08-30 Thread Andrey Turbanov
On Tue, 29 Aug 2023 18:06:44 GMT, Alexey Ivanov wrote: >> Found many typos in java.desktop by IDEA's inspection `Proofreading | Typo` > > src/java.desktop/share/classes/javax/swing/plaf/nimbus/DropShadowEffect.java > line 45: > >> 43: /** >> 44: * Get the type of this effect, one of UN

Re: RFR: 8315097: Rename createJavaProcessBuilder [v2]

2023-08-30 Thread David Holmes
On Tue, 29 Aug 2023 16:45:12 GMT, Roger Riggs wrote: >> I don't think this is the best change across so many files. >> It gives a very ugly name to a common test function and affects a very large >> number of tests. > >> @RogerRiggs If it is only the name you want changed, maybe you can offer a