Re: [PATCH 24/39] docs: driver-model: move it to the driver-api book

2019-06-28 Thread Jeff Kirsher
On Fri, 2019-06-28 at 09:30 -0300, Mauro Carvalho Chehab wrote: > The audience for the Kernel driver-model is clearly Kernel hackers. > > Signed-off-by: Mauro Carvalho Chehab Acked-by: Jeff Kirsher For the 'ice' driver changes. > --- > Documentation/{ => driver-api}/driver-model/binding.rst

Re: [v2] coccinelle: semantic code search for missing of_node_put

2019-06-28 Thread Markus Elfring
>> +x = >> +(of_… >> +|of_… >> +)@p1(...); > > Did you actually test this? I doubt that a position metavariable can be > put on a ) of a disjunction. Would you ever like to support this possibility? >> +|return >> +(x >> +|of_fwnode_handle(x) >> +); > > The original code is much more readable.

Re: [v2] coccinelle: semantic code search for missing of_node_put

2019-06-28 Thread Markus Elfring
>> +x = >> +(of_… >> +|of_… >> +)@p1(...); > > Did you actually test this? I doubt that a position metavariable can be > put on a ) of a disjunction. Would you ever like to support this possibility? >> +|return >> +(x >> +|of_fwnode_handle(x) >> +); > > The original code is much more readable.

[PATCH 24/39] docs: driver-model: move it to the driver-api book

2019-06-28 Thread Mauro Carvalho Chehab
The audience for the Kernel driver-model is clearly Kernel hackers. Signed-off-by: Mauro Carvalho Chehab --- Documentation/{ => driver-api}/driver-model/binding.rst | 0 Documentation/{ => driver-api}/driver-model/bus.rst | 0 Documentation/{ => driver-api}/driver-model/class.rst

Re: [Cocci] [PATCH v2] coccinelle: semantic code search for missing of_node_put

2019-06-28 Thread Julia Lawall
> > +x = @p1\(of_find_all_nodes\| > > I would find this SmPL disjunction easier to read without the usage > of extra backslashes. > > +x = > +(of_… > +|of_… > +)@p1(...); Did you actually test this? I doubt that a position metavariable can be put on a ) of a disjunction. > > +| > > +return x; >

Re: [PATCH v2] coccinelle: semantic code search for missing of_node_put

2019-06-28 Thread Markus Elfring
> The counter must be decremented after the last usage of a device node. Thanks for your next try to improve the software situation also in this area. > We find these functions by using the following SmPL: Would it be nicer to use the word “script” also here? > > @initialize:ocaml@ > @@ How