Ling Mao created CASSANDRA-17986:
------------------------------------

             Summary: improve StartupException related codes
                 Key: CASSANDRA-17986
                 URL: https://issues.apache.org/jira/browse/CASSANDRA-17986
             Project: Cassandra
          Issue Type: Improvement
          Components: Local/Other
            Reporter: Ling Mao


1. We should use the enum: _*ERR_WRONG_MACHINE_STATE*_ and 
*_ERR_WRONG_DISK_STATE_* to replace the magic number: 1 and 3
{code:java}
exitOrFail(1, e.getMessage(), e.getCause());
exitOrFail(3, "Exception encountered during startup", e);{code}
 

2. Delete the useless field: *_ERR_OUTDATED_SCHEMA_*



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org
For additional commands, e-mail: commits-h...@cassandra.apache.org

Reply via email to