git: dsynth - If WITH_DEBUG used, increase tmpfs size for BASE/construction

2021-06-24 Thread Matthew Dillon
commit aeecca076c312a89d24df27280c29f7088aec640 Author: Matthew Dillon Date: Thu Jun 24 21:11:18 2021 -0700 dsynth - If WITH_DEBUG used, increase tmpfs size for BASE/construction * When WITH_DEBUG is specified in dsynth's -make.conf, increase the tmpfs size for /constructio

git: kernel - change vfs.timestamp_precision default when hz < 100

2021-06-24 Thread Matthew Dillon
commit fba6eb5366bd0860ab6efea3a5c026867679e6b8 Author: Matthew Dillon Date: Thu Jun 24 14:48:55 2021 -0700 kernel - change vfs.timestamp_precision default when hz < 100 * Change the default for vfs.timestamp_precision to a more precise time calculation when hz is less than

git: nullfs - Improve NFS export FSID

2021-06-24 Thread Matthew Dillon
commit 1bb7a917f5b8b86fa1f5dbfdfd16dd09f4054233 Author: Matthew Dillon Date: Thu Jun 24 10:45:18 2021 -0700 nullfs - Improve NFS export FSID * Reduce the chance of collision and improve repeatability by integrating a CRC of the mntfromname string with the FSID of the root f

git: kernel - Add sequential TSC test, refactor concurrency test

2021-06-24 Thread Matthew Dillon
commit cac128231c7864434c0360660adced89b17a34d3 Author: Matthew Dillon Date: Thu Jun 24 10:36:30 2021 -0700 kernel - Add sequential TSC test, refactor concurrency test * Add a test that test the TSC, checking whether rdtsc() returns monotonically increasing values when hopp

git: sbin/hammer2: Introduce HAMMER2_SHOW_MIN_XXX_TID to limit blockrefs

2021-06-24 Thread Tomohiro Kusumi
commit 71782ce36f3953b7ba35612c81b8c60a4fe10fa1 Author: Tomohiro Kusumi Date: Wed Jun 23 01:24:07 2021 +0900 sbin/hammer2: Introduce HAMMER2_SHOW_MIN_XXX_TID to limit blockrefs Blockrefs with smaller tid are ignored as if HAMMER2_BREF_TYPE_EMPTY. The default is 0 which means

git: pc64/vmm: Update EPT code against EPT_* define changes

2021-06-24 Thread Aaron LI
commit fd6712ad6523732b2a53082d8e7b5ad9da32e51a Author: Aaron LI Date: Sat Jun 5 12:04:25 2021 +0800 pc64/vmm: Update EPT code against EPT_* define changes * Update 'EPT_IGNORE_PAT' to 'EPT_PG_IGNORE_PAT'. * Improve the definitions of 'pmap_bits_ept[]' and 'pmap_cache_bits_ep

git: pc64/vmm: Disable stuffs to avoid overload symbols confusing debuger

2021-06-24 Thread Aaron LI
commit c65f9d97d66fae84df02f2625465e97e637cce95 Author: Aaron LI Date: Sun Jun 13 21:30:36 2021 +0800 pc64/vmm: Disable stuffs to avoid overload symbols confusing debuger There are some static symbols in pc64/vmm have the same names as in nvmm, which can confuse ddb/kgdb. Di

git: x86_64/pmap.h: Move Intel EPT defines from

2021-06-24 Thread Aaron LI
commit a69b35e0ffe43d82670aff5b2f11b21dadfe5bae Author: Aaron LI Date: Fri Jun 4 06:35:25 2021 +0800 x86_64/pmap.h: Move Intel EPT defines from Renamed 'EPT_IGNORE_PAT' to 'EPT_PG_IGNORE_PAT' for better naming consistency. Fixes to the vmm/ept code will follow. Whi

git: pmap: Refactor PG_*_IDX and pmap_bits_default definitions

2021-06-24 Thread Aaron LI
commit 24aa2e44a85bc12e46a45c21451732106bb8f88a Author: Aaron LI Date: Sat Jun 5 11:57:23 2021 +0800 pmap: Refactor PG_*_IDX and pmap_bits_default definitions Refactor PG_*_IDX definitions by using an enumeration, and define the pmap_bits_default[] array with named indices, m

git: npx: Export fpusave()/fpurstor() functions for NVMM

2021-06-24 Thread Aaron LI
commit 5315046422ef311bc4a3c12eb96739ee9d97768d Author: Aaron LI Date: Sun May 16 09:38:13 2021 +0800 npx: Export fpusave()/fpurstor() functions for NVMM Summary of changes: sys/cpu/x86_64/include/npx.h | 2 ++ sys/platform/pc64/x86_64/npx.c | 7 ++- 2 files changed, 4 insertions(

git: Makefile: Install 'master.passwd' and 'group' if not exist

2021-06-24 Thread Aaron LI
commit 169805dbaab55a640955a7d94cd0cc7d15160523 Author: Aaron LI Date: Thu Jun 24 22:27:59 2021 +0800 Makefile: Install 'master.passwd' and 'group' if not exist For a new installation specified with DESTDIR, 'master.passwd' and 'group' just don't exist. Install them in such

git: Makefile: Rename 'preupgrade' to 'preinstall'

2021-06-24 Thread Aaron LI
commit 89e9c22c5a630254bf49e3b50153e7f88dc7d4f2 Author: Aaron LI Date: Thu Jun 24 22:11:38 2021 +0800 Makefile: Rename 'preupgrade' to 'preinstall' The 'preupgrade' target performs certain pre-installworld operations, and is executed before 'installworld' automatically. So r

git: Makefile: Make 'installworld' depend on 'preupgrade'

2021-06-24 Thread Aaron LI
commit 6d657f85300bddf82b40bc566b6cabb2f74e105e Author: Aaron LI Date: Fri May 28 07:17:12 2021 +0800 Makefile: Make 'installworld' depend on 'preupgrade' The 'preupgrade' target will creates new users/groups, which may be required by the 'installworld' target, so make 'insta

git: x86_64/cpufunc.h: Add load_cr2() function

2021-06-24 Thread Aaron LI
commit 251f5dcbc0ccead3e2afdc84452ed0a4efbf7d4e Author: Aaron LI Date: Mon May 10 07:33:54 2021 +0800 x86_64/cpufunc.h: Add load_cr2() function This function is a companion of rcr2() and would be used in NVMM. Summary of changes: sys/cpu/x86_64/include/cpufunc.h | 9 +++--

git: x86_64/cpufunc.h: Add rxcr() and rename xsetbv() to load_xcr()

2021-06-24 Thread Aaron LI
commit 23bf518b8690750023fb9f37577469601a98fa50 Author: Aaron LI Date: Mon May 10 07:27:17 2021 +0800 x86_64/cpufunc.h: Add rxcr() and rename xsetbv() to load_xcr() * rxcr() is taken from FreeBSD with minor changes. * Rename xsetbv() to load_xcr(), being consistent with rxcr(