Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-25 Thread Henri Yandell
On Fri, 25 Jul 2003 [EMAIL PROTECTED] wrote: from:Phil Steitz [EMAIL PROTECTED] I agree as well that the subtring names are much better, but what is the policy on changing the names of methods that have been introduced between releases? I would hate to see chomp, slice and

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-25 Thread Stephen Colebourne
Change made. Anything else in StringUtils todo? Stephen - Original Message - From: Henri Yandell [EMAIL PROTECTED] To: Jakarta Commons Developers List [EMAIL PROTECTED] Sent: Friday, July 25, 2003 6:39 PM Subject: Re: [lang] StringUtils.sliceFirstRemainder behavior On Fri, 25 Jul

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-24 Thread Stephen Colebourne
Message - From: Phil Steitz [EMAIL PROTECTED] To: Jakarta Commons Developers List [EMAIL PROTECTED] Sent: Thursday, July 24, 2003 4:39 AM Subject: Re: [lang] StringUtils.sliceFirstRemainder behavior Phil Steitz wrote: [EMAIL PROTECTED] wrote: from:Phil Steitz [EMAIL PROTECTED] I assume

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-23 Thread Henri Yandell
On Tue, 22 Jul 2003, Phil Steitz wrote: sliceFirst(s^x^t, x) + sliceFirstRemainder(s^x^t, x) = s^t The question is, is this symmetry worth the strange definition (at least strange to me) of sliceFirstRemainder which returns the full string when it does not include the delimiter. Nope. I'm

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-23 Thread scolebourne
] Sent: Tuesday, July 22, 2003 5:50 AM Subject: [lang] StringUtils.sliceFirstRemainder behavior Currently, StringUtils.sliceRemainder(foo, b) = = StringUtils.sliceFirst(foo, b), but StringUtils.sliceRemainder(foo, b) = foo. Is this the intended behavior? Phil

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-23 Thread Phil Steitz
[EMAIL PROTECTED] wrote: from:Phil Steitz [EMAIL PROTECTED] I assume you also agree that all slice functions should fix , null, i.e., slice[Xxx](null, *) = null, slice[Xxx](, *) = Yes, these seem like the simple cases. Stephen OK. Unless there are objections or someone else commits the

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-22 Thread Stephen Colebourne
] To: Jakarta Commons Developers List [EMAIL PROTECTED] Sent: Tuesday, July 22, 2003 5:50 AM Subject: [lang] StringUtils.sliceFirstRemainder behavior Currently, StringUtils.sliceRemainder(foo, b) = = StringUtils.sliceFirst(foo, b), but StringUtils.sliceRemainder(foo, b) = foo

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-22 Thread Phil Steitz
] StringUtils.sliceFirstRemainder behavior Currently, StringUtils.sliceRemainder(foo, b) = = StringUtils.sliceFirst(foo, b), but StringUtils.sliceRemainder(foo, b) = foo. Is this the intended behavior? Phil - To unsubscribe, e-mail

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-22 Thread Stephen Colebourne
[EMAIL PROTECTED] Sent: Tuesday, July 22, 2003 5:50 AM Subject: [lang] StringUtils.sliceFirstRemainder behavior Currently, StringUtils.sliceRemainder(foo, b) = = StringUtils.sliceFirst(foo, b), but StringUtils.sliceRemainder(foo, b) = foo. Is this the intended behavior? Phil

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-22 Thread Henri Yandell
like to change this, but why is it as it is??? Stephen - Original Message - From: Phil Steitz [EMAIL PROTECTED] To: Jakarta Commons Developers List [EMAIL PROTECTED] Sent: Tuesday, July 22, 2003 3:30 PM Subject: Re: [lang] StringUtils.sliceFirstRemainder behavior Stephen

Re: [lang] StringUtils.sliceFirstRemainder behavior

2003-07-22 Thread Phil Steitz
- Original Message - From: Phil Steitz [EMAIL PROTECTED] To: Jakarta Commons Developers List [EMAIL PROTECTED] Sent: Tuesday, July 22, 2003 3:30 PM Subject: Re: [lang] StringUtils.sliceFirstRemainder behavior Stephen Colebourne wrote: I think I would expect: StringUtils.slice(foo, b) = foo

[lang] StringUtils.sliceFirstRemainder behavior

2003-07-21 Thread Phil Steitz
Currently, StringUtils.sliceRemainder(foo, b) = = StringUtils.sliceFirst(foo, b), but StringUtils.sliceRemainder(foo, b) = foo. Is this the intended behavior? Phil - To unsubscribe, e-mail: [EMAIL PROTECTED] For additional