Re: [lang] Proposal (2): isEmpty

2003-07-19 Thread Henri Yandell
t; > isAlpha() - alpha or "" > etc. > > Thus, using isBlank avoids changing the functionality of the 1.0 > isWhitespace. > > Stephen > > - Original Message - > From: "Henri Yandell" <[EMAIL PROTECTED]> > To: "Jakarta Commons Dev

RE: [lang] Proposal (2): isEmpty

2003-07-19 Thread Jitterpig Default
> Any views on NN for 'not null' ? What's the problem with spelling this stuff out? -1 on using NN instead of NotNull. Are we really concerned with saving space (a whole 4 characters) or reducing typing over making code more readable? Keep in mind that more and more people are using IDEs that

Re: [lang] Proposal (2): isEmpty

2003-07-19 Thread Stephen Colebourne
; isAlpha() - alpha or "" etc. Thus, using isBlank avoids changing the functionality of the 1.0 isWhitespace. Stephen - Original Message - From: "Henri Yandell" <[EMAIL PROTECTED]> To: "Jakarta Commons Developers List" <[EMAIL PROTECTED]> Sent:

RE: [lang] Proposal (2): isEmpty

2003-07-19 Thread Henri Yandell
al Message- > From: Stephen Colebourne [mailto:[EMAIL PROTECTED] > Sent: Saturday, July 19, 2003 13:13 > To: Jakarta Commons Developers List > Subject: Re: [lang] Proposal (2): isEmpty > > From: "Henri Yandell" <[EMAIL PROTECTED]> > > > It isn't. My prefer

RE: [lang] Proposal (2): isEmpty

2003-07-19 Thread Gary Gregory
I like the blank version as it is more expressive. Does this version isBlank trim? Gary -Original Message- From: Stephen Colebourne [mailto:[EMAIL PROTECTED] Sent: Saturday, July 19, 2003 13:13 To: Jakarta Commons Developers List Subject: Re: [lang] Proposal (2): isEmpty From

RE: [lang] Proposal (2): isEmpty - commits

2003-07-19 Thread Gary Gregory
So, there are no isWhitespace methods, right? Gray -Original Message- From: Stephen Colebourne [mailto:[EMAIL PROTECTED] Sent: Saturday, July 19, 2003 14:58 To: Jakarta Commons Developers List Subject: Re: [lang] Proposal (2): isEmpty - commits I have updated CVS HEAD as follows

Re: [lang] Proposal (2): isEmpty - commits

2003-07-19 Thread Stephen Colebourne
"" or null isNotBlank - opposite I suggest that committers think if they want to -1 veto this change. Stephen - Original Message - From: "Henri Yandell" <[EMAIL PROTECTED]> To: "Jakarta Commons Developers List" <[EMAIL PROTECTED]> Sent: Saturday, J

Re: [lang] Proposal (2): isEmpty

2003-07-19 Thread Henri Yandell
So what's our 2.0 state with regard to this? What needs to be changed? Do we want to release tight with the following removed from current HEAD: isEmptyOrNull isNotEmptyOrNull isEmptyTrimmed isNotEmptyTrimmed isEmptyTrimmedOrNull isNotEmptyTrimmedOrNull Hen On Sat, 19 Jul 2003, Stephen Colebou

Re: [lang] Proposal (2): isEmpty

2003-07-19 Thread Stephen Colebourne
From: "Henri Yandell" <[EMAIL PROTECTED]> > > It isn't. My preference is now for > > > > isEmpty() - "" or null > > isBlank() - whitespace only, "" or null > > Could just tell people to do isWhitespace && isEmpty ? :) I feel isBlank() is more expressive than isWhitespace(). It just feels more i

Re: [lang] Proposal (2): isEmpty

2003-07-19 Thread Henri Yandell
On Sat, 19 Jul 2003, Stephen Colebourne wrote: > From: "Henri Yandell" <[EMAIL PROTECTED]> > > > Having just updated the whitespace processing, I now think that > isBlank() > > > should be fully Unicode compliant and trim using > Character.isWhitespace() > > > not String.trim(). > > > > So how i

RE: [lang] Proposal (2): isEmpty

2003-07-19 Thread Henri Yandell
I think I prefer [was it Gary's?] the idea of having StringUtils being usable as an instance in which you setup general strategies to overloading with a boolean variable. No insult intended, but that always seems like a confusing hack to me. Hen On Sat, 19 Jul 2003, Laird J. Nelson wrote: > > -

RE: [lang] Proposal (2): isEmpty

2003-07-19 Thread Laird J. Nelson
> -Original Message- > From: Stephen Colebourne [mailto:[EMAIL PROTECTED] > It isn't. My preference is now for > > isEmpty() - "" or null > isBlank() - whitespace only, "" or null > and maybe: > isEmptyTrimmed() - trim() then "" or null > > (plus isNotEmpty, isNotBlank, isEmptyNN, isBlankNN

RE: [lang] Proposal (2): isEmpty

2003-07-19 Thread Howard M. Lewis Ship
(I've switched my subscription over from digest back to full so I don't miss these). Thanks for re-posting this. I can see that this change will not affect me; if there are any places where the difference between isEmpty() and isBlank() will affect me, my test suite should find them. -- Howard

RE: [lang] Proposal (2): isEmpty

2003-07-18 Thread Henri Yandell
On Fri, 18 Jul 2003, Gary Gregory wrote: > I like #2. Boo! ;) Seriously for a moment. I think the usage of commons-lang is beginning to hit the up-curve. It's creeping into projects and people are starting to talk about it [along with other Commons things] outside of the usual circles. A 2.0 s

Re: [lang] Proposal (2): isEmpty

2003-07-18 Thread Henri Yandell
On Fri, 18 Jul 2003, Lavandowska wrote: > I could live with #1, though I'd rather the current contract (the > trim() functionality) didn't change (whine whine whine). isBlank! Just think of the joy you'll have as you switch to it. It's such a sexier name. > Or #2 is fine also, but I'd suggest

Re: [lang] Proposal (2): isEmpty

2003-07-18 Thread Henri Yandell
The comments at http://raibledesigns.com/comments/rd/minimal/commons_lang_stringutils are a good reason for how surprisingly nice people find isEmpty. On Fri, 18 Jul 2003, Stephen Colebourne wrote: > Proposal for methods: > > - isEmpty() - true for "" or null > - isNotEmpty() - opposite > - is

RE: [lang] Proposal (2): isEmpty

2003-07-18 Thread Gary Gregory
I like #2. A clarification please: I do not see why any isWhitespace methods are needed since the isBlank methods trim()'s their arguments. isBlank(null) returns true isWS(null) returns true isBlank("") returns true isWS("") returns true isBlank(" ") returns true isWS(" ") returns true isBlank

Re: [lang] Proposal (2): isEmpty

2003-07-18 Thread Lavandowska
I could live with #1, though I'd rather the current contract (the trim() functionality) didn't change (whine whine whine). Or #2 is fine also, but I'd suggest another name (StringTests connotes Unit tests to me), maybe StringChecks or CheckString? Lance --- Stephen Colebourne <[EMAIL PROTECTED]>