> In your subsequent email, I found that the asXXX and toXXX variants to be too
> similar to
> make it clear which throws and which does not or other differences unless it
> were a pervasive
> pattern that all developers would know and use.
We encourage this convention:
- Use "asXxx" to describ
Changeset: 84b61130cbed
Author:mcimadamore
Date: 2012-02-14 15:43 -0800
URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/84b61130cbed
7142086: performance problem in Check.checkOverrideClashes(...)
Summary: Code in Check.checkOverrideClashes() causes too many calls to
MethodSy
>Saturating arithmetic can be useful but there have been few requests.
Some needs can be unformulated until someone fulfils them :)
But indeed not being hit by integer/modulo arithmetic while still being exact
is surely a more common need than "jumping" to the closest value.
I must be biased due
On 02/13/2012 06:41 PM, Jeff Hain wrote:
Hello.
- It could be great to have versions of these methods that don't throw an
ArithmeticException in case of overflow, but would return the closest value
(XXX.MAX_VALUE or XXX.MIN_VALUE).
A common use-case I see (and have) for this is when dealing
For "toInt" method(s), and other methods that don't involve mathematical
operations but just transtyping, I think the naming conventions I was talking
about
(xxxInRange/xxxToRange for add/substract/multiply/negate/increment/etc.)
don't need to apply.
One could just use "asInt" for the throwing
Changeset: f62077973f9b
Author:vinnie
Date: 2012-02-14 11:47 +
URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/f62077973f9b
7142888: sun/security/tools/jarsigner/ec.sh fail on sparc
Reviewed-by: xuelei
! test/sun/security/tools/jarsigner/ec.sh
This is a request for review for 7144833:
sun/tools/jcmd/jcmd-Defaults.sh failing intermittently
Bug:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7144833
The problem occurs when one or several lines printed by the jcmd tool
match several rules in the awk script checking the output. The