Re: ReflectionData space optimization in java.lang.Class (JEP-149)

2012-12-17 Thread Peter Levart
Hi David, Fair enough. So only the basic ReflectionData patch for now. Here I prepared yet another revision that only contains the basic stuff from 1st revision of the patch but fixes long lines, splits the reflectionData method in two and also fixes an inconsistency - in one method there

hg: jdk8/tl/jdk: 8004928: TEST_BUG: Reduce dependence of CoreLib tests from the AWT subsystem

2012-12-17 Thread alexey . utkin
Changeset: a02212de8db6 Author:uta Date: 2012-12-17 14:34 +0400 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/a02212de8db6 8004928: TEST_BUG: Reduce dependence of CoreLib tests from the AWT subsystem Summary: the tests were refactored to drop AWT dependence where it was possible.

RFR: 7150256: Add back Diagnostic Command JMX API

2012-12-17 Thread Frederic Parain
Hi, Please review the following change for CR 7150256. This changeset is the JDK side of two parts project. The goal of this feature is to allow remote invocations of Diagnostic Commands via JMX. Diagnostic Commands are actually invoked from the jcmd tool, which is a local tool using the

Re: RFR 8005081: java/util/prefs/PrefsSpi.sh fails on macos-x

2012-12-17 Thread Alan Bateman
On 14/12/2012 17:36, Chris Hegarty wrote: Strangely, this test passed in my test runs, on all platforms, before the push with the changes that pass the TESTVMOPTS, 8003890. It has now been seen to fail on some mac machines. There appears to be an issue with the use of quotes around TESTVMOPTS.

Re: Review request: 8003562: Provide a command-line tool to find static dependencies

2012-12-17 Thread Alan Bateman
On 15/12/2012 01:30, Mandy Chung wrote: Having a second thought, it's a new tool and we need to learn its options anyway. I'd opt for consistency than familiarity and not to have mixture of Unix-style and GNU-style options. If no objection, I will change it to --classpath for the initial

EnumData space optimization in j.l.Class (JEP-146)

2012-12-17 Thread Peter Levart
Hi David and others, Here's a patch that eliminates one of two fields in java.lang.Class, related to caching enum constants: http://dl.dropbox.com/u/101777488/jdk8-tl/JEP-149.enum/webrev.01/index.html It does it by moving one field to a subclass of HashMap, which is referenced by a

Re: RFR: javax.xml.datatype: Using ServiceLoader to load JAXP datatype factories (7169894: JAXP Plugability Layer: using service loader)

2012-12-17 Thread Daniel Fuchs
Hi, As pointed out by Paul Alan, there's no reason to force Class.forName to initialize the class when attempting to load it in FactoryFinder. FactoryFinder should behave like ServiceLoader in this respect. So here is an updated webrev for javax.xml.datatype.

RFR: 8004699 : Add type annotation storage to Constructor, Field and Method

2012-12-17 Thread Joel Borggrén-Franck
Here is the first in a series of changes to add type annotation support to reflection. http://cr.openjdk.java.net/~jfranck/8004699/webrev.00/ While this adds overhead all instances of Field, Constructor, and Method we need this change in order to coordinate with the changes going in to HotSpot

hg: jdk8/tl/langtools: 8004832: Add new doclint package

2012-12-17 Thread jonathan . gibbons
Changeset: 75ab654b5cd5 Author:jjg Date: 2012-12-17 07:47 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/75ab654b5cd5 8004832: Add new doclint package Reviewed-by: mcimadamore ! make/build.properties ! src/share/classes/com/sun/source/util/DocTrees.java !

Re: RFR: 8004699 : Add type annotation storage to Constructor, Field and Method

2012-12-17 Thread Peter Levart
Hi Joel, 82 // This is set by the vm at Method creation 83 private byte[] type_annotations; Wouldn't it be better to initialize this field in the constructor? You could create an overloaded constructor if you wanted to be compatible with previous versions of the VM.

Re: RRFR 8002356: Add ForkJoin common pool and CountedCompleted

2012-12-17 Thread Doug Lea
On 12/13/12 15:16, Mike Duigou wrote: Some notes: Thanks! - The Object padding (pad10 - pad1d) in WorkQueue and ForkJoinPool is sensitive to reference size and compressed OOPS. I was surprised to see Object used rather than long or int. Until we get @Contended, this is black art. Because

Re: RFR: javax.xml.datatype: Using ServiceLoader to load JAXP datatype factories (7169894: JAXP Plugability Layer: using service loader)

2012-12-17 Thread Alan Bateman
On 17/12/2012 15:39, Daniel Fuchs wrote: Hi, As pointed out by Paul Alan, there's no reason to force Class.forName to initialize the class when attempting to load it in FactoryFinder. FactoryFinder should behave like ServiceLoader in this respect. So here is an updated webrev for

Re: Review request: 8003562: Provide a command-line tool to find static dependencies

2012-12-17 Thread Ulf Zibis
Am 17.12.2012 16:23, schrieb Alan Bateman: I mostly agree with your argument that this is a new tool and that we should be consistent with GNU-style options. So what was the final bid is, is it --classpath or --class-path? I guess it wouldn't do any harm to silently supporting -cp and

hg: jdk8/tl/langtools: 8004099: Bad compiler diagnostic generated when poly expression is passed to non-existent method

2012-12-17 Thread maurizio . cimadamore
Changeset: f20568328a57 Author:mcimadamore Date: 2012-12-17 16:13 + URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/f20568328a57 8004099: Bad compiler diagnostic generated when poly expression is passed to non-existent method Summary: Some code paths in resolve do not

Re: RFR: 4247235: (spec str) StringBuffer.insert(int, char[]) specification is inconsistent

2012-12-17 Thread Jim Gish
On 12/15/2012 08:58 AM, Alan Bateman wrote: On 14/12/2012 22:49, Jim Gish wrote: Please review http://cr.openjdk.java.net/~jgish/Bug4247235-Add-Blanket-Null-Stmt/ http://cr.openjdk.java.net/%7Ejgish/Bug4247235-Add-Blanket-Null-Stmt/ This minor spec change (which will require CCC approval),

hg: jdk8/tl/jdk: 8005081: java/util/prefs/PrefsSpi.sh fails on macos-x

2012-12-17 Thread chris . hegarty
Changeset: bcf79e6f52a0 Author:chegar Date: 2012-12-17 16:27 + URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/bcf79e6f52a0 8005081: java/util/prefs/PrefsSpi.sh fails on macos-x Reviewed-by: alanb ! test/java/util/prefs/PrefsSpi.sh

hg: jdk8/tl: 8005090: Include com.sun.source.doctree in Tree API docs

2012-12-17 Thread jonathan . gibbons
Changeset: a0779b1e9a4d Author:jjg Date: 2012-12-17 08:34 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/rev/a0779b1e9a4d 8005090: Include com.sun.source.doctree in Tree API docs Reviewed-by: erikj ! common/makefiles/javadoc/NON_CORE_PKGS.gmk

hg: jdk8/tl/jdk: 8005090: Include com.sun.source.doctree in Tree API docs

2012-12-17 Thread jonathan . gibbons
Changeset: 9f1b516cd9cb Author:jjg Date: 2012-12-17 08:34 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/9f1b516cd9cb 8005090: Include com.sun.source.doctree in Tree API docs Reviewed-by: erikj ! make/docs/NON_CORE_PKGS.gmk

Re: RFR: 8004699 : Add type annotation storage to Constructor, Field and Method

2012-12-17 Thread Joel Borggrén-Franck
On Dec 17, 2012, at 4:47 PM, Alan Bateman alan.bate...@oracle.com wrote: On 17/12/2012 15:41, Joel Borggrén-Franck wrote: Here is the first in a series of changes to add type annotation support to reflection. http://cr.openjdk.java.net/~jfranck/8004699/webrev.00/ I assume this should

Re: RFR: 4247235: (spec str) StringBuffer.insert(int, char[]) specification is inconsistent

2012-12-17 Thread Jim Gish
I've created a new bug: https://jbs.oracle.com/bugs/browse/JDK-8005118 - I'll address the consistency issues there, and treat the NPE specs separately. Jim On 12/17/2012 11:29 AM, Jim Gish wrote: On 12/15/2012 08:58 AM, Alan Bateman wrote: On 14/12/2012 22:49, Jim Gish wrote: Please review

Re: RFR: 8004699 : Add type annotation storage to Constructor, Field and Method

2012-12-17 Thread Joel Borggrén-Franck
On Dec 17, 2012, at 5:00 PM, Peter Levart peter.lev...@gmail.com wrote: Hi Joel, 82 // This is set by the vm at Method creation 83 private byte[] type_annotations; Wouldn't it be better to initialize this field in the constructor? You could create an overloaded

RFR: javax.xml.stream: Using ServiceLoader to load JAXP stream factories (7169894: JAXP Plugability Layer: using service loader)

2012-12-17 Thread Daniel Fuchs
Hi, Here is a new webrev in the series that addresses using ServiceLoader in JAXP for JDK 8. 7169894: JAXP Plugability Layer: using service loader This changeset addresses modification in the javax.xml.stream package. It is similar to changes proposed for the javax.xml.parsers package [1],

hg: jdk8/tl/jdk: 8004832: Add new doclint package

2012-12-17 Thread jonathan . gibbons
Changeset: bac477d67867 Author:jjg Date: 2012-12-17 10:31 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/bac477d67867 8004832: Add new doclint package Reviewed-by: erikj, ohair ! make/common/Release.gmk ! make/common/internal/Defs-langtools.gmk ! makefiles/CreateJars.gmk

RFR: [jdk7u-dev] - 8003898: X11 toolkit can be chosen as the default toolkit

2012-12-17 Thread Rob McKenna
Hi folks, This review contains: 8003898: X11 toolkit can be chosen as the default toolkit 7162111: TEST_BUG: change tests run in headless mode [macosx] (open) 8004928: TEST_BUG: Reduce dependence of CoreLib tests from the AWT subsystem Unfortunately the last two patches didn't apply cleanly,

hg: jdk8/tl/langtools: 8004961: rename Plugin.call to Plugin.init

2012-12-17 Thread jonathan . gibbons
Changeset: 064e372f273d Author:jjg Date: 2012-12-17 10:55 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/064e372f273d 8004961: rename Plugin.call to Plugin.init Reviewed-by: mcimadamore ! src/share/classes/com/sun/source/util/Plugin.java !

RFR:8005118 Javadoc styles are inconsistent

2012-12-17 Thread Jim Gish
Please review the simple fix that makes the String classes more consistent w.r.t. javadoc (specifically usages of tt, code, {@code}, etc.). http://cr.openjdk.java.net/~jgish/Bug8005118-String-spec-consistency/ http://cr.openjdk.java.net/%7Ejgish/Bug8005118-String-spec-consistency/ Thanks,

Re: EnumData space optimization in j.l.Class (JEP-146)

2012-12-17 Thread Mandy Chung
On 12/17/12 7:36 AM, Peter Levart wrote: Hi David and others, Here's a patch that eliminates one of two fields in java.lang.Class, related to caching enum constants: http://dl.dropbox.com/u/101777488/jdk8-tl/JEP-149.enum/webrev.01/index.html It does it by moving one field to a subclass

Re: EnumData space optimization in j.l.Class (JEP-146)

2012-12-17 Thread Peter Levart
On 12/17/2012 10:26 PM, Mandy Chung wrote: On 12/17/12 7:36 AM, Peter Levart wrote: Hi David and others, Here's a patch that eliminates one of two fields in java.lang.Class, related to caching enum constants: http://dl.dropbox.com/u/101777488/jdk8-tl/JEP-149.enum/webrev.01/index.html It

Re: EnumData space optimization in j.l.Class (JEP-146)

2012-12-17 Thread Peter Levart
On 12/17/2012 10:26 PM, Mandy Chung wrote: On 12/17/12 7:36 AM, Peter Levart wrote: Hi David and others, Here's a patch that eliminates one of two fields in java.lang.Class, related to caching enum constants: http://dl.dropbox.com/u/101777488/jdk8-tl/JEP-149.enum/webrev.01/index.html It

Re: EnumData space optimization in j.l.Class (JEP-146)

2012-12-17 Thread Remi Forax
On 12/17/2012 11:14 PM, Peter Levart wrote: On 12/17/2012 10:26 PM, Mandy Chung wrote: On 12/17/12 7:36 AM, Peter Levart wrote: Hi David and others, Here's a patch that eliminates one of two fields in java.lang.Class, related to caching enum constants:

hg: jdk8/tl/langtools: 8005137: Rename DocLint.call to DocLint.init which overrides Plugin.init

2012-12-17 Thread mandy . chung
Changeset: ef537bcc825a Author:mchung Date: 2012-12-17 15:19 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/ef537bcc825a 8005137: Rename DocLint.call to DocLint.init which overrides Plugin.init Reviewed-by: darcy, jjh !

Re: EnumData space optimization in j.l.Class (JEP-146)

2012-12-17 Thread David Holmes
Hi Peter, BTW JEP-149 not 146! Sorry I didn't get a chance to respond last night before you continued on this path. I have to say no to this too. First I am just running out of time to get this finalized by M6 - particularly with the Xmas break looming. Second the trade-off here is far

Re: RFR: 8004699 : Add type annotation storage to Constructor, Field and Method

2012-12-17 Thread David Holmes
On 18/12/2012 3:06 AM, Joel Borggrén-Franck wrote: On Dec 17, 2012, at 5:00 PM, Peter Levartpeter.lev...@gmail.com wrote: Hi Joel, 82 // This is set by the vm at Method creation 83 private byte[] type_annotations; Wouldn't it be better to initialize this field in

Re: Review request: 8003562: Provide a command-line tool to find static dependencies

2012-12-17 Thread Mandy Chung
On 12/17/12 8:13 AM, Ulf Zibis wrote: Am 17.12.2012 16:23, schrieb Alan Bateman: I mostly agree with your argument that this is a new tool and that we should be consistent with GNU-style options. So what was the final bid is, is it --classpath or --class-path? I propose --class-path so that