RFR(m): 8139233 add initial compact immutable collection implementations

2016-05-03 Thread Stuart Marks
Hi all, This is a reimplementation of collections created by the JEP 269 convenience factory methods. These implementations are overall quite a bit smaller than their conventional collections counterparts, particularly at small sizes. Lookup performance for the hash-based structures (Set and

Re: JDK 9 RFR of JDK-8154911: Move GCDuringIteration.java back to tier1

2016-05-03 Thread joe darcy
+1 Thanks, -Joe On 5/3/2016 7:30 PM, Martin Buchholz wrote: Looks good! Thanks for watching over our tests, and apologies for the years of flakiness! On Tue, May 3, 2016 at 6:24 PM, Amy Lu wrote: Please review. Thanks, Amy On 4/25/16 11:00 AM, Amy Lu wrote:

Re: JDK 9 RFR of JDK-8154911: Move GCDuringIteration.java back to tier1

2016-05-03 Thread Martin Buchholz
Looks good! Thanks for watching over our tests, and apologies for the years of flakiness! On Tue, May 3, 2016 at 6:24 PM, Amy Lu wrote: > Please review. > > Thanks, > Amy > > On 4/25/16 11:00 AM, Amy Lu wrote: >> >> java/util/WeakHashMap/GCDuringIteration.java >> >> This test

Re: JDK 9 RFR of JDK-8154911: Move GCDuringIteration.java back to tier1

2016-05-03 Thread Amy Lu
Please review. Thanks, Amy On 4/25/16 11:00 AM, Amy Lu wrote: java/util/WeakHashMap/GCDuringIteration.java This test was failing intermittently (JDK-6842353) and demoted to tier2. Mentioned issues have been resolved and no open bug (no failure reported) till now. This patch is to move the

Re: RFR 8147039 : Incorrect locals and operands in compiled frames

2016-05-03 Thread Mandy Chung
> On May 3, 2016, at 4:43 PM, Brent Christian > wrote: > > Hi, Mandy > >> On 05/03/2016 01:45 PM, Mandy Chung wrote: >> >> One minor nit: in stackwalk.cpp, the local variable “anchor” used in >> a couple places should also be renamed. You can fix that up before

Re: RFR (JAXP) 8152912: SAX XMLReaderFactory needs to be ServiceLoader compliant

2016-05-03 Thread huizhe wang
On 5/3/2016 3:36 AM, Daniel Fuchs wrote: Hi Joe, This look good but the implementation might be overly complex, which makes it difficult to read. It was basically the existing code with some cleanup. What's in jarLookup was a copy of the original code. As you can see I was eager to add

Re: RFR 8147039 : Incorrect locals and operands in compiled frames

2016-05-03 Thread Brent Christian
Hi, Mandy On 05/03/2016 01:45 PM, Mandy Chung wrote: One minor nit: in stackwalk.cpp, the local variable “anchor” used in a couple places should also be renamed. You can fix that up before you push (no need for a new webrev) Ah, looks like I missed JavaFrameStream::from_current(). Are you

Re: RFR: regex changes

2016-05-03 Thread Xueming Shen
Hi, This one has be out for review for a while. If there is no further comments and feedback the changes will be pushed in shortly. Thanks, Sherman On 3/18/16, 1:05 PM, Xueming Shen wrote: Hi, There are couple regex related changes waiting for review. I have pull them together here (with

Re: JDK 9 RFR of JDK-4943627 Deprecate rounding mode integer constants in BigDecimal and their uses

2016-05-03 Thread Joseph D. Darcy
Hi Brian, Pushed with updated copyright range; thanks, -Joe On 5/3/2016 3:22 PM, Brian Burkhalter wrote: Hi Joe, On Apr 30, 2016, at 8:24 PM, joe darcy > wrote: Please review the changes to address JDK-4943627 Deprecate rounding mode

Re: JDK 9 RFR of JDK-4943627 Deprecate rounding mode integer constants in BigDecimal and their uses

2016-05-03 Thread Brian Burkhalter
Hi Joe, On Apr 30, 2016, at 8:24 PM, joe darcy wrote: > Please review the changes to address > >JDK-4943627 Deprecate rounding mode integer constants in BigDecimal and > their uses > >http://cr.openjdk.java.net/~darcy/4943627.0/ > > Since JDK 5, the java.math

Re: RFR 8154049: DualPivot sorting calculates incorrect runs for nearly sorted arrays

2016-05-03 Thread Paul Sandoz
> On 3 May 2016, at 14:50, Aleksey Shipilev wrote: > > On 04/21/2016 04:24 PM, Paul Sandoz wrote: >> Please review: >> >> http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8154049-dual-pivot-sort-one-off-error/webrev/ > > Ew. It is a complete brain-twister to

Re: JDK 9 RFR of adding a few @jls tags to java.lang.String

2016-05-03 Thread Joseph D. Darcy
Hi David, On 5/2/2016 5:01 AM, David Holmes wrote: On 1/05/2016 5:34 AM, joe darcy wrote: Hello, Please review the small patch below to add some JLS references to the string class to supplement its textual discussion of a few sections of the JLS. Side question: what mechanism is there to

Original Bug ID: 8155514 -> Re: RFR: 8155600: jaxp.library.TestPolicy should extend the default security policy

2016-05-03 Thread huizhe wang
On 5/3/2016 9:42 AM, Mandy Chung wrote: On May 3, 2016, at 2:37 AM, Frank Yuan wrote: Hi Mandy and Joe I have re-fixed the bug with your comment, would you like to check again? http://cr.openjdk.java.net/~fyuan/8155514/webrev.01/ This patch extending the default

Re: RFR 8154049: DualPivot sorting calculates incorrect runs for nearly sorted arrays

2016-05-03 Thread Aleksey Shipilev
On 04/21/2016 04:24 PM, Paul Sandoz wrote: > Please review: > > http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8154049-dual-pivot-sort-one-off-error/webrev/ Ew. It is a complete brain-twister to understand the original code, the original improvement, the bug, and the fix -- all four! This is a

Re: RFR 8147039 : Incorrect locals and operands in compiled frames

2016-05-03 Thread Mandy Chung
> On May 3, 2016, at 12:00 PM, Brent Christian > wrote: > > Hi, > > Please review this change which fixes buggy behavior (including SEGV) in the > experimental LiveStackFrame feature of StackWalker. > > Bug: > https://bugs.openjdk.java.net/browse/JDK-8147039 >

Re: RFR: JDK-8150496,(zipfs) Fix performance issues in zip-fs

2016-05-03 Thread Xueming Shen
Hi Aleksey, Again, thanks for the review. The webrev has been updated accordingly, as well as the MyBenchmark.java (to use Blackhole, as suggested) http://cr.openjdk.java.net/~sherman/8150496/webrev/ http://cr.openjdk.java.net/~sherman/8150496/MyBenchmark.java -Sherman On 05/03/2016 05:39

Re: Review request: 8154190 & 8155513: Deprivilege java.compiler and jdk.charsets

2016-05-03 Thread Mandy Chung
> On Apr 29, 2016, at 11:25 PM, Alan Bateman wrote: > > On 30/04/2016 06:02, Mandy Chung wrote: >> JDK-8154190: Deprivilege java.compiler module >> Webrev: >>http://cr.openjdk.java.net/~mchung/jdk9/webrevs/8154190/webrev.00/ >> >> JDK-8155513: Deprivilege

Re: RFR 8155794 Move Objects.checkIndex BiFunction accepting methods to an internal package

2016-05-03 Thread Paul Sandoz
> On 3 May 2016, at 07:05, Remi Forax wrote: > > Looks good to me. > minor nitpick, neither checkFromToIndex() nor checkFromIndexSize() are > instrinsic (now !) but i think they also should be annotated with > @ForceInline in j.u.Objects to avoid the code to be asymmetric

Re: JDK 9 RFR of JDK-8155963: Fix deprecation warning in windows java.net implementation

2016-05-03 Thread Phil Race
+1 -phil. On 05/03/2016 12:14 PM, joe darcy wrote: Hello, Please review the patch below is address windows-specific code which was overlooked on the cleanup passes ahead of fixing JDK-6850612: Deprecate Class.newInstance since it violates the checked exception language contract. Thanks,

JDK 9 RFR of JDK-8155963: Fix deprecation warning in windows java.net implementation

2016-05-03 Thread joe darcy
Hello, Please review the patch below is address windows-specific code which was overlooked on the cleanup passes ahead of fixing JDK-6850612: Deprecate Class.newInstance since it violates the checked exception language contract. Thanks, -Joe diff -r 03453120a011

RFR 8147039 : Incorrect locals and operands in compiled frames

2016-05-03 Thread Brent Christian
Hi, Please review this change which fixes buggy behavior (including SEGV) in the experimental LiveStackFrame feature of StackWalker. Bug: https://bugs.openjdk.java.net/browse/JDK-8147039 Webrev: http://cr.openjdk.java.net/~bchristi/8147039/webrev.02/ As suggested in the bug report, stack

Re: RFR 8155258: VarHandle implementation improvements

2016-05-03 Thread Aleksey Shipilev
On 05/03/2016 09:35 PM, Paul Sandoz wrote: > http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8155258-vhs-impl-improvements-jdk/webrev/ > Okay then, looks good. -Aleksey

Re: RFR 8155258: VarHandle implementation improvements

2016-05-03 Thread Paul Sandoz
> On 3 May 2016, at 06:11, Aleksey Shipilev wrote: > > On 05/03/2016 01:18 AM, Paul Sandoz wrote: >> >> http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8155258-vhs-impl-improvements-jdk/webrev/ >> >>

Re: JEP 118 Parameter Names by default

2016-05-03 Thread Steven Schlansker
Hi Michael, Thanks for the link, this is exactly the explanation I was looking for. I am disappointed in the decision, but not exactly surprised. It really makes the feature less useful to have to go and educate every user that they must now pass special compiler flags, as well as ensure that

Re: RFR: 8155600: jaxp.library.TestPolicy should extend the default security policy

2016-05-03 Thread Mandy Chung
> On May 3, 2016, at 2:37 AM, Frank Yuan wrote: > > Hi Mandy and Joe > > I have re-fixed the bug with your comment, would you like to check again? > http://cr.openjdk.java.net/~fyuan/8155514/webrev.01/ > This patch extending the default security policy is a better

Re: RFR: 8155939: sun.launcher.LauncherHelper INSTANCE is unused

2016-05-03 Thread Claes Redestad
Thanks Roger! /Claes On 2016-05-03 16:56, Roger Riggs wrote: Looks fine, Roger On 5/3/2016 10:46 AM, Claes Redestad wrote: Hi, sun.launcher.LauncherHelper is currently a singleton enum class, but the INSTANCE is never used. With encapsulation in place we shouldn't worry about cleaning

Re: RFR:JDK-8079628:java.time: DateTimeFormatter containing "DD" fails on 3-digit day-of-year value

2016-05-03 Thread Stephen Colebourne
Letters "Q", "q", "M", "L", "d", "D", "F", "h", "H", "k", "K", "m", "s" and no doubt others use NORMAL via appendValue(field); Changing these to use NOT_NEGATIVE would be a big change and doesn't seem justified. For "D", "DD" and "DDD" these seem to be the best balance (as discussed

Re: RFR: JDK-8151914 java/util/jar/JarFile/MultiReleaseJar* tests do not declare module dependences

2016-05-03 Thread Chris Hegarty
On 2 May 2016, at 22:48, Steve Drach wrote: > Looks fine to me, +1. -Chris. > although I am not an official reviewer. Thanks for doing this. > >> On May 2, 2016, at 1:03 PM, Alexandre (Shura) Iline >> wrote: >> >> Hi, >> >> Can you

Re: RFR:JDK-8148949:DateTimeFormatter pattern letters 'A','n','N'

2016-05-03 Thread Stephen Colebourne
The current behaviour is to use NORMAL for "A" and NOT_NEGATIVE for "AA", "AAA" and so on. The sensible behaviour going forward is to use NOT_NEGATIVE for all these, simply because the values do not make sense to be negative. Given how these fields are nigh-on useless as currently defined, this

Re: RFR: 8151542: URL resources for multi-release jar files have a #runtime fragment appended to them

2016-05-03 Thread Alan Bateman
On 02/05/2016 17:23, Steve Drach wrote: Another webrev: http://cr.openjdk.java.net/~sdrach/8151542/webrev.05/index.html Only URLClassPath has changed. I put a comment on url.getProtocol indicating the URL assures it’s lower

Re: RFR: 8155939: sun.launcher.LauncherHelper INSTANCE is unused

2016-05-03 Thread Roger Riggs
Looks fine, Roger On 5/3/2016 10:46 AM, Claes Redestad wrote: Hi, sun.launcher.LauncherHelper is currently a singleton enum class, but the INSTANCE is never used. With encapsulation in place we shouldn't worry about cleaning this up. jdeps data show no usage of this helper class outside

RFR: 8155939: sun.launcher.LauncherHelper INSTANCE is unused

2016-05-03 Thread Claes Redestad
Hi, sun.launcher.LauncherHelper is currently a singleton enum class, but the INSTANCE is never used. With encapsulation in place we shouldn't worry about cleaning this up. jdeps data show no usage of this helper class outside of the JDK. Bug: https://bugs.openjdk.java.net/browse/JDK-8155939

Re: RFR:JDK-8148949:DateTimeFormatter pattern letters 'A','n','N'

2016-05-03 Thread Roger Riggs
Hi Nadeesh, src/java.base/share/classes/java/time/format/DateTimeFormatterBuilder:1522-1524 Is the switch from SignStyle.NOT_NEGATIVE to NORMAL intentional? The ValueRange of MilliOfDay for example is (0, 8640-1), so negative values would be out of range. Similarly, NanoOfSecond and

Re: RFR:JDK-8079628:java.time: DateTimeFormatter containing "DD" fails on 3-digit day-of-year value

2016-05-03 Thread Roger Riggs
Hi Nadeesh, On 5/3/2016 3:24 AM, nadeesh tv wrote: Hi Roger, Please see the answers inline On 5/3/2016 2:43 AM, Roger Riggs wrote: Hi Nadeesh, src/java.base/share/classes/java/time/format/DateTimeFormatterBuilder.java line 1835: the appendValue(field) method has a sign-style of NORMAL;

Re: RFR: 8152084: Introduction of ssliop protocol to corbaloc

2016-05-03 Thread Alan Bateman
On 03/05/2016 14:29, Andrew Dinn wrote: On 19/04/16 18:58, Tomasz Adamski wrote: Hello All, I would like to propose an extension to corbaloc resolution - the ssliop protocol. IORs created from corbaloc url with ssliop protocol will contain SSL tagged component with indication that secured

Re: RFR 8155794 Move Objects.checkIndex BiFunction accepting methods to an internal package

2016-05-03 Thread Remi Forax
Looks good to me. minor nitpick, neither checkFromToIndex() nor checkFromIndexSize() are instrinsic (now !) but i think they also should be annotated with @ForceInline in j.u.Objects to avoid the code to be asymmetric or weird if one of these methods is intrinsinfied later. Rémi - Mail

Re: RFR: 8152084: Introduction of ssliop protocol to corbaloc

2016-05-03 Thread Andrew Dinn
On 19/04/16 18:58, Tomasz Adamski wrote: > Hello All, > > I would like to propose an extension to corbaloc resolution - the > ssliop protocol. IORs created from corbaloc url with ssliop protocol > will contain SSL tagged component with indication that secured > invocation is required. As a

Re: RFR 8155258: VarHandle implementation improvements

2016-05-03 Thread Aleksey Shipilev
On 05/03/2016 01:18 AM, Paul Sandoz wrote: > > http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8155258-vhs-impl-improvements-jdk/webrev/ > > > >

Re: RFR 8147984: WindowsTerminal should support function keys

2016-05-03 Thread Florent Guillaume
Hi, http://www.x.org/docs/xterm/ctlseqs.pdf is probably a more canonical reference. Florent On Mon, May 2, 2016 at 8:31 PM, Stuart Marks wrote: > Hi Jan, > > Thanks for the update. Including the link is fine, but I'm a bit suspicious > of the durability of that

Re: RFR 8155794 Move Objects.checkIndex BiFunction accepting methods to an internal package

2016-05-03 Thread Aleksey Shipilev
On 05/03/2016 01:37 AM, Paul Sandoz wrote: > > http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8155794-checkIndex-bifunc-internal-jdk/webrev/ > > http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8155794-checkIndex-bifunc-internal-hotspot/webrev/ Both JDK and HS changes look good to me. It's

Re: RFR: JDK-8150496,(zipfs) Fix performance issues in zip-fs

2016-05-03 Thread Aleksey Shipilev
Hi Sherman, On 05/03/2016 02:28 AM, Xueming Shen wrote: > Please help review the performance cleanup for zipfs > > issue: https://bugs.openjdk.java.net/browse/JDK-8150496 > webrev: http://cr.openjdk.java.net/~sherman/8150496/webrev ZipFileSystem.java: *) These should be removed? 2032

Re: RFR (JAXP) 8152912: SAX XMLReaderFactory needs to be ServiceLoader compliant

2016-05-03 Thread Daniel Fuchs
Hi Joe, This look good but the implementation might be overly complex, which makes it difficult to read. First: 141 ClassLoader cl = ss.getContextClassLoader(); is misnamed, because as far as I can see this method returns the context class loader if not null, otherwise the system

Re: RFR 8155794 Move Objects.checkIndex BiFunction accepting methods to an internal package

2016-05-03 Thread Chris Hegarty
On 2 May 2016, at 23:37, Paul Sandoz wrote: > Hi, > > Please review: > > > http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8155794-checkIndex-bifunc-internal-jdk/webrev/ > >

RE: RFR: 8155600: jaxp.library.TestPolicy should extend the default security policy

2016-05-03 Thread Frank Yuan
Hi Mandy and Joe I have re-fixed the bug with your comment, would you like to check again? http://cr.openjdk.java.net/~fyuan/8155514/webrev.01/ Thanks, Frank > -Original Message- > From: Mandy Chung [mailto:mandy.ch...@oracle.com] > Sent: Friday, April 29, 2016 4:00 AM > To: Frank

Re: RFR:JDK-8079628:java.time: DateTimeFormatter containing "DD" fails on 3-digit day-of-year value

2016-05-03 Thread nadeesh tv
Hi Roger, Please see the answers inline On 5/3/2016 2:43 AM, Roger Riggs wrote: Hi Nadeesh, src/java.base/share/classes/java/time/format/DateTimeFormatterBuilder.java line 1835: the appendValue(field) method has a sign-style of NORMAL; should that be NOT_NEGATIVE? It's 'NOT_NEGATIVE'