Re: Feature suggestion: Add static equals methods to Float and Double

2019-01-04 Thread some-java-user-99206970363698485155
Hello Remi, You are right, the proposed method names would prevent backwards compatibility, I forgot to think about that. Sorry for the trouble. Maybe a different, currently not used name, such as `areEqual`, `primitiveEquals` or similar would be better. What do You think about the addition of

Re: Feature suggestion: Add static equals methods to Float and Double

2019-01-04 Thread Remi Forax
Hi, it's not obvious to me that this is a source backward compatible change. if you have something like: interface Fun { boolean eq(Double a, double b); } ... Fun fun = Double::equals; it's not clear to me which variant will be selected ? regards, Rémi - Mail original - > De: som

Feature suggestion: Provide efficient way for nullable value lookup in Map

2019-01-04 Thread some-java-user-99206970363698485155
The methods currently provided by the Map interface (https://docs.oracle.com/javase/8/docs/api/java/util/Map.html) do not provide an efficient way to look up nullable values. This problem would be solved if JDK-6552529 was implemented, but that will likely not be happening since the interface c

Feature suggestion: Add static equals methods to Float and Double

2019-01-04 Thread some-java-user-99206970363698485155
To test whether primitive float or double values are equal according to `Float.equals` and `Double.equals` you either have to create wrapper instances for them (possible performance decrease), use the respective static `compareTo` (verbose) or have to use the appropriate methods (`floatToIntBits

Feature suggestion: Allow generic wildcard in class literal expression

2019-01-04 Thread some-java-user-99206970363698485155
JDK-6184881 describes that Object.getClass() should ideally not return classes of raw types anymore but instead use wildcards. The problem is that, as noted in the comments, this breaks compability with previously written code and therefore this change is not very likely (at the moment?). Howev

Re: RFR: 8215412: Optimize PrintStream.println methods

2019-01-04 Thread Claes Redestad
On 2019-01-04 17:39, Claes Redestad wrote: I'll mull a bit about a succinct comment, but at least the version history will point to this RFE.. Lest I hear any objections, I'll push with this comment added to the two new writeln methods: // Used to optimize away back-to-back flushing and s

Re: RFR: 8215412: Optimize PrintStream.println methods

2019-01-04 Thread Roger Riggs
+1 Thanks On 01/04/2019 02:40 PM, Claes Redestad wrote: On 2019-01-04 17:39, Claes Redestad wrote: I'll mull a bit about a succinct comment, but at least the version history will point to this RFE.. Lest I hear any objections, I'll push with this comment added to the two new writeln metho

Re: RFR(JDK 13/java.xml) 8215330: javax.xml.catalog.CatalogResolverImpl: GroupEntry.matchURI fails to match

2019-01-04 Thread Joe Wang
Thanks Lance! The change is in now. -Joe On 1/3/19, 3:48 PM, Lance Andersen wrote: Hi Joe, The changes and test seem fine! Happy New Year On Jan 3, 2019, at 6:25 PM, Joe Wang > wrote: Hi, Please review a fix to the impl for the Catalog. The reporter was ri

Re: performance degradation in Array::newInstance on -XX:TieredStopAtLevel=1

2019-01-04 Thread Martin Buchholz
On Thu, Jan 3, 2019 at 11:26 PM Сергей Цыпанов wrote: > > I've run into this performance effect while investigating creation of > Spring's ConcurrentReferenceHashMap, > it turned out that it used Array::newInstance to create array of > References stored in a map's Segment: > Slight tangent - Con

Re: 8216134 (process) ProcessBuilder startPipeline does not hide piped streams

2019-01-04 Thread Roger Riggs
Thanks Brent, I will re-wrap L278 before pushing. On 01/04/2019 12:59 PM, Brent Christian wrote: Looks good. If you wanted to break up L278 in the test before pushing, I wouldn't complain. :) -Brent On 1/4/19 6:52 AM, Roger Riggs wrote: Hi Brent, Steve, Thanks for the review and correction

Re: 8216134 (process) ProcessBuilder startPipeline does not hide piped streams

2019-01-04 Thread Brent Christian
Looks good. If you wanted to break up L278 in the test before pushing, I wouldn't complain. :) -Brent On 1/4/19 6:52 AM, Roger Riggs wrote: Hi Brent, Steve, Thanks for the review and corrections for copyrights, removing debugging info, and input file contents. Updated Webrev:   http://cr

Re: [12] RFR: 8215303: Allowing additional currency code points from later Unicode updates

2019-01-04 Thread naoto . sato
Hi Chris, Yes. I just updated the CSR, adding the description in the compatibility risk: https://bugs.openjdk.java.net/browse/JDK-8215305 Naoto On 1/4/19 9:18 AM, Chris Hegarty wrote: Thanks Naoto. On 4 Jan 2019, at 17:10, naoto.s...@oracle.com wrote: Hi Chris, Yes, it will affect the b

Re: [12] RFR: 8215303: Allowing additional currency code points from later Unicode updates

2019-01-04 Thread naoto . sato
Hi Rachna, Updated: http://cr.openjdk.java.net/~naoto/8215303/webrev.01/ Naoto On 1/4/19 2:24 AM, Rachna Goel wrote: Hi Naoto, just one nit, copyright year need to be updated in Character.java. Thanks, Rachna On 1/3/19 10:26 PM, Naoto Sato wrote: Hello, Please review the fix to the foll

Re: RFR: 8182992 Typo in DatagramPacket constructor API doc

2019-01-04 Thread Roger Calnan
>> - * suitable for retrieving large{@code LONGVARCHAR}values. The JDBC >> driver will >> + * suitable for retrieving large{@code LONGVARCHAR} values. The JDBC >> driver will > Needs a space after large indeed, I looked for other examples and found a couple more. I’ll file a

Re: [12] RFR: 8215303: Allowing additional currency code points from later Unicode updates

2019-01-04 Thread Chris Hegarty
Thanks Naoto. > On 4 Jan 2019, at 17:10, naoto.s...@oracle.com wrote: > > Hi Chris, > > Yes, it will affect the behavior of those methods. This has been discussed > within the JLS folks, and their understanding was that the risk is minimal > and OK to proceed. I was not involved in the discuss

Re: [13] RFR 8215913: [Test_bug]java/util/Locale/LocaleProvidersRun.java failed on de_DE and ja_JP locale.

2019-01-04 Thread naoto . sato
+1 Naoto On 1/4/19 7:21 AM, Roger Riggs wrote: +1 On 01/04/2019 04:44 AM, Rachna Goel wrote: Hi Dora, Kindly update copyright years in both files and add bug id in LocaleProvidersRun.java. Other than that, it looks good to me. Thanks, Rachna On 1/4/19 7:58 AM, Dora Zhou wrote: Hello,

Re: [12] RFR: 8215303: Allowing additional currency code points from later Unicode updates

2019-01-04 Thread naoto . sato
Hi Chris, Yes, it will affect the behavior of those methods. This has been discussed within the JLS folks, and their understanding was that the risk is minimal and OK to proceed. I was not involved in the discussion, but here are the reasons I can think of. - The Currency Symbols range is ve

Re: 8215798: [javadoc] Use {@systemProperty} for org.openjdk.java.util.stream.tripwire system property

2019-01-04 Thread Lance Andersen
+1 > On Jan 4, 2019, at 11:18 AM, Roger Riggs wrote: > > Please review using @systemProperty to refer to the > org.openjdk.java.util.stream.tripwire > system property. > > > diff --git a/src/java.base/share/classes/java/util/Spliterator.java > b/src/java.base/share/classes/java/util/Spliterat

Re: RFR: 8215412: Optimize PrintStream.println methods

2019-01-04 Thread Claes Redestad
On 2019-01-04 16:55, Roger Riggs wrote: Oops, missed a revision. Looks good, Thanks! > though the reader may puzzle a while about why. I'll mull a bit about a succinct comment, but at least the version history will point to this RFE.. /Claes

Re: RFR: 8215412: Optimize PrintStream.println methods

2019-01-04 Thread Claes Redestad
On 2019-01-04 16:46, fo...@univ-mlv.fr wrote: The perf diff is more that what i was expected :) Looks good to me ! Thanks! /Claes

8215798: [javadoc] Use {@systemProperty} for org.openjdk.java.util.stream.tripwire system property

2019-01-04 Thread Roger Riggs
Please review using @systemProperty to refer to the org.openjdk.java.util.stream.tripwire system property. diff --git a/src/java.base/share/classes/java/util/Spliterator.java b/src/java.base/share/classes/java/util/Spliterator.java --- a/src/java.base/share/classes/java/util/Spliterator.java

Re: Class.getDeclaredMethods() is returning inherited methods

2019-01-04 Thread Roger Riggs
Hi David, Its worth considering and so I reset the issue so it would be re-triaged and assigned for an appropriate person to consider. Roger On 01/03/2019 05:58 PM, David Holmes wrote: Hi Roger, On 4/01/2019 12:22 am, Roger Riggs wrote: Hi, With a link to the explanation added to the issue

Re: RFR: 8215412: Optimize PrintStream.println methods

2019-01-04 Thread Roger Riggs
Oops, missed a revision. Looks good, though the reader may puzzle a while about why. Thanks, Roger On 01/04/2019 10:44 AM, Remi Forax wrote: Hi Roger, the field has disappear in the latest webrev. Rémi - Mail original - De: "Roger Riggs" À: "Claes Redestad" , "core-libs-dev" Envo

Re: RFR: 8215412: Optimize PrintStream.println methods

2019-01-04 Thread forax
The perf diff is more that what i was expected :) Looks good to me ! Rémi - Mail original - > De: "Claes Redestad" > À: "Remi Forax" > Cc: "core-libs-dev" > Envoyé: Mercredi 2 Janvier 2019 21:32:09 > Objet: Re: RFR: 8215412: Optimize PrintStream.println methods > Hi again, > > as e

Re: RFR: 8215412: Optimize PrintStream.println methods

2019-01-04 Thread Remi Forax
Hi Roger, the field has disappear in the latest webrev. Rémi - Mail original - > De: "Roger Riggs" > À: "Claes Redestad" , "core-libs-dev" > > Envoyé: Vendredi 4 Janvier 2019 16:38:06 > Objet: Re: RFR: 8215412: Optimize PrintStream.println methods > Hi Claes, > > The logic looks fine

Re: RFR: 8215412: Optimize PrintStream.println methods

2019-01-04 Thread Roger Riggs
Hi Claes, The logic looks fine, but the 'internal' field name doesn't mean anything and there's no description of the optimization. The field could be renamed:  noOverride or notOverridden or noDoubleSync or ... or add a comment to the field describing its purpose. Update copyright date on Pr

Re: [13] RFR 8215913: [Test_bug]java/util/Locale/LocaleProvidersRun.java failed on de_DE and ja_JP locale.

2019-01-04 Thread Roger Riggs
+1 On 01/04/2019 04:44 AM, Rachna Goel wrote: Hi Dora, Kindly update copyright years in both files and add bug id in LocaleProvidersRun.java. Other than that, it looks good to me. Thanks, Rachna On 1/4/19 7:58 AM, Dora Zhou wrote: Hello, Please help review the fix for the test bug jav

Re: 8216134 (process) ProcessBuilder startPipeline does not hide piped streams

2019-01-04 Thread Roger Riggs
Hi Brent, Steve, Thanks for the review and corrections for copyrights, removing debugging info, and input file contents. Updated Webrev:   http://cr.openjdk.java.net/~rriggs/webrev-pipeline-8211844-2/ Regards, Roger On 01/04/2019 06:03 AM, Steve Groeger wrote: Roger, Looks OK. One small p

Re: [12] RFR: 8215303: Allowing additional currency code points from later Unicode updates

2019-01-04 Thread Chris Hegarty
On 1/3/19 10:26 PM, Naoto Sato wrote: > Hello, > > Please review the fix to the following issue (and its approved CSR): > > https://bugs.openjdk.java.net/browse/JDK-8215303 > https://bugs.openjdk.java.net/browse/JDK-8215305 > > The proposed changeset is located at: > > http://cr.openjdk.java

Re: 8216134 (process) ProcessBuilder startPipeline does not hide piped streams

2019-01-04 Thread Steve Groeger
Roger, Looks OK. One small point, I know it is only a test but do you need the extra System.out.printf statements, they look as though they might have been just for debugging. No issues if they stay in there just wondering if it was a oversight in removing them. Also, need to have the copy

Re: [12] RFR: 8215303: Allowing additional currency code points from later Unicode updates

2019-01-04 Thread Nishit Jain
Changes looks fine to me. Regards, Nishit Jain On 03-01-2019 22:26, Naoto Sato wrote: Hello, Please review the fix to the following issue (and its approved CSR): https://bugs.openjdk.java.net/browse/JDK-8215303 https://bugs.openjdk.java.net/browse/JDK-8215305 The proposed changeset is located

Re: [12] RFR: 8215303: Allowing additional currency code points from later Unicode updates

2019-01-04 Thread Rachna Goel
Hi Naoto, just one nit, copyright year need to be updated in Character.java. Thanks, Rachna On 1/3/19 10:26 PM, Naoto Sato wrote: Hello, Please review the fix to the following issue (and its approved CSR): https://bugs.openjdk.java.net/browse/JDK-8215303 https://bugs.openjdk.java.net/brows

Re: [12] RFR: 8215303: Allowing additional currency code points from later Unicode updates

2019-01-04 Thread Rachna Goel
Hi Naoto, Your fix looks good to me. Thanks, Rachna On 1/3/19 10:26 PM, Naoto Sato wrote: Hello, Please review the fix to the following issue (and its approved CSR): https://bugs.openjdk.java.net/browse/JDK-8215303 https://bugs.openjdk.java.net/browse/JDK-8215305 The proposed changeset is

Re: performance degradation in Array::newInstance on -XX:TieredStopAtLevel=1

2019-01-04 Thread Claes Redestad
Hi, I've also taken a look at your microbenchmark and seen a few regressions from 9 through 12, some of which I've identified - and some that might be (partially) actionable. Mostly related to recent additions of low overhead heap sampling and allocator/GC changes. All of the blame is in hotspot,

Re: [13] RFR 8215913: [Test_bug]java/util/Locale/LocaleProvidersRun.java failed on de_DE and ja_JP locale.

2019-01-04 Thread Rachna Goel
Hi Dora, Kindly update copyright years in both files and add bug id in LocaleProvidersRun.java. Other than that, it looks good to me. Thanks, Rachna On 1/4/19 7:58 AM, Dora Zhou wrote: Hello, Please help review the fix for the test bug java/util/Locale/LocaleProvidersRun.java failed on