RFR(JDK 13/java.xml) 8222743: Xerces 2.12.0: DOM Implementation

2019-04-19 Thread Joe Wang
Please review an update to xerces/dom. Details are as described in the JBS. XML related tests and JCK passed. JBS: https://bugs.openjdk.java.net/browse/JDK-8222743 webrev: http://cr.openjdk.java.net/~joehw/jdk13/8222743/webrev/ Thanks, Joe

Re: [PATCH] 4511638: Double.toString(double) sometimes produces incorrect results

2019-04-19 Thread Raffaello Giulietti
Hi, the semantics of java.io.IOError is: "Thrown when a serious I/O error has occurred" which I guess is not appropriate here. I think the best compromise is 880 try { 881 FloatToDecimal.appendTo(f, this); 882 } catch (IOException cause) { 883 throw new AssertionError("Code shall be un

Re: RFR: JDK-8219683,,Modify App Image layout on Mac

2019-04-19 Thread Phil Race
+1 Only thing I have to say is that in the test JPackagePath I liked the esier to read formatting you didhere at lines 184-185 and you could have done something similar at lines 159-161 + + File.separator + "Contents" + + File.separator + "runtime" + + File.separator + "Contents" + + File.separa

Re: RFR: JDK-8219683,,Modify App Image layout on Mac

2019-04-19 Thread Kevin Rushforth
Looks good. -- Kevin On 4/19/2019 9:32 AM, Andy Herrick wrote: Please review the jpackage fix for bug [1] at [2]. This is a fix for the JDK-8200758-branch branch of the open sandbox repository (jpackage). [1] https://bugs.openjdk.java.net/browse/JDK-8219683 [2] http://cr.openjdk.java.net/

Re: [PATCH] 4511638: Double.toString(double) sometimes produces incorrect results

2019-04-19 Thread Jason Mehrens
Maybe rename the catch variable from 'cause' or 'ignored' to 'unreachable' and then wrap java.io.IOException in java.io.IOError? From: core-libs-dev on behalf of Raffaello Giulietti Sent: Thursday, April 18, 2019 3:37 PM To: Brian Burkhalter; core-libs-

RFR: JDK-8219683,,Modify App Image layout on Mac

2019-04-19 Thread Andy Herrick
Please review the jpackage fix for bug [1] at [2]. This is a fix for the JDK-8200758-branch branch of the open sandbox repository (jpackage). [1] https://bugs.openjdk.java.net/browse/JDK-8219683 [2] http://cr.openjdk.java.net/~herrick/8219683/ /Andy

Re: [13] Review Request: 8220134 Cleanup the code in java.base which take care about multiple AppContext

2019-04-19 Thread Daniel Fuchs
On 19/04/2019 16:46, Alan Bateman wrote: On 18/04/2019 23:41, Sergey Bylokhov wrote: Hello. Please review the fix for JDK 13. Bug: https://bugs.openjdk.java.net/browse/JDK-8220134 Fix: http://cr.openjdk.java.net/~serb/8220134/webrev.00 The AppContext class was used as a kind of "sandbox" in ca

Re: [13] Review Request: 8220134 Cleanup the code in java.base which take care about multiple AppContext

2019-04-19 Thread Alan Bateman
On 18/04/2019 23:41, Sergey Bylokhov wrote: Hello. Please review the fix for JDK 13. Bug: https://bugs.openjdk.java.net/browse/JDK-8220134 Fix: http://cr.openjdk.java.net/~serb/8220134/webrev.00 The AppContext class was used as a kind of "sandbox" in case of applets/webstart. Both applets and