RE: RFR: 8224560: (tz) Upgrade time-zone data to tzdata2019a and 8225580: tzdata2018i integration causes test failures on jdk-13

2019-07-08 Thread Ramanand Patil
Hi Andrew, Thank you for your review. Updated webrev: http://cr.openjdk.java.net/~rpatil/8224560/webrev.01/ Regards, Ramanand. > -Original Message- > From: Andrew John Hughes > Sent: Saturday, July 6, 2019 9:53 PM > To: Ramanand Patil ; core-libs- > d...@openjdk.java.net; i18n-...@openjd

Re: Inputs on patch for JDK-8225763? Inflater and Deflater should implement AutoCloseable

2019-07-08 Thread Lance Andersen
Hi Jaikiran, Thank you for your efforts here. > On Jul 6, 2019, at 9:59 AM, Jaikiran Pai wrote: > >> >> - Idempotency >> >> Yes, it looks to me like Inflater.end() and Deflater.end() >> implementations are idempotent. As you point out, overrides by >> subclasses might not be. We should be cl

Re: RFR: 8224560: (tz) Upgrade time-zone data to tzdata2019a and 8225580: tzdata2018i integration causes test failures on jdk-13

2019-07-08 Thread naoto . sato
Hi Ramanand, As to the change in ZoneInfoFile.java, I would put that special handling of Gaza/Hebron in line 577, as well as merging the comment in 575,576, so that it won't duplicate the code. Otherwise looks good. Naoto On 7/8/19 3:35 AM, Ramanand Patil wrote: Hi Andrew, Thank you for yo

8193072: File.delete() should remove its path from DeleteOnExitHook.files

2019-07-08 Thread Brian Burkhalter
https://bugs.openjdk.java.net/browse/JDK-8193072 There does appear to be a memory leak of sorts if one does something like — File[] files; for (int i = 0; i < largeNumber; i++) { files[i] = File.createTempFile(“blah”, null); files[i].de

Re: 8193072: File.delete() should remove its path from DeleteOnExitHook.files

2019-07-08 Thread Lance Andersen
Looks OK brian and does not seem to require any update to runHooks() so all good for me :-) > On Jul 8, 2019, at 4:11 PM, Brian Burkhalter > wrote: > > https://bugs.openjdk.java.net/browse/JDK-8193072 > > > There does appear to be a memory

Re: 8193072: File.delete() should remove its path from DeleteOnExitHook.files

2019-07-08 Thread Ivan Gerasimov
Hi Brian! I believe this would introduce a behavior change in a scenario lile: File f = ...; f.deleteOnExit(); f.delete(); f.createNewFile(); I.e. when the with the same name is recreated.  Current behavior is to unlink such a file before exiting, no matter if it were explicitly deleted and th

Re: 8193072: File.delete() should remove its path from DeleteOnExitHook.files

2019-07-08 Thread Jason Mehrens
Brian, Previously File.delete wouldn't throw IllegalStateException and with this patch it looks like that is possible (and not desirable). I would think that this change could the break java.util.logging.FileHandler because Handler.close runs in a shutdown hook. Jason ___

Re: 8193072: File.delete() should remove its path from DeleteOnExitHook.files

2019-07-08 Thread Brian Burkhalter
Ivan / Jason, Thanks for the good observations. > On Jul 8, 2019, at 1:35 PM, Ivan Gerasimov wrote: > > I believe this would introduce a behavior change in a scenario lile: > File f = ...; > f.deleteOnExit(); > f.delete(); > f.createNewFile(); > > I.e. when the with the same name is recreated.

[13] RFR: 8227127: Era designator not displayed correctly using the COMPAT provider

2019-07-08 Thread naoto . sato
Hello, Please review the fix to the following issue: https://bugs.openjdk.java.net/browse/JDK-8227127 The proposed changeset is located at: https://cr.openjdk.java.net/~naoto/8227127/webrev.00/ This is a regression caused by the fix to 8039301, where era display names are correctly retrieved

Re: EnumSet.class serialization broken - twice - JDK-8227368

2019-07-08 Thread Stuart Marks
Hi Peter, Thanks for picking this up, for filing the bug (JDK-8227368), and developing the fix. For the current release, I think we should go ahead and put in the "right" fix, that is, to define serialVersionUID the conventional way -- as a compile-time constant -- and then simply to remove