Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread Phil Race
On Sun, 6 Sep 2020 13:57:19 GMT, Dmitriy Dumanskiy wrote: > **isEmpty** is faster + has less byte code + easier to read. Benchmarks could > be found > > [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416). 1) This is un-necessary churn. 2) I can't

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread Jonathan Gibbons
On Thu, 10 Sep 2020 12:04:48 GMT, Dmitriy Dumanskiy wrote: > I have in mind dozens of improvements all over the code like this one. That sounds scary. Broad updates like these cause unnecessary churn in the codebase, and can make merging and back porting harder. Changes should be discussed ah

Re: [PATCH] Allocate uninitialized byte[] to improve performance of String-related operations

2020-09-10 Thread Сергей Цыпанов
Hi Paul, thanks for looking into this! > The update to AbstractStringBuilder is problematic because the uninitialized > array could potentially be accessed through reflection. > > In other cases it seems you have slotted in the allocation at a low-level > e.g. StringUTF16.newBytesFor. That make

Coordinated Restore at Checkpoint: A new project for start-up optimization?

2020-09-10 Thread Gil Tene
Hello, We would like to open a discussion about a new project focused on "Coordinated Restore at Checkpoint". A possible relevant project name might be Tubthumpting [9]. Over the years, we [at Azul] have tinkered with various ways to improve java start-up time and warmup behavior for different u

Re: RFR: 8138732: Rename @HotSpotIntrinsicCandidate to @IntrinsicCandidate and move it to the jdk.internal.vm.annotation package [v2]

2020-09-10 Thread Paul Sandoz
On Wed, 9 Sep 2020 09:49:44 GMT, Philippe Marschall wrote: >> Hello, newbie here >> >> I picked JDK-8138732 to work on because it has a "starter" label and I >> believe I understand what to do. >> >> - I tried to update the copyright year to 2020 in every file. >> - I decided to change `@sinc

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread Jorn Vernee
On Thu, 10 Sep 2020 15:50:39 GMT, Alan Bateman wrote: >> 14 cc'd mailing lists is unworkable. You need to be subscribed to lists to >> post, but even if you are a reply-all will >> be delayed due to all of the mails being held up for moderator approval due >> to: >> " Too many recipients to the

Re: RFR: 8242451: ensure semantics of non-capturing lambdas are preserved independent of execution mode [v2]

2020-09-10 Thread Mandy Chung
On Thu, 10 Sep 2020 15:23:14 GMT, Gilles Duboscq wrote: >> [JDK-8232806](https://bugs.openjdk.java.net/browse/JDK-8232806) introduced >> the >> jdk.internal.lambda.disableEagerInitialization system property to be able to >> disable eager initialization of lambda >> classes. This was necessary t

Re: RFR: 8251495: Clarify DOM documentation

2020-09-10 Thread Joe Wang
On Thu, 10 Sep 2020 16:16:57 GMT, Joe Wang wrote: >> Marked as reviewed by alanb (Reviewer). > > Remove the implNote from the package description added by JDK-8249643. > The implementation's deviation from the specification was actually wrong. > It incorrectly identified characters from #x1 t

Re: RFR: 8251495: Clarify DOM documentation

2020-09-10 Thread Joe Wang
On Thu, 10 Sep 2020 05:45:59 GMT, Alan Bateman wrote: >> Revert changes made by JDK-8249643, removing the implNote. > > Marked as reviewed by alanb (Reviewer). Remove the implNote from the package description added by JDK-8249643. The implementation's deviation from the specification was actuall

Integrated: 8252919: JDK built with --enable-cds=no fails with NoClassDefFoundError

2020-09-10 Thread Mandy Chung
On Wed, 9 Sep 2020 19:38:38 GMT, Mandy Chung wrote: > `jlink --generate-jli-classes` plugin should retain the original holder > classes if the default_jli_trace.txt > file does not exist. > > Before JDK-8252725, `JavaLangInvokeAccess::generateXXXHolderClassesBytes` > methods are invoked > unco

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread Alan Bateman
On Thu, 10 Sep 2020 13:53:10 GMT, David Holmes wrote: >> @dholmes-ora raises a good point. Hopefully there is a balance point between >> a dozen different bugs / pull requests >> each targeting one area and one bug / PR targeting a dozen separate areas. I >> don't have a good general rule to su

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread David Holmes
On 10/09/2020 10:07 pm, Dmitriy Dumanskiy wrote: On Thu, 10 Sep 2020 11:21:28 GMT, David Holmes wrote: The code in java.base was updated to use String::isEmpty in JDK 12 (JDK-8215281). There was follow-up in JDK 13 to do the same in the java.desktop module (JDK-8223237). Changing the remainin

Re: RFR: 8242451: ensure semantics of non-capturing lambdas are preserved independent of execution mode [v2]

2020-09-10 Thread Gilles Duboscq
On Thu, 10 Sep 2020 11:50:04 GMT, Gilles Duboscq wrote: >> It's a good suggestion as `disableEagerInitialization` support is not part >> of javac. > > OK makes sense. I guess it's still good to clean the test comments of the old > `disableEagerInitialization` references? I have created a new t

Re: RFR: 8242451: ensure semantics of non-capturing lambdas are preserved independent of execution mode [v2]

2020-09-10 Thread Gilles Duboscq
> [JDK-8232806](https://bugs.openjdk.java.net/browse/JDK-8232806) introduced the > jdk.internal.lambda.disableEagerInitialization system property to be able to > disable eager initialization of lambda > classes. This was necessary to prevent side effects of class initializers > triggered by such

Re: RFR: 8242451: ensure semantics of non-capturing lambdas are preserved independent of execution mode [v2]

2020-09-10 Thread Gilles Duboscq
On Wed, 9 Sep 2020 16:36:43 GMT, Mandy Chung wrote: >> Gilles Duboscq has updated the pull request incrementally with three >> additional commits since the last revision: >> >> - Remove extra field test from LambdaTest6 >> - Wrap long lines >> - Add deciated test in the jdk tests > > src/jav

Integrated: 8252830: Correct missing javadoc comments in java.rmi module

2020-09-10 Thread Roger Riggs
On Tue, 8 Sep 2020 15:19:40 GMT, Roger Riggs wrote: > 8252830: Correct missing javadoc comments in java.rmi module This pull request has now been integrated. Changeset: 418e4a25 Author:Roger Riggs URL: https://git.openjdk.java.net/jdk/commit/418e4a25 Stats: 39 lines in 4 files ch

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread David Holmes
On Thu, 10 Sep 2020 12:18:51 GMT, Kevin Rushforth wrote: >> This should be broken up to deal with the files in different functional >> areas under different bugids and PRs. Otherwise >> the cross-posting to so many lists is prohibitive. Files in different areas >> need to be reviewed by differe

Re: RFR: 8229186: Improve error messages for TestStringIntrinsics failures

2020-09-10 Thread Evgeny Nikitin
On Thu, 10 Sep 2020 12:20:05 GMT, Evgeny Nikitin wrote: > pre-Skara RFR thread: > [link](https://mail.openjdk.java.net/pipermail/hotspot-compiler-dev/2020-May/038416.html) > > Error reporting was improved by writing a C-style escaped string > representations for the variables passed to the > m

RFR: 8229186: Improve error messages for TestStringIntrinsics failures

2020-09-10 Thread Evgeny Nikitin
pre-Skara RFR thread: [link](https://mail.openjdk.java.net/pipermail/hotspot-compiler-dev/2020-May/038416.html) Error reporting was improved by writing a C-style escaped string representations for the variables passed to the methods being tested. For array comparisons, a dedicated diff-formatter

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread Kevin Rushforth
On Thu, 10 Sep 2020 11:21:28 GMT, David Holmes wrote: >> The code in java.base was updated to use String::isEmpty in JDK 12 >> (JDK-8215281). There was follow-up in JDK 13 to do >> the same in the java.desktop module (JDK-8223237). Changing the remaining >> usages make sense although I see that

Re: RFR: 8252919: JDK built with --enable-cds=no fails with NoClassDefFoundError

2020-09-10 Thread Claes Redestad
On Wed, 9 Sep 2020 19:38:38 GMT, Mandy Chung wrote: > `jlink --generate-jli-classes` plugin should retain the original holder > classes if the default_jli_trace.txt > file does not exist. > > Before JDK-8252725, `JavaLangInvokeAccess::generateXXXHolderClassesBytes` > methods are invoked > unco

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread Dmitriy Dumanskiy
On Thu, 10 Sep 2020 11:21:28 GMT, David Holmes wrote: >> The code in java.base was updated to use String::isEmpty in JDK 12 >> (JDK-8215281). There was follow-up in JDK 13 to do >> the same in the java.desktop module (JDK-8223237). Changing the remaining >> usages make sense although I see that

Re: RFR: 8242451: ensure semantics of non-capturing lambdas are preserved independent of execution mode

2020-09-10 Thread Gilles Duboscq
On Wed, 9 Sep 2020 16:39:25 GMT, Mandy Chung wrote: >> test/langtools/tools/javac/lambda/lambdaExpression/LambdaTest6.java line 29: >> >>> 27: * @summary Add lambda tests >>> 28: * Test bridge methods for certain SAM conversions >>> 29: * Test the set of generate fields >> >> I would sug

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread David Holmes
On Thu, 10 Sep 2020 10:40:15 GMT, Alan Bateman wrote: >> @kevinrushforth thanks. Done. >> >> Similar issues: >> https://bugs.java.com/bugdatabase/view_bug.do?bug_id=8215014 >> https://bugs.java.com/bugdatabase/view_bug.do?bug_id=8251246 >> https://bugs.java.com/bugdatabase/view_bug.do?bug_id=822

Re: JDK-8252803: Add the /LARGEADDRESSAWARE flag when linking executables for Windows 32-bit.

2020-09-10 Thread Alan Bateman
On 10/09/2020 10:44, Archana Nogriya wrote: Hi, I am requesting a proposal for the contribution to OpenJDK. I have created webrev with my changes. Moving to build-dev as that is normally where the linker options are discussed. I don't know if there is a significant need for Windows 32-bit bu

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-10 Thread Alan Bateman
On Thu, 10 Sep 2020 08:47:35 GMT, Dmitriy Dumanskiy wrote: >> Before this Enhancement can be formally reviewed, you will need a JBS bug >> ID. If you are already working with a >> Committer or Reviewer in the `jdk` project who has agreed to sponsor your >> change, they can file the Enhancement

Re: RFR: 8252919: JDK built with --enable-cds=no fails with NoClassDefFoundError

2020-09-10 Thread Alan Bateman
On Wed, 9 Sep 2020 19:38:38 GMT, Mandy Chung wrote: > `jlink --generate-jli-classes` plugin should retain the original holder > classes if the default_jli_trace.txt > file does not exist. > > Before JDK-8252725, `JavaLangInvokeAccess::generateXXXHolderClassesBytes` > methods are invoked > unco

JDK-8252803: Add the /LARGEADDRESSAWARE flag when linking executables for Windows 32-bit.

2020-09-10 Thread Archana Nogriya
Hi, I am requesting a proposal for the contribution to OpenJDK. I have created webrev with my changes. Please can I have someone to review my changes and suggest further. Details description is as follow, == Title : Add the /LARGEADDRESSAWARE fl

JDK-8252802 - Performance optimization by setting MALLOCOPTIONS and LDR_CNTRL java launcher in order to use 64KB pages by default for perf on AIX.

2020-09-10 Thread Archana Nogriya
Hi, I am requesting a proposal for the contribution to OpenJDK. I have created webrev with my changes. Please can I have someone to review my changes and suggest further. Details description is as follow, === Title : Performance optimization by setting MALL

Re: RFR: 8252999: replace all String.equals("") usages with String.isEmpty()

2020-09-10 Thread Dmitriy Dumanskiy
On Wed, 9 Sep 2020 20:21:44 GMT, Kevin Rushforth wrote: >> @mrserb hello. Thanks for the review. Any further actions required from me? > > Before this Enhancement can be formally reviewed, you will need a JBS bug ID. > If you are already working with a > Committer or Reviewer in the `jdk` projec

Re: RFR: 8252999: replace all String.equals("") usages with String.isEmpty()

2020-09-10 Thread Kevin Rushforth
On Wed, 9 Sep 2020 07:57:48 GMT, Dmitriy Dumanskiy wrote: >> @doom369 jcheck requires an associated issue > > @mrserb hello. Thanks for the review. Any further actions required from me? Before this Enhancement can be formally reviewed, you will need a JBS bug ID. If you are already working wit

Re: RFR: 8252999: replace all String.equals("") usages with String.isEmpty()

2020-09-10 Thread Sergey Bylokhov
On Sun, 6 Sep 2020 13:57:19 GMT, Dmitriy Dumanskiy wrote: > **isEmpty** is faster + has less byte code + easier to read. Benchmarks could > be found > > [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416). src/demo/share/java2d/J2DBench/src/j2dben

Re: RFR: 8252999: replace all String.equals("") usages with String.isEmpty()

2020-09-10 Thread Dmitriy Dumanskiy
On Sun, 6 Sep 2020 18:08:15 GMT, thatsIch wrote: >> **isEmpty** is faster + has less byte code + easier to read. Benchmarks >> could be found >> >> [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416). > > @doom369 jcheck requires an associated issu

RFR: 8252999: replace all String.equals("") usages with String.isEmpty()

2020-09-10 Thread Dmitriy Dumanskiy
**isEmpty** is faster + has less byte code + easier to read. Benchmarks could be found [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416). - Commit messages: - Merge branch 'master' of https://github.com/doom369/jdk into reaplce_equal

Re: RFR: 8252999: replace all String.equals("") usages with String.isEmpty()

2020-09-10 Thread thatsIch
On Sun, 6 Sep 2020 13:57:19 GMT, Dmitriy Dumanskiy wrote: > **isEmpty** is faster + has less byte code + easier to read. Benchmarks could > be found > > [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416). @doom369 jcheck requires an associated is

Re: RFR 8252537: Replace @exception with @throws for core-libs

2020-09-10 Thread Pavel Rappo
> On 4 Sep 2020, at 21:32, Vipin Sharma wrote: > > > I have generated Javadoc for all updated packages and compared html files, > before and after changes. Since effects can be nonlocal (e.g. {@inheritDoc}), you should always compare everything. >> There are ~ 1.5K lines, 86 files changed in

Re: RFR: 8138732: Rename @HotSpotIntrinsicCandidate to @IntrinsicCandidate and move it to the jdk.internal.vm.annotation package [v2]

2020-09-10 Thread Alan Bateman
On Wed, 9 Sep 2020 09:49:44 GMT, Philippe Marschall wrote: >> Hello, newbie here >> >> I picked JDK-8138732 to work on because it has a "starter" label and I >> believe I understand what to do. >> >> - I tried to update the copyright year to 2020 in every file. >> - I decided to change `@sinc