Re: RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-17 Thread Daniel Fuchs
On 17/06/16 14:57, Pavel Rappo wrote: Roger, On 17 Jun 2016, at 14:14, Roger Riggs wrote: Subclassing is the normal (one) way to override/augment behavior of an existing class. And I was looking for a minimal change since there have been many issues in this area. Also, I avoided the extra o

Re: RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-17 Thread Roger Riggs
Hi Pavel, @Override added. Thanks, Roger On 6/17/2016 9:57 AM, Pavel Rappo wrote: Roger, On 17 Jun 2016, at 14:14, Roger Riggs wrote: Subclassing is the normal (one) way to override/augment behavior of an existing class. And I was looking for a minimal change since there have been many is

Re: RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-17 Thread Roger Riggs
Hi Daniel, Webrev updated in place. http://cr.openjdk.java.net/~rriggs/webrev-skip-8155808/index.html On 6/17/2016 9:41 AM, Daniel Fuchs wrote: Hi Roger, Should PipeInputStream be final? It is extended by DeferredCloseInputStream, used on Solaris, and is private to the implementation so bei

Re: RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-17 Thread Pavel Rappo
Roger, > On 17 Jun 2016, at 14:14, Roger Riggs wrote: > > Subclassing is the normal (one) way to override/augment behavior of an > existing class. > And I was looking for a minimal change since there have been many issues in > this area. > Also, I avoided the extra object and performance overh

Re: RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-17 Thread Daniel Fuchs
Hi Roger, Should PipeInputStream be final? If so I guess you could remove the first part of the sentence in the @exception clause (should that be @throws?): 655 * @exception IOException if the stream does not support seek, 656 * or if some other

Re: RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-17 Thread Roger Riggs
Hi Pavel, On 6/17/2016 5:03 AM, Pavel Rappo wrote: Hi Roger, Do we need PipeInputStream to be a java.io.FileInputStream? Can we get away with it being an InputStream? If so, then we could use a simple delegation which would allow us to avoid code duplication (the implementation of `skip` is alm

Re: RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-17 Thread Pavel Rappo
Hi Roger, Do we need PipeInputStream to be a java.io.FileInputStream? Can we get away with it being an InputStream? If so, then we could use a simple delegation which would allow us to avoid code duplication (the implementation of `skip` is almost identical to one in InputStream): private sta

Re: RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-16 Thread Roger Riggs
Ping? On 6/13/2016 11:06 AM, Roger Riggs wrote: A latent issue with Process InputStreams support for the skip method was reported[1]. Though the InputStream returned is a BufferedInputStream, in some cases, the skip method calls FileInputStream.seek on the pipe containing output from the proc

RFR 9: 8155808: Process.getInputStream().skip() method is faulty

2016-06-13 Thread Roger Riggs
A latent issue with Process InputStreams support for the skip method was reported[1]. Though the InputStream returned is a BufferedInputStream, in some cases, the skip method calls FileInputStream.seek on the pipe containing output from the process but the pipes do not support seek. The propose