Re: RFR: 8282036: [Test]: Update java/util/zip/ZipFile/DeleteTempJar.java to stop HttpServer cleanly in case of exceptions

2022-06-26 Thread Jaikiran Pai
On Mon, 27 Jun 2022 04:50:09 GMT, Thejasvi Voniadka wrote: > This is a simple change to add some protective code to > java/util/zip/ZipFile/DeleteTempJar.java so that the clean-up is more > complete in the event of encountering an any exceptions while running. In the > present state, the

RFR: 8282036: [Test]: Update java/util/zip/ZipFile/DeleteTempJar.java to stop HttpServer cleanly in case of exceptions

2022-06-26 Thread Thejasvi Voniadka
This is a simple change to add some protective code to java/util/zip/ZipFile/DeleteTempJar.java so that the clean-up is more complete in the event of encountering an any exceptions while running. In the present state, the server.stop() does not get executed in case of encountering a failure.

Re: RFR: 8289079: java/lang/Thread/jni/AttachCurrentThread/AttachTest.java#id1 failed with "RuntimeException: Test failed"

2022-06-26 Thread David Holmes
On Sun, 26 Jun 2022 09:50:11 GMT, Alan Bateman wrote: > This is a fix to a recently added test. The test uses pthread_create to > create native threads that invoke a Java method via a generated "upcall > stub". The upcall stub is created in an implicit memory session but the test > doesn't do

Re: RFR: JDK-8266670: Better modeling of access flags in core reflection [v35]

2022-06-26 Thread Alan Bateman
On Sat, 25 Jun 2022 19:08:48 GMT, Joe Darcy wrote: >> This is an early review of changes to better model JVM access flags, that is >> "modifiers" like public, protected, etc. but explicitly at a VM level. >> >> Language level modifiers and JVM level access flags are closely related, but >>

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v3]

2022-06-26 Thread Lance Andersen
> Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A readAttributesIfExists(Path > path, Class type, LinkOption...

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v2]

2022-06-26 Thread Lance Andersen
On Sun, 26 Jun 2022 13:13:35 GMT, Alan Bateman wrote: > The implementation changes in latest version address my previous points, > thanks! I don't the test as it duplicates most of the existing of the > TestProvider in this directory and the naming is inconsistent with the > existing tests. I

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v2]

2022-06-26 Thread Alan Bateman
On Sun, 26 Jun 2022 11:13:58 GMT, Lance Andersen wrote: >> Hi, >> >> Please review the following patch which will: >> >> - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include >> the methods >> >> - public boolean exists(Path path, LinkOption... options) >> - public

Re: RFR: 8283335 : Add exists and readAttributesIfExists methods to FileSystemProvider [v2]

2022-06-26 Thread Lance Andersen
> Hi, > > Please review the following patch which will: > > - Enhance the java.nio.file.spi.FileSystemProvider abstract class to include > the methods > > - public boolean exists(Path path, LinkOption... options) > - public A readAttributesIfExists(Path > path, Class type, LinkOption...

RFR: 8289079: java/lang/Thread/jni/AttachCurrentThread/AttachTest.java#id1 failed with "RuntimeException: Test failed"

2022-06-26 Thread Alan Bateman
This is a fix to a recently added test. The test uses pthread_create to create native threads that invoke a Java method via a generated "upcall stub". The upcall stub is created in an implicit memory session but the test doesn't do anything to ensure that the memory session remains open.

Re: RFR: JDK-8288746: HttpClient resources could be reclaimed more eagerly

2022-06-26 Thread Jaikiran Pai
On Mon, 20 Jun 2022 14:09:27 GMT, Daniel Fuchs wrote: > Hi, > > Please find here a patch that should help the HttpClient's SelectorManager > thread to terminate more timely, allowing the resources consumed by the > client to be released earlier. > > The idea is to use a Cleaner registered