Withdrawn: 8321637: Simplify if statement in ArraysSupport::hugeLength

2023-12-18 Thread John Jiang
On Sat, 9 Dec 2023 23:19:52 GMT, John Jiang wrote: > It looks the `else-if` and `else` clauses in method > `ArraysSupport::hugeLength` could be simplified by `Math::max`. This pull request has been closed without being integrated. - PR: https://git.openjdk.org/jdk/pull/17043

Re: RFR: 8321637: Simplify if statement in ArraysSupport::hugeLength

2023-12-18 Thread John Jiang
On Tue, 19 Dec 2023 03:44:26 GMT, Stuart Marks wrote: >> It looks the `else-if` and `else` clauses in method >> `ArraysSupport::hugeLength` could be simplified by `Math::max`. > > This change would make the code shorter, but in my opinion, it obscures > what's going on. This code tries to be

Re: RFR: 8321637: Simplify if statement in ArraysSupport::hugeLength

2023-12-18 Thread John Jiang
On Sat, 9 Dec 2023 23:19:52 GMT, John Jiang wrote: > It looks the `else-if` and `else` clauses in method > `ArraysSupport::hugeLength` could be simplified by `Math::max`. Could this simple PR be reviewed? - PR Comment: https://git.openjdk.org/jdk/pull/17043#issuec

Re: RFR: 8321637: Simplify if statement in ArraysSupport::hugeLength

2023-12-10 Thread John Jiang
On Sun, 10 Dec 2023 03:57:00 GMT, Jie Fu wrote: >> It looks the `else-if` and `else` clauses in method >> `ArraysSupport::hugeLength` could be simplified by `Math::max`. > > The JBS should be an enhancement, not a bug, right? @DamonFool > The JBS should be an enhancement, not a bug, right?

RFR: 8321637: Simplify if statement in ArraysSupport::hugeLength

2023-12-09 Thread John Jiang
It looks the `else-if` and `else` clauses in method `ArraysSupport::hugeLength` could be simplified by `Math::max`. - Commit messages: - 8321637: Simplify if statement in ArraysSupport::hugeLength Changes: https://git.openjdk.org/jdk/pull/17043/files Webrev:

Re: RFR: 8313612: Use JUnit in lib-test/jdk tests

2023-08-15 Thread John Jiang
On Wed, 2 Aug 2023 23:25:13 GMT, Qing Xiao wrote: > Modified all tests under lib-test/jdk to use JUnit test/lib-test/jdk/test/lib/format/ArrayDiffTest.java line 2: > 1: /* > 2: * Copyright (c) 2020, 2021, 2023, Oracle and/or its affiliates. All > rights reserved. Should it just modify the

Integrated: 8313231: Redundant if statement in ZoneInfoFile

2023-07-31 Thread John Jiang
On Thu, 27 Jul 2023 06:46:46 GMT, John Jiang wrote: > if (i < savingsInstantTransitions.length) { > // javazic writes the last GMT offset into index 0! > if (i < savingsInstantTransitions.length) { > offsets[0] = standardOffsets[standardOffsets.

Re: RFR: 8313231: Redundant if statement in ZoneInfoFile

2023-07-31 Thread John Jiang
On Mon, 31 Jul 2023 07:11:24 GMT, Stephen Colebourne wrote: >> if (i < savingsInstantTransitions.length) { >> // javazic writes the last GMT offset into index 0! >> if (i < savingsInstantTransitions.length) { >> offsets[0] = standardOffsets[standardOffsets.length - 1] * 1000; >>

RFR: 8313231: Redundant if statement in ZoneInfoFile

2023-07-27 Thread John Jiang
if (i < savingsInstantTransitions.length) { // javazic writes the last GMT offset into index 0! if (i < savingsInstantTransitions.length) { offsets[0] = standardOffsets[standardOffsets.length - 1] * 1000; nOffsets = 1; } ... } The second if statement looks

Re: RFR: 8311178: JMH tests don't scale well when sharing output buffers

2023-07-10 Thread John Jiang
On Sat, 1 Jul 2023 07:53:17 GMT, Swati Sharma wrote: > The below benchmark files have scaling issues due to cache contention and > leads to poor scaling when run on multiple threads. The patch sets the scope > from benchmark level to thread level to fix the issue: > -